FAQ

On Tue, Sep 05, 2006 at 06:28:37PM -0700, jpease@jesush.com wrote:
Hi, I'm having troubles trying to upgrade the DBI module in Perl. When I
do the following (as root):

/usr/bin/perl -MCPAN -e 'install "DBI"'

it downloads the new module, builds everything, and then starts running
the make test portion of the install. During this process, I get the
following output (after a bunch of other successful tests):

t/zvpp_72childhandles....NOK 3# Failed test (t/72childhandles.t at line 43)
The test for weak reference support doesn't work properly with early
version of perl 5.8.x. (Fixed for the next DBI release.)
I really have no idea how to proceed from this point. Any ideas?
Since that's the only failure and, I presume you don't want to use both
the ChildHandle attribute and DBI::PurePerl, you can go ahead and
force the installation (using "force install DBI" in the cpan shell).

Tim.

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 9 of 9 | next ›
Discussion Overview
groupdbi-users @
categoriesperl
postedSep 6, '06 at 1:34a
activeSep 18, '06 at 8:14a
posts9
users5
websitedbi.perl.org

People

Translate

site design / logo © 2021 Grokbase