FAQ

"Greg Sabino Mullane" writes:
PostgreSQL version: 80215 (default port: 5432) ...
/usr/local/GP-4.2.4.0/include/libpq-fe.h:533: error:
previous declaration of 'lo_import_with_oid' was here
Something is very wrong here. Version 8.2 (old and unsupported,
FWIW) had no concept of lo_import_with_oid, so you have a
more modern libpq-fe header file there, which will cause
all sorts of problems beyond the function at hand.
He is using a postgres fork (something called 'Greenplum' aka
'GP'). This documents itself as

  Greenplum Database is based on PostgreSQL 8.2 with a few
  features added in from the 8.3 release.

and when the libpq-fe.he which came with this database has the
prototype for lo_import_with_oid, chances are that the corresponding
library has it as well (nm -D ... | grep lo_import could be used to
check this).

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 4 | next ›
Discussion Overview
groupdbd-pg @
categoriesperl
postedAug 28, '13 at 7:56p
activeAug 31, '13 at 3:01p
posts4
users3
websiteperl.org

People

Translate

site design / logo © 2022 Grokbase