X-Died: Can't locate HTML/HeadParser.pm in @INC (you may need to install
the HTML::HeadParser module) (@INC contains:
[snip]
Does anyone know where HTML::HeadParser is used? How should we fix?
What's in the X-Died that you snipped? It should give a file/line
indicating what was trying to use HTML::HeadParser.

On Fri, Oct 9, 2015 at 5:33 PM, James E Keenan wrote:
On 10/09/2015 03:09 AM, Slaven Rezic wrote:

James E Keenan <jkeen@verizon.net> writes:

Is it still the case that one can only submit reports to cpantesters
if one is running a mail server on the machine running the smoker?
No. The default Metabase setup requires just a working network
connection via HTTPS/SSL (*). Looking at the error below it seems that
LWP::Protocol::https does not work at all on your system. Maybe a
certificate issue? Or incompatible SSL modules installed on your system?
Can you check if something like

lwp-request -mHEAD https://www.google.com

works?
Slaven to the rescue once again!

Here's what I got on my first pass:

##########
$ lwp-request -mHEAD https://www.google.com
200 OK
Cache-Control: private, max-age=0
Connection: close
Date: Fri, 09 Oct 2015 23:19:58 GMT
Accept-Ranges: none
Server: gws
Vary: Accept-Encoding
Content-Type: text/html; charset=ISO-8859-1
Expires: -1
Client-Aborted: die
Client-Date: Fri, 09 Oct 2015 23:20:00 GMT
Client-Peer: 63.117.14.251:443
Client-Response-Num: 1
Client-SSL-Cert-Issuer: /C=US/O=Google Inc/CN=Google Internet Authority G2
Client-SSL-Cert-Subject: /C=US/ST=California/L=Mountain View/O=Google
Inc/CN=google.com
Client-SSL-Cipher: ECDHE-RSA-AES128-SHA
Client-SSL-Socket-Class: IO::Socket::SSL
P3P: CP="This is not a P3P policy! See
http://www.google.com/support/accounts/bin/answer.py?hl=en&answer=151657
for more info."
Set-Cookie:
PREF=ID=1111111111111111:FF=0:TM=1444432798:LM=1444432798:V=1:S=eUKMokQBpfnFC_yd;
expires=Thu, 31-Dec-2015 16:02:17 GMT; path=/; domain=.google.com
Set-Cookie:
NID=72=DdL67AYckgbavJLieae9AH1OYOh45Ank6AkC8R2iVQ2tKHM61Npp9j0UsOtRpPthIrOUD9YtJeOWofZeJttoN_hh_IPXOpjixsCRuKonmak4CO9NUi4Ug_21bYZSIf4MC2Sl4-aiPZlvtCxzFFBvmAW2UOviZf9J;
expires=Sat, 09-Apr-2016 23:19:58 GMT; path=/; domain=.google.com;
HttpOnly
X-Died: Can't locate HTML/HeadParser.pm in @INC (you may need to install
the HTML::HeadParser module) (@INC contains:
[snip]
#########

Once I installed HTML::HeadParser, my CPANtesters set up started
functioning as intended. I did 'force test NNN' on about 6 CPAN distros,
and was pleasantly surprised to see reports on both the libraries tested
and their prequisites in the tail.log.

So somewhere in the large stack of libraries used in the CPAN::Reporter
version of report filing, there is an unsatisfied prerequisite:
HTML::HeadParser. Who knows? This may have been why I was unable to get
CPAN testing going eight years ago!

Does anyone know where HTML::HeadParser is used? How should we fix?

Thank you very much.

Jim Keenan
Jim Keenan

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 6 of 10 | next ›
Discussion Overview
groupcpan-testers-discuss @
categoriesperl
postedOct 9, '15 at 12:16a
activeOct 12, '15 at 1:30p
posts10
users6
websitecpan.org

People

Translate

site design / logo © 2021 Grokbase