hi Alexandr,

These test reports, all from perl 5.12.3, seem to indicate that 'configure
requires' prerequisites haven't been satisfied. Module::Build::Tiny 0.035
does properly declare a dependency on Test::Harness::Env, but it hasn't
been satisfied on your smoker:

https://metacpan.org/source/LEONT/Module-Build-Tiny-0.035/META.json#L36

http://www.cpantesters.org/cpan/report/d43ceee7-6bfa-1014-b91b-937de356f3d8
http://www.cpantesters.org/cpan/report/c63ef688-6bfa-1014-8cdb-f376e356f3d8
http://www.cpantesters.org/cpan/report/78ce09b4-6bff-1014-aad4-c38ce356f3d8
http://www.cpantesters.org/cpan/report/3fa1f244-6bf9-1014-8877-0b73e356f3d8

This might be due to an old CPAN.pm on your smoker. If so, I would suggest
updating it to the latest version.


(Other testers: should we put a minimum bar on the acceptable version of
CPAN.pm/CPANPLUS for smoking, if we know that earlier versions are
guaranteed to produce bad results? I've thought about adding a check right
in Makefile.PL for the version of the cpan client (for information purposes
only - that wouldn't affect the outcome of the build) -- what versions
should I be looking for?)


Karen Etheridge
ether@cpan.org

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 22 | next ›
Discussion Overview
groupcpan-testers-discuss @
categoriesperl
postedApr 22, '14 at 12:51a
activeApr 23, '14 at 10:25p
posts22
users8
websitecpan.org

People

Translate

site design / logo © 2021 Grokbase