Hi Karen,

I've checked the install this morning and couldn't see anything
obviously wrong apart from an outdated CPAN on that server. The issue
could well have been in the install of Module::ExtractUse as this was
showing as being installed but when used would produce the
Parse::RecDescent error as noted in the report.

Having upgraded to CPAN v2.00 and re-installed Module::ExtractUse the
issue seems to have cleared. The smoker is running fine at present and
getting dependencies as required - I'm going to keep an eye on it during
the day to see how it performs with other modules.

Thanks,
Graham

On 05/02/2014 05:33, Karen Etheridge wrote:
Hi Graham,

Regarding this test report:
http://www.cpantesters.org/cpan/report/0218d752-8d0d-11e3-a4ba-87efbe8737eb

It appears you have Parse::RecDescent 1.967003 installed, but one of the
dependencies of the distribution being tested is Module::ExtractUse, which
declares a dependency on Parse::RecDescent 1.967009.

https://metacpan.org/source/DOMM/Module-ExtractUse-0.30/META.json#L31

Is your CPAN client properly detecting and processing distribution dependency
information?

cheers,

Karen Etheridge
ether@cpan.org

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 2 | next ›
Discussion Overview
groupcpan-testers-discuss @
categoriesperl
postedFeb 5, '14 at 5:33a
activeFeb 6, '14 at 10:09a
posts2
users2
websitecpan.org

People

Translate

site design / logo © 2021 Grokbase