FAQ
Hi everyone,

Iḿ new on this list, so please forgive me if i'm asking something already
discussed. (Found nothing in the archives, though)

For this project we're doing, we try to build qt 4.0.1 with embedded
mysql-support. The qt-part is no problem, but mysql 5.0.15 won't let me build
a shared library for libmysqld. Very strange.

According to the documentation, I have to give:

./configure --with-embedded-server --enable-shared=yes

but no lib is being build... make even errors on the libmysqld/examples
directory ('no rules to make target')

I even tried (In my despair) a line like :

./configure --with-embedded-server --enable-shared=yes --enable-static=no

but this gives me an error also:

then mv -f ".deps/liboptions_a-priv.Tpo" ".deps/liboptions_a-priv.Po"; else rm
-f ".deps/liboptions_a-priv.Tpo"; exit 1; fi
make[3]: *** No rule to make target `../../libmysql/get_password.o', needed by
`liboptions.a'. Stop.
make[3]: Leaving directory
`/home/pgroen/projects/mysql-5.0.15/server-tools/instance-manager'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/pgroen/projects/mysql-5.0.15/server-tools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/pgroen/projects/mysql-5.0.15'
make: *** [all] Error 2


I'm quite desperate at the moment because our first demo is due next week....

What am I doing wrong?

Regards,

Peter

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 3 | next ›
Discussion Overview
groupmysql @
categoriesmysql
postedNov 10, '05 at 10:23a
activeNov 10, '05 at 10:48a
posts3
users2
websitemysql.com
irc#mysql

2 users in discussion

Peter M. Groen: 2 posts Bruce Martin: 1 post

People

Translate

site design / logo © 2022 Grokbase