FAQ
Ryan,

I solved the problem by adding the helper modules to the new Controller I
created.

*Should these helper methods be added to Spree::BaseController?*

module Spree
   class Spree::WizardsController < Spree::BaseController

     # helper methods that are located in the spree layout view code
     #
     helper Spree::StoreHelper
     helper Spree::BaseHelper
     include Spree::Core::ControllerHelpers::Order

     # ... controller actions ...
end


Gemfile and gemspec,

#######################################################
## Gemfile

source 'https://rubygems.org'

gem 'spree', github: 'spree/spree', branch: '2-0-stable'
# Provides basic authentication functionality for testing parts of your
engine
gem 'spree_auth_devise', github: 'spree/spree_auth_devise', branch:
'2-0-stable'

gemspec


#######################################################
## my_spree_extension.gemspec

# encoding: UTF-8
Gem::Specification.new do |s|
   s.platform = Gem::Platform::RUBY
   s.name = 'spree_product_selection_wizard'
   s.version = '2.0.0'
   s.summary = 'Wizard step through to select products'
   s.description = 'Flexible Spree::Admin defined wizard step through
process to select product groups'
   s.required_ruby_version = '>= 1.9.3'

   s.author = 'weston platter'
   s.email = 'westonplatter@gmail.com'
   s.homepage = 'http://westonplatter.com'

   s.files = `git ls-files`.split("\n")
   s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
   s.require_path = 'lib'
   s.requirements << 'none'

   s.add_dependency 'spree_core', '~> 2.0.0'

   s.add_development_dependency 'capybara', '~> 2.1'
   s.add_development_dependency 'coffee-rails'
   s.add_development_dependency 'database_cleaner'
   s.add_development_dependency 'factory_girl', '~> 4.2'
   s.add_development_dependency 'ffaker'
   s.add_development_dependency 'rspec-rails', '~> 2.13'
   s.add_development_dependency 'sass-rails'
   s.add_development_dependency 'selenium-webdriver'
   s.add_development_dependency 'simplecov'
   s.add_development_dependency 'sqlite3'
   s.add_development_dependency 'shoulda'
end



*Weston Platter | **westonplatter@gmail.com | google voice** - 408.657.8090*

On Tue, Jul 2, 2013 at 8:31 PM, Ryan Bigg wrote:

Weston:

What's your Gemfile look like? That could really help us in fixing this
problem.

On Wed, Jul 3, 2013 at 4:39 AM, Weston Platter wrote:

@sancho - i've got the same issue. How did you fix this?

On Saturday, June 1, 2013 10:03:23 AM UTC-6, sancho wrote:

The only that I have just was an empty Rails app + spree +
spree_auth_devise + gem 'spree_email_to_friend'

gem 'spree', github: 'spree/spree', branch: '2-0-stable'
gem 'spree_auth_devise', github: 'spree/spree_auth_devise', branch:
'2-0-stable'

When i send a mail throw product show,

undefined method `store_menu?' for #<#<Class:0xb9e4bb0>:**0xb9e2860>

1: <header id="header" class="row" data-hook>
2: <figure id="logo" class="columns six" data-hook><%= logo %></figure>
3: <%= render :partial => 'spree/shared/nav_bar' %>
4: <%= render :partial => 'spree/shared/main_nav_bar' if store_menu? %>
5: </header>

Thanks,
Sancho

--

Ryan Bigg
Community Manager
Spree Commerce, Inc.

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 3 | next ›
Discussion Overview
groupspree-user @
categoriesrubyonrails
postedJul 2, '13 at 6:39p
activeJul 3, '13 at 3:07p
posts3
users2
websitespreecommerce.com
irc#RubyOnRails

2 users in discussion

Weston Platter: 2 posts Ryan Bigg: 1 post

People

Translate

site design / logo © 2022 Grokbase