I don't want to say we'll never support SSL, but it seems like a bit
of a stretch. The Selenium server itself doesn't bind to an SSL
socket, so there's never been a need for the clients to support it.
So, you have the proverbial chicken and egg problem. Since you really
should only be using Selenium server on secured networks to begin
with, I don't see much incentive to add the additional overhead of SSL
on the server side. And without the server support, it's hard to
justify the work in the clients supporting it.

--
Kevin
On Wed, May 30, 2012 at 4:25 PM, Steve Zaluk wrote:
Ok, thanks.  We also use the Grid for our iPhone and Android web
tests.  Is there anything I can do to get that working?

Do we ever plan on supporting HTTPS in the future?

Thanks for the help,
Steve
On Tue, May 29, 2012 at 8:28 PM, Kevin Menard wrote:
Oh, gotcha.  I'm pretty sure it just doesn't speak HTTPS.  I'll
double-check, but if you need something today, your best bet is
probably to use stunnel or SSH port forwarding to relay HTTP over a
secure channel.

--
Kevin
On Tue, May 29, 2012 at 2:59 PM, Steve Zaluk wrote:
Yes.  I can still register them using the defaults,
http://servername:4444/.....   The issue seems that when I do specify
https, it gets converted to http and a -1 is added as the port number.

On Tue, May 29, 2012 at 2:56 PM, Santiago Suarez Ordoñez
wrote:
Hm, does registering over http actually work? Probably Kevin or Francois are
the ones to answer here.

Santi


On Sun, May 27, 2012 at 4:33 AM, Steve Zaluk wrote:

We are seeing an issue when we are running the Grid with default
options and using a ProxyPass directive in Apache to route it through
HTTPS.  When we try to register the nodes, we are using the following:

java -jar selenium-server-standalone-2.19.0.jar -role node -hub https:/
servername/grid/register -browser
browserName=firefox,version=10,maxInstances=5,platform=WINDOWS

This is the output we are seeing when the nodes try to register:

17:51:11.803 INFO - starting auto register thread. Will try to
register every 5000 ms.
17:51:11.803 INFO - Registering the node to hub :http://servername:-1/
grid/register
17:51:11.974 INFO - couldn't register this node : Error sending the
registration request.

Any idea why the URL is being converted from https to http and a -1 is
being inserted as the port number?  We are using Selenium 2.19.

Thanks,
Steve

--
You received this message because you are subscribed to the Google Groups
"Selenium Developers" group.
To post to this group, send email to selenium-developers@googlegroups.com.
To unsubscribe from this group, send email to
selenium-developers+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/selenium-developers?hl=en.
--
You received this message because you are subscribed to the Google Groups
"Selenium Developers" group.
To post to this group, send email to selenium-developers@googlegroups.com.
To unsubscribe from this group, send email to
selenium-developers+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/selenium-developers?hl=en.
--
You received this message because you are subscribed to the Google Groups "Selenium Developers" group.
To post to this group, send email to selenium-developers@googlegroups.com.
To unsubscribe from this group, send email to selenium-developers+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/selenium-developers?hl=en.
--
You received this message because you are subscribed to the Google Groups "Selenium Developers" group.
To post to this group, send email to selenium-developers@googlegroups.com.
To unsubscribe from this group, send email to selenium-developers+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/selenium-developers?hl=en.
--
You received this message because you are subscribed to the Google Groups "Selenium Developers" group.
To post to this group, send email to selenium-developers@googlegroups.com.
To unsubscribe from this group, send email to selenium-developers+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/selenium-developers?hl=en.
--
You received this message because you are subscribed to the Google Groups "Selenium Developers" group.
To post to this group, send email to selenium-developers@googlegroups.com.
To unsubscribe from this group, send email to selenium-developers+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/selenium-developers?hl=en.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 9 of 10 | next ›
Discussion Overview
groupselenium-developers @
categoriesselenium
postedMay 27, '12 at 4:01p
activeJun 7, '12 at 9:32p
posts10
users3
websiteseleniumhq.org

People

Translate

site design / logo © 2021 Grokbase