On Sat, Oct 31, 2015 at 8:16 AM, Arto Lohi wrote:

I got error message "You don't have write permissions for the
/Library/Ruby/Gems/2.0.0 directory." when I tried install Rails to my Mac
using command line command "gem install rails". I have admin rights on my
machine.
If you're using the system Ruby, then you'll need to install gems with
`sudo`.

Most people use rvm or rbenv to avoid this (as well as enabling the
installation of multiple versions of Ruby and associated gems).

HTH,
--
Hassan Schroeder ------------------------ hassan.schroeder@gmail.com
http://about.me/hassanschroeder
twitter: @hassan
Consulting Availability : Silicon Valley or remote

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CACmC4yCSAYKiJ3U_46ByJL-jEAwVcWQNgDj6dhzHOdH33%3D8_8A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 2 | next ›
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 31, '15 at 5:39p
activeOct 31, '15 at 9:18p
posts2
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Hassan Schroeder: 1 post Arto Lohi: 1 post

People

Translate

site design / logo © 2021 Grokbase