After adding "gem 'rack', github: ''rack/rack'" to example repo below, I
get this when I run "bundle" command:

Bundler could not find compatible versions for gem "rack":
   In Gemfile:
     rails (>= 0) ruby depends on
       actionpack (= 5.0.0.alpha) ruby depends on
         rack (~> 1.6) ruby

     rack (>= 0) ruby

It appears that we need both rack (2.x) and rack (1.6).

On Friday, August 21, 2015 at 12:09:38 PM UTC-4, Al Snow wrote:

I have 5 Rails 5 "canery apps' that in the past run bundle cleanly, but
yesterday things changed.

I have two repos (rt_demo_app5, rt_first_app5) that have run bundle
cleanly (after adding rack

master to Gemfile) and 3 that do not (hello_app5, toy_app5,
sample_app_5_0_rt) even after

adding the rack master to Gemfile.

For the ones that do not run bundle cleanly, the error message is (before
adding rack master to Gemfile):

Bundler could not find compatible versions for gem "rack":
In Gemfile:
rails (>= 0) ruby depends on
actionpack (= 5.0.0.alpha) ruby depends on
rack (~> 2.x) ruby
Could not find gem 'rack (~> 2.x) ruby', which is required by
gem 'actionpack (= 5.0.0.alpha) ruby', in any of the sources.

Example Public repo:


I checked and latest rack is at 1.6.4 so unclear how to get

*So how do I change my Gemfile to find "rack 2.x"?*



You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
To post to this group, send email to
To view this discussion on the web visit
For more options, visit

Search Discussions

Discussion Posts


Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 5 | next ›
Discussion Overview
grouprubyonrails-talk @
postedAug 21, '15 at 4:09p
activeAug 21, '15 at 8:28p

2 users in discussion

Al Snow: 4 posts Hassan Schroeder: 1 post



site design / logo © 2022 Grokbase