Thank you so much for the reply. The below is the top portion of the
production.log.
It shows 500 Internal Server Error at the 5th line from the top. I don't
understand the cause of the error because
hardly anything has changed since the time before the boot. I would be
every so grateful if you would could suggest any potential solutions.


Connecting to database specified by database.yml
Connecting to database specified by database.yml
Started GET "/teaser" for 153.120.196.200 at 2013-07-11 17:26:20 +0900
Processing by StaticPagesController#register as HTML
Completed 500 Internal Server Error in 109ms

ActiveRecord::StatementInvalid (PG::Error: ERROR: relation "registers"
does not exist
LINE 5: WHERE a.attrelid = '"registers"'::regclass
                                         ^
: SELECT a.attname, format_type(a.atttypid, a.atttypmod),
                      pg_get_expr(d.adbin, d.adrelid), a.attnotnull,
a.atttypid, a.atttypmod
               FROM pg_attribute a LEFT JOIN pg_attrdef d
                 ON a.attrelid = d.adrelid AND a.attnum = d.adnum
              WHERE a.attrelid = '"registers"'::regclass
                AND a.attnum > 0 AND NOT a.attisdropped
              ORDER BY a.attnum
):
   app/controllers/static_pages_controller.rb:16:in `new'
   app/controllers/static_pages_controller.rb:16:in `register'


Started GET "/teaser" for 153.120.196.200 at 2013-07-11 17:26:22 +0900
Processing by StaticPagesController#register as HTML
Completed 500 Internal Server Error in 113ms

ActiveRecord::StatementInvalid (PG::Error: ERROR: relation "registers"
does not exist
LINE 5: WHERE a.attrelid = '"registers"'::regclass
                                         ^
: SELECT a.attname, format_type(a.atttypid, a.atttypmod),
                      pg_get_expr(d.adbin, d.adrelid), a.attnotnull,
a.atttypid, a.atttypmod
               FROM pg_attribute a LEFT JOIN pg_attrdef d
                 ON a.attrelid = d.adrelid AND a.attnum = d.adnum
              WHERE a.attrelid = '"registers"'::regclass
                AND a.attnum > 0 AND NOT a.attisdropped
              ORDER BY a.attnum
):
   app/controllers/static_pages_controller.rb:16:in `new'
   app/controllers/static_pages_controller.rb:16:in `register'


Started GET "/teaser" for 153.120.196.200 at 2013-07-11 17:26:23 +0900
Processing by StaticPagesController#register as HTML
Completed 500 Internal Server Error in 1ms

ActiveRecord::StatementInvalid (PG::Error: ERROR: relation "registers"
does not exist
LINE 5: WHERE a.attrelid = '"registers"'::regclass
                                         ^
: SELECT a.attname, format_type(a.atttypid, a.atttypmod),
                      pg_get_expr(d.adbin, d.adrelid), a.attnotnull,
a.atttypid, a.atttypmod
               FROM pg_attribute a LEFT JOIN pg_attrdef d
                 ON a.attrelid = d.adrelid AND a.attnum = d.adnum
              WHERE a.attrelid = '"registers"'::regclass
                AND a.attnum > 0 AND NOT a.attisdropped
              ORDER BY a.attnum
):
   app/controllers/static_pages_controller.rb:16:in `new'
   app/controllers/static_pages_controller.rb:16:in `register'

On Thursday, 17 April 2014 23:28:45 UTC+9, Frederick Cheung wrote:


On Thursday, April 17, 2014 3:25:38 PM UTC+1, Ead wrote:

Hello everyone

I am desperately in need of help because a website created by Ruby on
Rails has gone down after remotely rebooting a VPS server.
The site is this: http://offeriland.com/

I could not let update reflect in the site, so I rebooted the site using
the web host's remote VPS control system. The site now only displays ' We're
sorry, but something went wrong.'
I have searched across the web for a solution with no luck.
This isn't solvable without more information. The first step would for you
to take a look at the logfiles for the application (by default this will be
in log/production.log in the folder where the rails app is checked out).
This should have more information about the error. For example perhaps one
of the services on the server didn't start up when you restarted the server.

Fred
--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/b7a4f0b6-0b38-44da-9317-1d1109a050fa%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 17 | next ›
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedApr 17, '14 at 2:26p
activeApr 18, '14 at 2:04a
posts17
users6
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase