On 23 October 2013 15:53, RVic wrote:

Could you please not top post, it makes it difficult to follow the
thread. Insert your reply at appropriate points in previous message.
Thanks.
Colin, ok, I installed 1.3.7:

rvm install rubygems 1.3.7

then:

ruby script/server

Error loading RubyGems plugin
"/home/user/.rvm/gems/ruby-1.8.6-p420/gems/executable-hooks-1.2.6/lib/rubygems_plugin.rb":
uninitialized constant ExecutableHooks (NameError)
Error loading RubyGems plugin
"/home/user/.rvm/gems/ruby-1.8.6-p420@global/gems/executable-hooks-1.2.5/lib/rubygems_plugin.rb":
uninitialized constant ExecutableHooks (NameError)
./script/../config/boot.rb:39:in `run': uninitialized constant
Rails::Initializer (NameError)
from ./script/../config/boot.rb:11:in `boot!'

WHICH, if I now do:
gem -v

Error loading RubyGems plugin
"/home/user/.rvm/gems/ruby-1.8.6-p420/gems/executable-hooks-1.2.6/lib/rubygems_plugin.rb":
uninitialized constant ExecutableHooks (NameError)
Why are you using the executablehooks gem anyway on a rails 2 app?

Colin

It seems there's something missing at a higher level in my setup? Thanks for
looking at this for me, I'm really stuck here. RVic

On Wednesday, October 23, 2013 8:44:46 AM UTC-4, RVic wrote:

I have an older rails app that runs on an old, windows machine that i ned
to port to a more modern linux. The app is written using ruby 1.8.6
(2010-09-02 patchlevel 420) [i686-linux] with rails 2.3.2.

I have installed all of it on the new system, all the required gems and
plugins, but when I go to fire it up from the projects to-level foder, it
errors out on me. I've looked all over the web for this, but can't find the
solution, and at this point, the tings others have tried frighten me as I
dont really want to kill the pristine setup I have on this new machine
(using rvm):
ruby script/server
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/executable-hooks-1.2.6/lib/executable-hooks/regenerate_binstubs_command.rb:47:
warning: parenthlesize argument(s) for future version
=> Booting Mongrel
=> Rails 2.3.2 application starting on http://0.0.0.0:3000

/home/user/.rvm/gems/ruby-1.8.6-p420/gems/rails-2.3.2/lib/rails/gem_dependency.rb:99:Warning:
Gem::Dependency#version_requirements is deprecated and will be removed on or
after August 2010. Use #requirement

/home/user/.rvm/rubies/ruby-1.8.6-p420/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- ruby-debug
(MissingSourceFile)
from
/home/user/.rvm/rubies/ruby-1.8.6-p420/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
`require'
from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:156:in
`require'
from /home/user/ggripv2/config/environments/development.rb:2:in
`load_environment'
from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/rails-2.3.2/lib/initializer.rb:365:in
`load_environment'
from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/activesupport-2.3.2/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/rails-2.3.2/lib/initializer.rb:358:in
`load_environment'
... 9 levels...
from
/home/user/.rvm/gems/ruby-1.8.6-p420/gems/rails-2.3.2/lib/commands/server.rb:84
from
/home/user/.rvm/rubies/ruby-1.8.6-p420/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
from
/home/user/.rvm/rubies/ruby-1.8.6-p420/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
from script/server:3
--
You received this message because you are subscribed to the Google Groups
"Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/rubyonrails-talk/07b5f995-ec2c-4b79-97de-5c2698056813%40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.
--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To unsubscribe from this group and stop receiving emails from it, send an email to rubyonrails-talk+unsubscribe@googlegroups.com.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/rubyonrails-talk/CAL%3D0gLtTh5hdGE8gDotXVA8Wc2%2B%2BPSiQ_-16XahE5B4n%3DL-CBA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 6 of 17 | next ›
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 23, '13 at 12:44p
activeOct 24, '13 at 8:20a
posts17
users5
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2021 Grokbase