Hi!

It seems that you need to install Python:

make: python: Command not found



On Thu, May 31, 2012 at 6:02 PM, Felipe Pieretti Umpierre
wrote:
Hello, I have a problem when I try to add the gem therubyracer.

I put in my prompt:

bundle install, and this error appears:

C:\rails\organily>bundle install
Fetching gem metadata from https://rubygems.org/.........
Using rake (0.9.2.2)
Using i18n (0.6.0)
Using multi_json (1.3.6)
Using activesupport (3.2.3)
Using builder (3.0.0)
Using activemodel (3.2.3)
Using erubis (2.7.0)
Using journey (1.0.3)
Using rack (1.4.1)
Using rack-cache (1.2)
Using rack-test (0.6.1)
Using hike (1.2.1)
Using tilt (1.3.3)
Using sprockets (2.1.3)
Using actionpack (3.2.3)
Using mime-types (1.18)
Using polyglot (0.3.3)
Using treetop (1.4.10)
Using mail (2.4.4)
Using actionmailer (3.2.3)
Using arel (3.0.2)
Using tzinfo (0.3.33)
Using activerecord (3.2.3)
Using activeresource (3.2.3)
Using bundler (1.2.0.pre.1)
Using coffee-script-source (1.3.3)
Using execjs (1.4.0)
Using coffee-script (2.2.0)
Using rack-ssl (1.3.2)
Using json (1.7.3)
Using rdoc (3.12)
Using thor (0.14.6)
Using railties (3.2.3)
Using coffee-rails (3.2.2)
Using jquery-rails (2.0.2)
Using libv8 (3.10.8.0)
Using mysql (2.8.1)
Using rails (3.2.3)
Using sass (3.1.19)
Using sass-rails (3.2.5)
Using sqlite3 (1.3.6)
Installing therubyracer (0.8.2) with native extensions
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native
extension
.

C:/Ruby193/bin/ruby.exe extconf.rb
mkdir -p build
cp -r scons build
mkdir -p build/scons/install
python build/scons/setup.py install --prefix=install
make: python: Command not found
make: *** [build/scons/install/bin/scons] Error 127
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=C:/Ruby193/bin/ruby
extconf.rb:10:in `<main>': Error compiling V8 (RuntimeError)
Compiling V8


Gem files will remain installed in
C:/Ruby193/lib/ruby/gems/1.9.1/gems/therubyra
cer-0.8.2 for inspection.
Results logged to
C:/Ruby193/lib/ruby/gems/1.9.1/gems/therubyracer-0.8.2/ext/v8/
gem_make.out
An error occurred while installing therubyracer (0.8.2), and Bundler
cannot cont
inue.
Make sure that `gem install therubyracer -v '0.8.2'` succeeds before
bundling.

How can I solve this ?

Thank you.

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 16 | next ›
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedMay 31, '12 at 9:02p
activeAug 18, '14 at 11:10a
posts16
users6
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2021 Grokbase