Hi,
while running "rails server" , i get the error .
C:/Ruby192/lib/ruby/1.9.1/
rubygems.rb:762:in `report_activate_error': Could not find Ruby
Gem json (~> 1.4) (Gem::LoadError)
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:219:in `activate'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:254:in `block in
activate'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:253:in `each'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:253:in `activate'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:254:in `block in
activate'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:253:in `each'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:253:in `activate'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:254:in `block in
activate'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:253:in `each'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:253:in `activate'
from C:/Ruby192/lib/ruby/1.9.1/rubygems.rb:1065:in `gem'
from C:/Ruby192/bin/rails:18:in `<main>'


Next , i gave command "gem install json" .so i get error

Building native extensions. This could take a while...
ERROR: Error installing json:
ERROR: Failed to build gem native extension.

C:/Ruby192/bin/ruby.exe extconf.rb
creating Makefile

make
gcc -I. -IC:/Ruby192/include/ruby-1.9.1/i386-mingw32
-I/C/Ruby192/include/ruby-1.9.1/ruby
/backward -I/C/Ruby192/include/ruby-1.9.1 -I. -O3 -g -Wextra
-Wno-unused-parameter -Wno
-parentheses -Wpointer-arith -Wwrite-strings
-Wno-missing-field-initializers -Wno-long-lo
ng -O3 -Wall -o parser.o -c parser.c
../fbuffer/fbuffer.h:129:13: warning: 'fbuffer_append_long' defined but not
used
../fbuffer/fbuffer.h:136:17: warning: 'fbuffer_dup' defined but not used
../fbuffer/fbuffer.h:149:14: warning: 'fbuffer_to_s' defined but not used
../fbuffer/fbuffer.h:90:13: warning: 'fbuffer_append_str' defined but not
used
gcc -shared -s -o parser.so parser.o -L. -LC:/Ruby192/lib -L.
-LC:\\Users\\Luis\\Projects
\\oss\\oneclick\\rubyinstaller\\sandbox\\tk\\lib
-LC:\\Users\\Luis\\Projects\\oss\\onecli
ck\\rubyinstaller\\sandbox\\tcl\\lib
-LC:\\Users\\Luis\\Projects\\oss\\oneclick\\rubyinst
aller\\sandbox\\libyaml\\lib
-LC:\\Users\\Luis\\Projects\\oss\\oneclick\\rubyinstaller\\s
andbox\\pdcurses\\lib
-LC:\\Users\\Luis\\Projects\\oss\\oneclick\\rubyinstaller\\sandbox\
\openssl\\lib
-LC:\\Users\\Luis\\Projects\\oss\\oneclick\\rubyinstaller\\sandbox\\zlib\\l
ib
-LC:\\Users\\Luis\\Projects\\oss\\oneclick\\rubyinstaller\\sandbox\\iconv\\lib
-LC:\\U
sers\\Luis\\Projects\\oss\\oneclick\\rubyinstaller\\sandbox\\gdbm\\lib
-LC:\\Users\\Luis\
\Projects\\oss\\oneclick\\rubyinstaller\\sandbox\\libffi\\lib
-Wl,--enable-auto-image-ba
se,--enable-auto-import parser-i386-mingw32.def -lmsvcrt-ruby191
-lshell32 -lws2_32
c:/rhostudio/devkit/mingw/bin/../lib/gcc/mingw32/4.5.1/../../../../mingw32/bin/ld.exe:
ca
nnot find -lmsvcrt-ruby191
collect2: ld returned 1 exit status
make: *** [parser.so] Error 1


Gem files will remain installed in
C:/Ruby192/lib/ruby/gems/1.9.1/gems/json-1.6.5 for ins
pection.
Results logged to
C:/Ruby192/lib/ruby/gems/1.9.1/gems/json-1.6.5/ext/json/ext/parser/gem_
make.out


CAN ANYONE HELP ME???

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 1 | next ›
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedMar 4, '12 at 12:00p
activeMar 4, '12 at 12:00p
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

'Vinoth M: 1 post

People

Translate

site design / logo © 2021 Grokbase