Sure the problem is WEBrick? Error message seems to be complaining
about mysql. Did you install mysql?

On 02/29/2012 03:48 PM, Joel wrote:
Hello,

I started a class on RoR, and the instructor is using WEBrick, which
he says "ships with Rails." Is that still true? I've followed all
the other instructions, I believe, and I'm not getting good messages
when I type rails server . Instead I get

joelrwesley$ rails server
/Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/mysql2-0.3.11/lib/
mysql2.rb:9:in `require': dlopen(/Users/joelrwesley/.rvm/gems/
ruby-1.9.3-p125/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle, 9):
Library not loaded: libmysqlclient.18.dylib (LoadError)
Referenced from: /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/
mysql2-0.3.11/lib/mysql2/mysql2.bundle
Reason: image not found - /Users/joelrwesley/.rvm/gems/ruby-1.9.3-
p125/gems/mysql2-0.3.11/lib/mysql2/mysql2.bundle
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/mysql2-0.3.11/
lib/mysql2.rb:9:in `<top (required)>'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/bundler-1.0.22/
lib/bundler/runtime.rb:68:in `require'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/bundler-1.0.22/
lib/bundler/runtime.rb:68:in `block (2 levels) in require'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/bundler-1.0.22/
lib/bundler/runtime.rb:66:in `each'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/bundler-1.0.22/
lib/bundler/runtime.rb:66:in `block in require'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/bundler-1.0.22/
lib/bundler/runtime.rb:55:in `each'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/bundler-1.0.22/
lib/bundler/runtime.rb:55:in `require'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/bundler-1.0.22/
lib/bundler.rb:122:in `require'
from /Users/joelrwesley/Desktop/Sites/simple_cms/config/
application.rb:7:in `<top (required)>'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/railties-3.2.1/
lib/rails/commands.rb:53:in `require'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/railties-3.2.1/
lib/rails/commands.rb:53:in `block in<top (required)>'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/railties-3.2.1/
lib/rails/commands.rb:50:in `tap'
from /Users/joelrwesley/.rvm/gems/ruby-1.9.3-p125/gems/railties-3.2.1/
lib/rails/commands.rb:50:in `<top (required)>'
from script/rails:6:in `require'
from script/rails:6:in `<main>'
joelrwesley$


Thanks,
Joel
--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 6 | next ›
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedFeb 29, '12 at 11:48p
activeMar 1, '12 at 4:24a
posts6
users5
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase