I tried using this https://github.com/matschaffer/win32-open3-19 as
described in this post:
http://stackoverflow.com/questions/4930270/ruby-1-9-no-such-file-to-load-win32-open3

But I never got it to work.

Note that the "win32-open3 requires Ruby version < 1.9.0" So I used pik
to downgrade to Ruby version 1.8.7, so I could use win32-open3, and then
I was able to run the rails_upgrade plugin. Then I plan to upgrade my
app using 1.8.7, make sure that works, and get that checked into version
control. Once that's done I'll use pik to go back up to 1.9.* and make
sure it still works.

Don't forget to add

gem "win32-open3"

to your Gemfile, at least until you get the rails upgrade done (no need
to check that into version control unless you are also checking in the
rails upgrade plugin, which you probably won't).

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 1 | next ›
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedNov 11, '11 at 12:03a
activeNov 11, '11 at 12:03a
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Gayle Craig: 1 post

People

Translate

site design / logo © 2022 Grokbase