FAQ
Hi,

I am new to writing code for puppet. I installed biemond/jdk7 module. In
that it has install7.pp and javaexec.pp Now I am trying to modify the
parameters using wrapper class. In that I wrote
class javajdk {
  include jdk7,java7_exec

  jdk7::install7{ "jdk1.7.0_25" :
   version => "7u25",
   fullVersion => "jdk1.7.0_25",
   x64 => true,
   user => oracle,
   group => oinstall,
   alternativesPriority => 17065,
   downloadDir => "/data/install",
   urandomJavaFix => true,
   sourcePath => "/stage/",
}

.......
......
class java7_exec{
  $path = "/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:"
  $fullVersion = "jdk1.7.0_25"
   $jdkfile =
"jdk-${version}-${installVersion}-${type}${installExtension}"
   $user = 'oracle'
   $group = 'oinstall'
  jdk7::javaexec{ 'java7_exec' :
   path => $path,
   fullVersion => "jdk1.7.0_25",
   jdkfile => $jdkfile,
   user => $user,
   group => $group
}
I am getting the issue:*Error: Puppet::Parser::AST::Resource failed with
error ArgumentError: Invalid resource type jdk7::javaexec*

Please help me.

Thank you



--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [email protected].
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/4940a992-fe7a-40a4-9ccd-fec00229b2d2%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 1 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 1, '14 at 1:41a
activeFeb 1, '14 at 1:41a
posts1
users1
websitepuppetlabs.com

1 user in discussion

Supriya Uppalapati: 1 post

People

Translate

site design / logo © 2023 Grokbase