I found my own answer. I didn't realize that I either have to install ruby
via an rpm or use --no-deps to install.
On Saturday, August 31, 2013 1:57:43 PM UTC-6, rjl wrote:

I am trying to install puppet puppet-server 3.2.4-1. I have installed ruby
2.0.0p247 from source. This is on Centos5.9. I am installing from my own
yum repository. All of my dependencies are resolved except for ruby.

--> Finished Dependency Resolution
puppet-3.2.4-1.el5.noarch from lvlt-tools-fasttrack has depsolving problems
--> Missing Dependency: ruby >= 1.8.7 is needed by package
puppet-3.2.4-1.el5.noarch (lvlt-tools-fasttrack)
Error: Missing Dependency: ruby >= 1.8.7 is needed by package
puppet-3.2.4-1.el5.noarch (lvlt-tools-fasttrack)

Here is my is my ruby environment.
[root@stsdev-sec ~]# ruby -v;which ruby;whereis ruby
ruby 2.0.0p247 (2013-06-27) [x86_64-linux]
ruby: /usr/local/bin/ruby /usr/local/lib/ruby

I have tried linking to /usr/bin/ruby and that does not work either.

Thanks in advance for any assistance!

You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Discussion Posts


Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 2 | next ›
Discussion Overview
grouppuppet-users @
postedAug 31, '13 at 7:57p
activeAug 31, '13 at 8:19p

1 user in discussion

Rjl: 2 posts



site design / logo © 2022 Grokbase