FAQ
Hi all,

I am trying to use puppet (2.7.18) for downgrading varnish cache on Centos
Linux (6.3).

Unfortunately there are two varnish RPMs (which seem to have circular
dependencies):

varnish-3.0.4-1.el6.x86_64
varnish-libs-3.0.4-1.el6.x86_64

When using "ensure" for downgrading I get a bunch of errors:

err: /Stage[main]/Varnish/Package[varnish-libs]/ensure: change from
3.0.4-1.el6 to 3.0.3-1.el6 failed: Could not update: Execution of
'/usr/bin/yum -d 0 -e 0 -y downgrade varnish-libs-3.0.3-1.el6' returned 1:
Error: Package: varnish-3.0.4-1.el6.x86_64 (@varnish-3.0)
            Requires: varnish-libs = 3.0.4-1.el6
            Removing: varnish-libs-3.0.4-1.el6.x86_64 (@varnish-3.0)
                varnish-libs = 3.0.4-1.el6
            Downgraded By: varnish-libs-3.0.3-1.el6.x86_64 (varnish-3.0)
                varnish-libs = 3.0.3-1.el6
            Available: varnish-libs-2.1.5-1.el6.i686 (EPEL-RHEL)
                varnish-libs = 2.1.5-1.el6
            Available: varnish-libs-3.0.3-0.rc1.el6.x86_64 (varnish-3.0)
                varnish-libs = 3.0.3-0.rc1.el6
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest
  at /etc/puppet/environments/development/modules/varnish/manifests/init.pp:8
err: /Stage[main]/Varnish/Package[varnish]/ensure: change from 3.0.4-1.el6
to 3.0.3-1.el6 failed: Could not update: Execution of '/usr/bin/yum -d 0 -e
0 -y downgrade varnish-3.0.3-1.el6' returned 1: Error: Package:
varnish-3.0.3-1.el6.x86_64 (varnish-3.0)
            Requires: varnish-libs = 3.0.3-1.el6
            Installed: varnish-libs-3.0.4-1.el6.x86_64 (@varnish-3.0)
                varnish-libs = 3.0.4-1.el6
            Available: varnish-libs-2.1.5-1.el6.i686 (EPEL-RHEL)
                varnish-libs = 2.1.5-1.el6
            Available: varnish-libs-3.0.3-0.rc1.el6.x86_64 (varnish-3.0)
                varnish-libs = 3.0.3-0.rc1.el6
            Available: varnish-libs-3.0.3-1.el6.x86_64 (varnish-3.0)
                varnish-libs = 3.0.3-1.el6
  You could try using --skip-broken to work around the problem
  You could try running: rpm -Va --nofiles --nodigest
  at /etc/puppet/environments/development/modules/varnish/manifests/init.pp:8

Whatever I try I do not succeed. My goal is to have a rock-solid puppet
manifest for switching between varnish versions in development environments
without having to reinstall the whole VM.

Using yum to downgrade both packages at the same time (and being able to
resolve circular dependencies) succeeds:

/usr/bin/yum -d 0 -e 0 -y downgrade varnish-libs-3.0.3-1.el6
varnish-3.0.3-1.el6

Any idea how I can solve this?

Kind regards,
   Stefan


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 4 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 28, '13 at 2:11p
activeSep 17, '13 at 12:42p
posts4
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2021 Grokbase