FAQ
Hi

fully expecting to have done something silly here but am struggling to debug why I am getting the error:

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: No such file or directory - getcwd at /etc/puppet/manifests/nodes.pp:2 on node my.domain.net

the line in question is getting a custom module which has not changed recently.

I was installing http://www.practicalclouds.com/content/guide/pclouds-vcsdeploy-deploy-stuff and having some permissions issues, so I think this may well be to do with permissions. However I am at a loss as to what as everything looks to be ok.

Puppet Master and two client nodes on Debian Wheezy, the clients both return this error. Puppet version 3.2.1 on all 3.

Any suggestions as to where to start debugging this?

Rachel

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 2 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJun 19, '13 at 4:28p
activeDec 10, '13 at 6:40p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Rachel Andrew: 1 post Jon Jaroker: 1 post

People

Translate

site design / logo © 2022 Grokbase