On 15 May 2013 19:33, jcbollinger wrote:
On Wednesday, May 15, 2013 10:45:19 AM UTC-5, Dick Davies wrote:

<%- if yum_proxy_url != false %>
# use proxy
proxy=<%=yum_proxy_url %>
<% end -%>

which is a bit more readable. Not really clear why the : != false part is
required, but
feels cleaner to me.
In other words, yes, you do need all the same logic in all the same
places. In that case, your only real option is to choose the special value
you like best. Personally, I find the empty string very appropriate, and
whereas there could conceivably be a machine named "false", but there
cannot be one named "". Still, it's a matter of taste.
Absolutely - see your point - it looks to me like the template is treating
literal false (not "false")
as a string rather than a boolean.
I might be wrong but my reading is that hiera can return booleans as well
as strings,
so maybe it's a template thing? Anyway, spent enough time on this for now -

You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Discussion Posts


Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 5 of 5 | next ›
Discussion Overview
grouppuppet-users @
postedMay 15, '13 at 11:29a
activeMay 16, '13 at 6:53a

2 users in discussion

Dick Davies: 3 posts Jcbollinger: 2 posts



site design / logo © 2022 Grokbase