FAQ
Hi Heidi,



Now We tried to install the puppet and puppet-server packages from
puppetlabs, but we faced below discrepancy.



Please look into this and let us know your suggestions because issue was
not found in Puppet community as well. There was 1 issue related to this
but it dint help us

(http://projects.puppetlabs.com/issues/16634 )



We went through
http://docs.puppetlabs.com/pe/latest/install_system_requirements.html and
http://docs.puppetlabs.com/guides/installation.html



Also went through Puppet community and could not find the solution for the
issue we are facing.



*Below is the detail summary of issue we are facing*



we have already enabled dependencies repo from puppetlabs by running
following command but still facing issues



rpm -ivh
http://yum.puppetlabs.com/el/6/products/x86_64/puppetlabs-release-6-6.noarch.rpm





*Below is the repo list*

*
*

*
*


* *


[root@xxxxxxxx xxxxxxxx]# yum install -y puppet puppet-server

Loaded plugins: product-id, security, subscription-manager

Updating certificate-based repositories.

Unable to read consumer identity



This machine has not been registered and therefore has

no access to security and other critical updates. Please

register using subscription-manager.



Setting up Install Process

Resolving Dependencies

--> Running transaction check

---> Package puppet.noarch 0:3.1.1-1.el6 will be installed

--> Processing Dependency: ruby >= 1.8.7 for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: ruby(abi) >= 1.8 for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: facter >= 1.6.11 for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: hiera >= 1.0.0 for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: ruby(selinux) for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: ruby-augeas for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: /usr/bin/ruby for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: ruby-shadow for package:
puppet-3.1.1-1.el6.noarch

---> Package puppet-server.noarch 0:3.1.1-1.el6 will be installed

--> Running transaction check

---> Package facter.x86_64 1:1.6.18-1.el6 will be installed

--> Processing Dependency: ruby >= 1.8.5 for package:
1:facter-1.6.18-1.el6.x86_64

--> Processing Dependency: ruby(abi) >= 1.8 for package:
1:facter-1.6.18-1.el6.x86_64

--> Processing Dependency: /usr/bin/ruby for package:
1:facter-1.6.18-1.el6.x86_64

---> Package hiera.noarch 0:1.1.2-1.el6 will be installed

--> Processing Dependency: ruby >= 1.8.5 for package:
hiera-1.1.2-1.el6.noarch

--> Processing Dependency: ruby(abi) >= 1.8 for package:
hiera-1.1.2-1.el6.noarch

--> Processing Dependency: rubygem-json for package:
hiera-1.1.2-1.el6.noarch

---> Package puppet.noarch 0:3.1.1-1.el6 will be installed

--> Processing Dependency: ruby >= 1.8.7 for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: ruby(abi) >= 1.8 for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: ruby(selinux) for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: /usr/bin/ruby for package:
puppet-3.1.1-1.el6.noarch

---> Package ruby-augeas.x86_64 0:0.4.1-1.el6 will be installed

--> Processing Dependency: ruby(abi) = 1.8 for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: augeas-libs >= 0.8.0 for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for
package: ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for
package: ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for
package: ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libruby.so.1.8()(64bit) for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0()(64bit) for package:
ruby-augeas-0.4.1-1.el6.x86_64

---> Package ruby-shadow.x86_64 0:1.4.1-13.el6 will be installed

--> Processing Dependency: ruby(abi) = 1.8 for package:
ruby-shadow-1.4.1-13.el6.x86_64

--> Processing Dependency: libruby.so.1.8()(64bit) for package:
ruby-shadow-1.4.1-13.el6.x86_64

--> Running transaction check

---> Package facter.x86_64 1:1.6.18-1.el6 will be installed

--> Processing Dependency: ruby >= 1.8.5 for package:
1:facter-1.6.18-1.el6.x86_64

--> Processing Dependency: ruby(abi) >= 1.8 for package:
1:facter-1.6.18-1.el6.x86_64

--> Processing Dependency: /usr/bin/ruby for package:
1:facter-1.6.18-1.el6.x86_64

---> Package hiera.noarch 0:1.1.2-1.el6 will be installed

--> Processing Dependency: ruby >= 1.8.5 for package:
hiera-1.1.2-1.el6.noarch

--> Processing Dependency: ruby(abi) >= 1.8 for package:
hiera-1.1.2-1.el6.noarch

---> Package puppet.noarch 0:3.1.1-1.el6 will be installed

--> Processing Dependency: ruby >= 1.8.7 for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: ruby(abi) >= 1.8 for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: ruby(selinux) for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: /usr/bin/ruby for package:
puppet-3.1.1-1.el6.noarch

---> Package ruby-augeas.x86_64 0:0.4.1-1.el6 will be installed

--> Processing Dependency: ruby(abi) = 1.8 for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: augeas-libs >= 0.8.0 for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for
package: ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for
package: ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for
package: ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libruby.so.1.8()(64bit) for package:
ruby-augeas-0.4.1-1.el6.x86_64

--> Processing Dependency: libaugeas.so.0()(64bit) for package:
ruby-augeas-0.4.1-1.el6.x86_64

---> Package ruby-shadow.x86_64 0:1.4.1-13.el6 will be installed

--> Processing Dependency: ruby(abi) = 1.8 for package:
ruby-shadow-1.4.1-13.el6.x86_64

--> Processing Dependency: libruby.so.1.8()(64bit) for package:
ruby-shadow-1.4.1-13.el6.x86_64

---> Package rubygem-json.x86_64 0:1.5.5-1.el6 will be installed

--> Processing Dependency: ruby(abi) = 1.8 for package:
rubygem-json-1.5.5-1.el6.x86_64

--> Processing Dependency: rubygems for package:
rubygem-json-1.5.5-1.el6.x86_64

--> Processing Dependency: /usr/bin/ruby for package:
rubygem-json-1.5.5-1.el6.x86_64

--> Processing Dependency: libruby.so.1.8()(64bit) for package:
rubygem-json-1.5.5-1.el6.x86_64

--> Processing Dependency: /usr/bin/ruby for package:
1:facter-1.6.18-1.el6.x86_64

--> Processing Dependency: /usr/bin/ruby for package:
puppet-3.1.1-1.el6.noarch

--> Processing Dependency: /usr/bin/ruby for package:
rubygem-json-1.5.5-1.el6.x86_64

--> Finished Dependency Resolution

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: libaugeas.so.0(AUGEAS_0.1.0)(64bit)

Error: Package: rubygem-json-1.5.5-1.el6.x86_64 (puppetlabs-deps)

Requires: rubygems

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: libaugeas.so.0(AUGEAS_0.8.0)(64bit)

Error: Package: puppet-3.1.1-1.el6.noarch (puppetlabs-products)

Requires: ruby(abi) >= 1.8

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: libaugeas.so.0()(64bit)

Error: Package: puppet-3.1.1-1.el6.noarch (puppetlabs-products)

Requires: ruby >= 1.8.7

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: libaugeas.so.0(AUGEAS_0.11.0)(64bit)

Error: Package: rubygem-json-1.5.5-1.el6.x86_64 (puppetlabs-deps)

Requires: libruby.so.1.8()(64bit)

Error: Package: puppet-3.1.1-1.el6.noarch (puppetlabs-products)

Requires: /usr/bin/ruby

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: augeas-libs >= 0.8.0

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: libruby.so.1.8()(64bit)

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: libaugeas.so.0(AUGEAS_0.10.0)(64bit)

Error: Package: hiera-1.1.2-1.el6.noarch (puppetlabs-products)

Requires: ruby >= 1.8.5

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: ruby(abi) = 1.8

Error: Package: 1:facter-1.6.18-1.el6.x86_64 (puppetlabs-products)

Requires: /usr/bin/ruby

Error: Package: rubygem-json-1.5.5-1.el6.x86_64 (puppetlabs-deps)

Requires: /usr/bin/ruby

Error: Package: 1:facter-1.6.18-1.el6.x86_64 (puppetlabs-products)

Requires: ruby(abi) >= 1.8

Error: Package: ruby-augeas-0.4.1-1.el6.x86_64 (puppetlabs-deps)

Requires: libaugeas.so.0(AUGEAS_0.12.0)(64bit)

Error: Package: rubygem-json-1.5.5-1.el6.x86_64 (puppetlabs-deps)

Requires: ruby(abi) = 1.8

Error: Package: hiera-1.1.2-1.el6.noarch (puppetlabs-products)

Requires: ruby(abi) >= 1.8

Error: Package: 1:facter-1.6.18-1.el6.x86_64 (puppetlabs-products)

Requires: ruby >= 1.8.5

Error: Package: puppet-3.1.1-1.el6.noarch (puppetlabs-products)

Requires: ruby(selinux)

Error: Package: ruby-shadow-1.4.1-13.el6.x86_64 (puppetlabs-deps)

Requires: ruby(abi) = 1.8

Error: Package: ruby-shadow-1.4.1-13.el6.x86_64 (puppetlabs-deps)

Requires: libruby.so.1.8()(64bit)

You could try using --skip-broken to work around the problem


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 2 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMar 16, '13 at 1:27a
activeMar 16, '13 at 3:01a
posts2
users2
websitepuppetlabs.com

2 users in discussion

Dan White: 1 post Ripunjay Godhani: 1 post

People

Translate

site design / logo © 2022 Grokbase