FAQ
Felix ,

Thanks for your reply. Please see the below thread. I deleted this post,
because my title was'nt clear. Not sure how it showed up again. Yes, I did
removed old hiera and updated new one. Still no use.

https://groups.google.com/forum/?hl=en&fromgroups#!topic/puppet-users/Fueb5cXA9Fg

Regards
Sai.
On Monday, February 25, 2013 8:28:29 AM UTC-5, Felix.Frank wrote:

Hi,

I don't really understand the problem.
On 02/22/2013 07:29 PM, Sai_Emc wrote:
/opt/puppet/lib/gems/1.8/gems/hiera-0.3.0
/opt/puppet/lib/gems/1.8/gems/hiera-puppet-0.3.0

Later when I updated to new version of hiera then it installed (via gem
install) under

/opt/puppet/lib/gems/1.8/gems/hiera-1.1.1
/opt/puppet/lib/gems/1.8/gems/hiera-puppet-1.0.0
Are these not the same base directories? It's not really clear why one
would work and not the other.
/opt/puppet/lib/site_ruby/1.8/puppet/parser/functions/hiera_include.rb
Do you have this file? Or is ruby looking for that?

You may need to fix your RUBYLIB environment. Have you tried
reinstalling the older hiera version.

HTH,
Felix
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 4 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 22, '13 at 6:29p
activeFeb 25, '13 at 2:41p
posts4
users2
websitepuppetlabs.com

2 users in discussion

Sai_Emc: 3 posts Felix Frank: 1 post

People

Translate

site design / logo © 2022 Grokbase