FAQ
Thank you! My vagrant box have 2.7.6 installed. Got to test with newer
version.

Chad: yes I know, but I hope that I don't need any pre-install step when I
use Vagrant. Its easier if there is no multiple steps to get environment up
and running. Thanks for help anyway!

-Erno

perjantai, 1. helmikuuta 2013 3.38.15 UTC+2 Nan Liu kirjoitti:
On Wed, Jan 30, 2013 at 10:50 PM, Erno Aapa <aapa...@gmail.com<javascript:>
wrote:
Hi,
I have tricky problem and I hope that someone could help me.
I'm using puppetlabs-firewall module. My box doesn't have iptables
pre-installed. And because there is no /sbin/iptables puppet don't find
provider for firewall -type. I get error that no provider for firewall
found.

Does anyone have idea how to get around this? Even if I create stage
which is before "main"-stage and install the iptables there I get errors.
The issue should be fixed somewhere in 2.7.x where you can install
packages and have it satisfy provider requirements in a single puppet run.
See: http://projects.puppetlabs.com/issues/6907.

Nan
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 5 of 5 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJan 31, '13 at 6:53a
activeFeb 2, '13 at 6:29a
posts5
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase