FAQ

On Tuesday, November 27, 2012 8:37:22 PM UTC-6, Brian Jolly wrote:
I am experiencing the same problem with a 3.0.1 install.

If I set "enable_inventory_service: false" there are no problems.

ruby: symbol lookup error:
/usr/lib/ruby/gems/1.8/gems/json-1.5.1/ext/json/ext/json/ext/parser.so:
undefined symbol: RSTRING_PTR

ruby 1.8.7 (2012-06-29 patchlevel 370) [x86_64-linux]

# ldd
/usr/lib/ruby/gems/1.8/gems/json-1.5.1/ext/json/ext/json/ext/parser.so
linux-vdso.so.1 => (0x00007fff7f920000)
libruby.so.1.8 => /usr/lib64/libruby.so.1.8 (0x00002aeccf1a9000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aeccf4a7000)
libdl.so.2 => /lib64/libdl.so.2 (0x00002aeccf6c3000)
libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aeccf8c7000)
libm.so.6 => /lib64/libm.so.6 (0x00002aeccfaff000)
libc.so.6 => /lib64/libc.so.6 (0x00002aeccfd83000)
librt.so.1 => /lib64/librt.so.1 (0x00002aecd00da000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aecd02e3000)
/lib64/ld-linux-x86-64.so.2 (0x00002aecced7c000)
rpm -q -f /usr/lib64/libruby.so.1.8
rpm -q -f
/usr/lib/ruby/gems/1.8/gems/json-1.5.1/ext/json/ext/json/ext/parser.so
rpm -q -f $(which ruby)


John


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/lJ3CjIOVbBsJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 15 of 24 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedNov 23, '12 at 10:46p
activeDec 14, '12 at 2:51p
posts24
users8
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase