On Fri, Nov 23, 2012 at 2:46 PM, Alaric wrote:

I'm having a weird issue and was wondering if anyone else had run into it. I recently upgraded from puppet 2.7 -> 3.0.1 After cleaning up some gems on my puppet master everything seemed to be working ok. I had originally used the EPEL repo's to deploy puppet, but switched to the Puppet Labs repos so I could upgrade to 2.7 then 3. On RHEL5 only, I get a RSTRING_PTR error if I upgrade to the Puppet Labs version (1.4.6) if I roll back to the EPEL veriosn of rubygem-json (1.4.3) Everything works again.
Has anyone affected by this issue seen
https://bugzilla.redhat.com/show_bug.cgi?id=634380 ?

This information leads me to believe the rubygem-json package from
Puppet Labs may not be carrying the same patch that the rubygem-json
1.4.3 package from the Fedora Project is carrying. This difference
may be the cause of the error. Can anyone confirm?


You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Discussion Posts


Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 18 of 24 | next ›
Discussion Overview
grouppuppet-users @
postedNov 23, '12 at 10:46p
activeDec 14, '12 at 2:51p



site design / logo © 2022 Grokbase