FAQ

On Tuesday, October 9, 2012 10:24:53 AM UTC+1, Fran Rodríguez wrote:

Yes, it does. This occurs when change apt module for the puppetlabs-apt.
Maybe is a issue with environments, im trying to figure out what is
happening, and like the log said the module stdlib which provide the anchor
type, is not being recognize.
I had the same problem, caused by the puppetlabs-stdlib Ruby libraries not
being available to the puppet master when it was parsing and compiling the
manifests. It's related to bug http://projects.puppetlabs.com/issues/13858
as far as I can tell. The solution was to run puppet agent on the master
itself, with pluginsync enabled, such that the required plugins from
the puppetlabs-stdlib module get "synced" onto the master.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To view this discussion on the web visit https://groups.google.com/d/msg/puppet-users/-/NnZGhz0U58YJ.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 9 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 8, '12 at 3:19p
activeJul 10, '13 at 1:24p
posts9
users7
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase