FAQ

Jeeva <kissan475 <at> gmail.com> writes:


Hi,

I was trying to instal puppet-enterprise-2.5.1-el-5-x86_64 in centos6
machine. But got below error.

## Installing packages from files...
error: Failed dependencies:
java >= 1.5.0 is needed by pe-
tanukiwrapper-3.5.9-5.pe.el5.x86_64
======
!! ERROR: Could not install packages from files; see messages above
for cause.

1. Then I checked my java version which is > what is required.
java -version
java version "1.6.0_29"
Java(TM) SE Runtime Environment (build 1.6.0_29-b11)
Java HotSpot(TM) 64-Bit Server VM (build 20.4-b02, mixed mode)

2. I'm trying to install puppet master, console and puppet agent in
same machine as i want to test it before I move it to prod.

Kindly help..
I am having the same issue and it seems that the puppet installer does
not look for a valid Sun/Oracle java installation. How do you get around
that problem aside from installing another java product. I have
installed the rpms from Oracle for the current java. The rpms are listed
in the rpm database as jdk-<VERSION>-fcs or jre-<VERSION>-fcs. So if the
puppet installer is looking for java in the rpm database they will not
find it.

This is for a production box and the client wants oracle java not a
knock off, no matter how good they are.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 6 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 16, '12 at 10:29a
activeJun 11, '12 at 1:45p
posts6
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase