FAQ

On Wed, May 16, 2012 at 8:34 AM, jcbollinger wrote:
On May 16, 5:23 am, Jeeva wrote:
Hi,

I was trying to instal puppet-enterprise-2.5.1-el-5-x86_64 in centos6
machine. But got below error.

## Installing packages from files...
error: Failed dependencies:
java >= 1.5.0 is needed by pe-
tanukiwrapper-3.5.9-5.pe.el5.x86_64

================================================================================

!! ERROR: Could not install packages from files; see messages above
for cause.

1. Then I checked my java version which is > what is required.
java -version
java version "1.6.0_29"
Java(TM) SE Runtime Environment (build 1.6.0_29-b11)
Java HotSpot(TM) 64-Bit Server VM (build 20.4-b02, mixed mode)

That exhibits the java executable's idea of its version, which has
nothing to do with the problem.  The issue revolves around the
features declared by packages (RPMs) installed on your system and
those available from the configured repositories.

For CentOS 6, you would normally expect the "java" feature to be
provided by package java-1.6.0-openjdk or java-1.5.0-gcj (or both).
These are available on the CentOS install media and from the standard
CentOS repositories.  Alternatively, I think you can get an installer
from Oracle that provides an RPM (that used to be the case under Sun,
anyway), and you should always prefer that one on RPM-based systems
such as CentOS.  (Indeed, it is unwise to install *any* unpackaged
software on an RPM-based system if you have or can create a packaged
version.)

That yum emitted the error you describe indicates that
1) either your RPM database is borked, OR
2a) your Java is not installed from RPM, AND
2b) the CentOS standard repositories are disabled or inaccessible, OR
3) whatever Java RPM you have does not declare the "java" feature


If the problem is (1) then the command "rpm --rebuilddb" might help.
If not then the system is fundamentally broken, and you should
reinstall the whole thing from scratch.

If the problem is (2) then you should install Java from a suitable
RPM.  I recommend java-1.6.0-openjdk, which is the open source version
of what used to be Sun's Java 1.6.0 distribution.  If you use a
distribution direct from Oracle the be sure to get the RPM-based
installer.  Were I you, I would first remove the unpackaged version,
but perhaps you could get away without doing so.  Be warned, however:
removing unpackaged software can be much harder than installing it,
especially if there is other software installed on top.

I can't speak to what you might need to do to fix your repository
configuration, as I have no way to guess what in particular might be
wrong with it.

If the problem is (3) then you should switch Java packages, or at
least install an additional one that provides the needed feature.


John

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.
The short answer is that openjdk-1.6.0 should be the package that
works almost universally.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To post to this group, send email to puppet-users@googlegroups.com.
To unsubscribe from this group, send email to puppet-users+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/puppet-users?hl=en.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 6 | next ›
Discussion Overview
grouppuppet-users @
categoriespuppet
postedMay 16, '12 at 10:29a
activeJun 11, '12 at 1:45p
posts6
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase