FAQ
Thank you, Gustavo!

I had to clear out the old versions and download from scratch.
Everything worked after that. I appreciate your support.

Rob
On Friday, February 26, 2016 at 10:24:47 PM UTC-8, Gustavo Niemeyer wrote:

Hi Rob,

On Sat, Feb 27, 2016 at 2:53 AM, Rob Farrow <robbyri...@gmail.com
<javascript:>> wrote:
I am getting the same error with the latest release?
Is the mgo package still being supported?
Yes, and there was a major release days ago which you might be interested
on if you've been away for a while.

The error provides no clue as to where it is or how to fix it.
This behavior was introduced in Go 1.5. Please have a look at the
documentation:

https://golang.org/cmd/go/#hdr-Internal_Directories

~ $ go get gopkg.in/mgo.v2
package gopkg.in/mgo.v2
imports gopkg.in/mgo.v2-unstable/internal/scram: use of
internal package not allowed
Nothing imports from unstable in the stable package. Your is not
reflecting the actual v2 branch:

$ grep unstable * -r | wc -l


Try removing the content in there and re-getting it.


gustavo @ http://niemeyer.net
--
You received this message because you are subscribed to the Google Groups "mgo-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mgo-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 5 of 5 | next ›
Discussion Overview
groupmgo-users @
categoriesmongodb
postedDec 9, '15 at 12:31p
activeFeb 28, '16 at 5:25a
posts5
users3
websitelabix.org...
irc#mongodb

People

Translate

site design / logo © 2021 Grokbase