@lee, thanks, I am using ruby-1.9.3-p484 and I installed it from source
codes.Like configure, make, make install.

-DuJun

在 2014年2月22日星期六UTC+8下午11时36分59秒,dj19...@gmail.com写道:
Hi all,
I am playing with bosh-lite and I meet an issue about net-gateway-ssh when
I use `bosh target` command,
root@zjuvlis05:/home/dujun# bosh target 192.168.50.4

Then I will get the error message shown below:

/usr/local/lib/ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could
not find net-ssh-gateway (~> 1.1.0) amongst [archive-tar-minitar-0.5.2,
aws-sdk-1.8.5, bigdecimal-1.1.0, blobstore_client-1.1858.0,
bosh_cli-1.1858.0, bosh_common-1.1858.0, builder-3.2.2, bundler-1.5.3,
chef-11.6.2, diff-lcs-1.2.5, erubis-2.7.0, excon-0.25.3, fog-1.14.0,
formatador-0.2.4, highline-1.6.20, httpclient-2.2.4, io-console-0.3,
ipaddress-0.8.0, json-1.7.7, json-1.5.5, json_pure-1.8.1, librarian-0.1.1,
librarian-chef-0.0.2, log4r-1.1.10, mime-types-2.1, mini_portile-0.5.2,
minitar-0.5.4, minitest-2.5.1, mixlib-authentication-1.3.0,
mixlib-cli-1.4.0, mixlib-config-1.1.2, mixlib-log-1.6.0,
mixlib-shellout-1.3.0, multi_json-1.8.4, net-scp-1.1.2, net-ssh-2.8.0,
net-ssh-2.7.0, net-ssh-gateway-1.2.0, net-ssh-multi-1.1, netaddr-1.5.0,
nokogiri-1.6.1, ohai-6.20.0, progressbar-0.9.2, rake-10.1.1, rake-0.9.2.2,
rdoc-3.9.5, rest-client-1.6.7, rspec-2.14.1, rspec-core-2.14.7,
rspec-expectations-2.14.4, rspec-mocks-2.14.4, ruby-atmos-pure-1.0.5,
ruby-hmac-0.4.0, systemu-2.5.2, terminal-table-1.4.5, thor-0.18.1,
uuidtools-2.1.4, yajl-ruby-1.2.0] (Gem::LoadError)
from /usr/local/lib/ruby/1.9.1/rubygems/specification.rb:777:in
`block in activate_dependencies'
from /usr/local/lib/ruby/1.9.1/rubygems/specification.rb:766:in
`each'
from /usr/local/lib/ruby/1.9.1/rubygems/specification.rb:766:in
`activate_dependencies'
from /usr/local/lib/ruby/1.9.1/rubygems/specification.rb:750:in
`activate'
from /usr/local/lib/ruby/1.9.1/rubygems.rb:1232:in `gem'
from /usr/local/bin/bosh:22:in `<main>'

It seems that net-ssh-gateway (~> 1.1.0) is missing in my system, but when
I type `gem list` to show all gems installed in my system, I find the gems
concernning net-ssh:
*net-scp (1.1.2)*
*net-ssh (2.8.0, 2.7.0)*
*net-ssh-gateway (1.2.0)*
*net-ssh-multi (1.1)*

So I feel confused about the error message. Is there anyone has
encountered the problem? Thanks!
*PS: I am installing ruby from source codes and has `libssl-dev` and
`libcurl4-openssl-dev` installed before installing ruby.*

--
Regards,
DuJun
To unsubscribe from this group and stop receiving emails from it, send an email to bosh-users+unsubscribe@cloudfoundry.org.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 5 of 7 | next ›
Discussion Overview
groupbosh-users @
postedFeb 22, '14 at 3:37p
activeMar 2, '14 at 8:58a
posts7
users3

3 users in discussion

Du Jun: 4 posts Ward Lee: 2 posts Rsanchez Roy: 1 post

People

Translate

site design / logo © 2021 Grokbase