FAQ
Found it! :)
The mistake I was making was to provide the credentials in plain text.
Instead we need to provide the credentials in hash format as obtained from

mkpasswd -m sha-512

May have been documented else where as well, but I found it going thru this
link
https://github.com/cloudfoundry/oss-docs/blob/master/bosh/samples/cloudfoundry.yml

Regards
On Wednesday, July 25, 2012 11:57:22 AM UTC+5:30, Ankit wrote:

Hello All,

I'm trying to deploy the public stemcell "bosh-stemcell-vsphere-0.6.1",
hoping to have a bosh instance.

"bosh micro deploy ~/stemcells/bosh-stemcell-vsphere-0.6.1.tgz"

Above command completes successfully. And I see the virtual machine up and
running in the vsphere client. But when I try to ssh connect to the
provisioned bosh box, I'm not able to do so and continue to get "invalid
credentials" message. The last few entries in bosh_micro_deploy.log file
are as follows

I, [2012-07-25T02:12:57.345179 #13735]
[create_vm(bm-e42510ae-4892-4aee-a33d-22bcdefb8dc6, ...)] INFO -- :
Powering on VM: <[Vim.VirtualMachine] vm-448>
(vm-1590735d-6ae3-4d61-a99b-852119ea5e12)
I, [2012-07-25T02:13:20.908363 #13735] [create_disk(4096, _)] INFO -- :
Creating disk with size: 4096
I, [2012-07-25T02:13:20.910703 #13735] [create_disk(4096, _)] INFO -- :
Created disk: #<VSphereCloud::Models::Disk @values={:id=>1, :path=>nil,
:datacenter=>nil, :datastore=>nil, :size=>4096}>

I, [2012-07-25T02:13:20.913065 #13735]
[attach_disk(vm-1590735d-6ae3-4d61-a99b-852119ea5e12, 1)] INFO -- :
Attaching disk: 1 on vm: vm-1590735d-6ae3-4d61-a99b-852119ea5e12
I, [2012-07-25T02:13:21.021381 #13735]
[attach_disk(vm-1590735d-6ae3-4d61-a99b-852119ea5e12, 1)] INFO -- : Found
requested resource pool BOSH-VMS under cluster ESXCLUSTER
I, [2012-07-25T02:13:21.106660 #13735]
[attach_disk(vm-1590735d-6ae3-4d61-a99b-852119ea5e12, 1)] INFO -- : Need
to create disk
I, [2012-07-25T02:13:21.401283 #13735]
[attach_disk(vm-1590735d-6ae3-4d61-a99b-852119ea5e12, 1)] INFO -- :
Reading current agent env:
{"vm"=>{"name"=>"vm-1590735d-6ae3-4d61-a99b-852119ea5e12", "id"=>"vm-448"},
"agent_id"=>"bm-e42510ae-4892-4aee-a33d-22bcdefb8dc6",
"networks"=>
{"bosh"=>
{"cloud_properties"=>{"name"=>"VM Network"},
"netmask"=>"255.255.255.128",
"gateway"=>"W.X.Y.Z",
"ip"=>"W1.X1.Y1.Z1",
"dns"=>["W2.X2.Y2.Z2"],
"type"=>nil,
"default"=>["dns", "gateway"],
"mac"=>"00:50:56:9c:92:6d"}},
"disks"=>{"system"=>0, "ephemeral"=>1, "persistent"=>{}},
"ntp"=>["W3.X3.Y3.Z3"],
"blobstore"=>
{"plugin"=>"local",
"properties"=>{"blobstore_path"=>"/var/vcap/micro_bosh/data/cache"}},
"mbus"=>"http://vcap:b00tstrap@0.0.0.0:6868",
"env"=>{"bosh"=>{"password"=>"passwd123"}}}

I, [2012-07-25T02:13:21.403062 #13735]
[attach_disk(vm-1590735d-6ae3-4d61-a99b-852119ea5e12, 1)] INFO -- :
Updating agent env to:
{"vm"=>{"name"=>"vm-1590735d-6ae3-4d61-a99b-852119ea5e12", "id"=>"vm-448"},
"agent_id"=>"bm-e42510ae-4892-4aee-a33d-22bcdefb8dc6",
"networks"=>
{"bosh"=>
{"cloud_properties"=>{"name"=>"VM Network"},
"netmask"=>"255.255.255.128",
"gateway"=>"W.X.Y.Z",
"ip"=>"W1.X1.Y1.Z1",
"dns"=>["W2.X2.Y2.Z2"],
"type"=>nil,
"default"=>["dns", "gateway"],
"mac"=>"00:50:56:9c:92:6d"}},
"disks"=>{"system"=>0, "ephemeral"=>1, "persistent"=>{"1"=>2}},
"ntp"=>["W3.X3.Y3.Z3"],
"blobstore"=>
{"plugin"=>"local",
"properties"=>{"blobstore_path"=>"/var/vcap/micro_bosh/data/cache"}},
"mbus"=>"http://vcap:b00tstrap@0.0.0.0:6868",
"env"=>{"bosh"=>{"password"=>"passwd123"}}}

I, [2012-07-25T02:13:23.169140 #13735]
[attach_disk(vm-1590735d-6ae3-4d61-a99b-852119ea5e12, 1)] INFO -- :
Attaching disk
I, [2012-07-25T02:13:27.205385 #13735]
[attach_disk(vm-1590735d-6ae3-4d61-a99b-852119ea5e12, 1)] INFO -- :
Finished attaching disk
W, [2012-07-25T02:13:28.220863 #13735] [0x5ae8d0] WARN -- : !!!
mount_disk(1) failed !!! retrying...
I, [2012-07-25T02:13:50.317486 #13735] [0x5ae8d0] INFO -- : Director is
ready: {"name"=>"micro", "uuid"=>"ec8d0b4a-6efc-4790-b3e2-884b4d116968",
"version"=>"0.4 (00000000)", "user"=>nil}


Tasks and logs on vsphere show no anomaly as well. But I am not able to
login to the provisioned VM using root/passwd123

Did I miss something?
Are there more logs that I can look at? Is there way to increase log
details?
Are there default credentials for the bosh-stemcell-vsphere-0.6.1 stemcell?

Appreciate all the help I can get on this
Thanks

Search Discussions

Discussion Posts

Previous

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 2 | next ›
Discussion Overview
groupbosh-users @
postedJul 25, '12 at 6:27a
activeJul 25, '12 at 1:20p
posts2
users1

1 user in discussion

Ankit: 2 posts

People

Translate

site design / logo © 2022 Grokbase