Hi,Brown
     Thank you for your prompt reply!Can you explain what the difference
between "rake stemcell:basic["openstack"]" and "bundle exec rake
stemcell:basic["openstack"]"?And during my creation of micro-bosh
stemcell,exactly speaking,in the bosh_micro stage,I find the following
information:

Building native extensions. This could take a while...
Successfully installed highline-1.6.20
Successfully installed crack-0.3.2
Successfully installed monit_api-1.5.0.pre
Successfully installed netaddr-1.5.0
Successfully installed posix-spawn-0.3.6
Successfully installed log4r-1.1.10
Successfully installed ruby-hmac-0.4.0
Successfully installed ruby-atmos-pure-1.0.5
Successfully installed rack-1.4.5
Successfully installed eventmachine-0.12.10
Successfully installed daemons-1.1.9
Successfully installed thin-1.5.1
Successfully installed uuidtools-2.1.4
Successfully installed yajl-ruby-1.1.0
Successfully installed nokogiri-1.5.10
Successfully installed aws-sdk-1.8.1.3
Successfully installed builder-3.1.4
Successfully installed excon-0.29.0
Successfully installed formatador-0.2.4
Successfully installed multi_json-1.8.2
Successfully installed mime-types-2.0
Successfully installed net-ssh-2.7.0
Successfully installed net-scp-1.0.4
Successfully installed fog-1.9.1
Successfully installed httpclient-2.2.4
Successfully installed bosh_common-1.5.0.pre
Successfully installed blobstore_client-1.5.0.pre
Successfully installed gibberish-1.2.2
Successfully installed bosh_encryption-1.5.0.pre
Successfully installed tilt-1.4.1
Successfully installed backports-3.3.5
Successfully installed sinatra-1.2.9
Successfully installed json_pure-1.7.7
Successfully installed nats-0.4.28
Successfully installed sigar-0.7.2
Successfully installed ffi-1.9.3
Successfully installed sys-filesystem-1.1.1
Successfully installed bosh_agent-1.5.0.pre
38 gems installed

Well,there is "bosh_agent-1.5.0.pre" installed.However,when I type "gem
list" to show the gem packages installed,the result turns out to be like
these:
addressable (2.3.5)
archive-tar-minitar (0.5.2)
aws-sdk (1.8.1.3)
backports (3.3.5)
bcrypt-ruby (3.0.1)
builder (3.1.4)
bundler (1.3.5)
bundler-unload (1.0.2)
crack (0.3.2)
daemons (1.1.9)
em-http-request (0.3.0)
escape_utils (1.0.0)
eventmachine (0.12.10)
excon (0.29.0)
executable-hooks (1.2.6)
ffi (1.9.3)
fog (1.9.1)
formatador (0.2.4)
gibberish (1.2.2)
highline (1.6.20)
httpclient (2.2.4)
json (1.8.1)
json_pure (1.7.7)
little-plugger (1.1.3)
log4r (1.1.10)
logging (1.5.2)
membrane (0.0.2)
mime-types (2.0)
minitar (0.5.4)
multi_json (1.8.2)
nats (0.4.28)
net-scp (1.0.4)
net-ssh (2.7.0)
net-ssh-gateway (1.1.2)
netaddr (1.5.0)
nokogiri (1.5.10)
pg (0.17.0)
posix-spawn (0.3.6)
progressbar (0.9.2)
rack (1.4.5)
rack-test (0.6.2)
rake (10.1.0, 10.0.4)
redis (3.0.6)
redis-namespace (1.3.2)
resque (1.23.1)
rest-client (1.6.7)
retryable (1.3.2)
ruby-atmos-pure (1.0.5)
ruby-hmac (0.4.0)
rubygems-bundler (1.4.2)
rvm (1.11.3.8)
sequel (3.43.0)
sigar (0.7.2)
sinatra (1.2.9)
sqlite3 (1.3.8)
sys-filesystem (1.1.1)
terminal-table (1.4.5)
thin (1.5.1)
tilt (1.4.1)
trollop (1.16.2)
uuidtools (2.1.4)
vegas (0.1.11)
yajl-ruby (1.1.0)

There is no "bosh_agent-1.5.0.pre"!Can you help me explain why?

--------------
Best regards,
Frank


2013/11/14 Chris Brown <cb@pivotallabs.com>
Try using `bundle exec rake stemcell:basic["openstack"]` instead. It
looks as if some of the local gems aren't in your GEMPATH.

On Wed, Nov 13, 2013 at 8:36 AM, wrote:

When I try to create bosh stemcell by typing:
rake stemcell:basic["openstack"]
Every thing is ok until it enter the stage of bosh_micro,and I get the
following error message:

Successfully installed agent_client-1.5.0.pre
Successfully installed trollop-1.16.2
Successfully installed package_compiler-1.5.0.pre
3 gems installed
Starting micro bosh compilation
Starting BOSH Agent for compiling micro bosh package, agent pid is 15959
/var/vcap/bosh/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require': cannot load such file -- bosh_agent (LoadError)
from /var/vcap/bosh/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from /var/vcap/bosh/lib/ruby/gems/1.9.1/gems/bosh_agent-1.5.0.pre/bin/bosh_agent:5:in
`<top (required)>'
from /var/vcap/bosh/bin/bosh_agent:23:in `load'
from /var/vcap/bosh/bin/bosh_agent:23:in `<main>'
/var/vcap/bosh/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require': cannot load such file -- package_compiler (LoadError)
from /var/vcap/bosh/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from /var/vcap/bosh/lib/ruby/gems/1.9.1/gems/package_compiler-1.
5.0.pre/bin/package_compiler:4:in `<top (required)>'
from /var/vcap/bosh/bin/package_compiler:23:in `load'
from /var/vcap/bosh/bin/package_compiler:23:in `<main>'


I feel confused because I already have built bosh release.And as the
message shows,so that I have "Successfully installed
package_compiler-1.5.0.pre",why it tell me "/var/vcap/bosh/lib/ruby/site_
ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such
file -- package_compiler (LoadError)"?

So,can anyone tell me why and offer some suggestions?

------------------
Best regards,
Frank

To unsubscribe from this group and stop receiving emails from it, send
an email to bosh-dev+unsubscribe@cloudfoundry.org.
To unsubscribe from this group and stop receiving emails from it, send an email to bosh-dev+unsubscribe@cloudfoundry.org.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 3 of 7 | next ›
Discussion Overview
groupbosh-dev @
postedNov 13, '13 at 8:36a
activeNov 15, '13 at 7:06a
posts7
users4

People

Translate

site design / logo © 2021 Grokbase