FAQ
Thanks for bringing this up. I've opened an internal ticket for this and we
will get it fixed in a future CM release.

For now you can use oozie-site.xml safety valve to set "oozie.base.url" to
the correct value with "https" in it and hue server safety valve to
set oozie_url. The CM UI will still point to http URL, but you will be able
to submit jobs from Hue to Oozie.

On Fri, Apr 18, 2014 at 4:49 PM, Vikram Bajaj wrote:

To use Loadbalancer SSL (LB SSL --> Oozie Non SSL) I tried setting up the
loadbalancer to redirect from port 80 to 443. This works with the WEB UI,
but in HUE when we submit a job it fails to follow the redirect.

This looks like a limitation and probably a bug, that oozie cannot use a
LB configured for SSL.

Regards,
Vikram

On Thu, Apr 17, 2014 at 6:59 PM, Vikram Bajaj wrote:

Thanks!, That works.

Another question was regarding the loadbalancer URL. The loadbalancer URL
is set to <lb>:443 (SSL), but when clicked from CM (WEB UI), by default it
uses http://<lb>:443 instead of https. How do we say it's https?

Regards,
Vikram

On Thu, Apr 17, 2014 at 6:19 PM, Vikram Srivastava wrote:

Yes. Make sure to configure all database properties before calling this.

def create_oozie_db(self):
"""
Creates the Oozie Database Schema in the configured database.

@return: Reference to the submitted command.
@since: API v2
"""

On Thu, Apr 17, 2014 at 6:17 PM, Vikram Bajaj wrote:

Thank!! Is there a python API available for this? I presume it should
be.
On Apr 17, 2014 6:15 PM, "Vikram Srivastava" <vikrams@cloudera.com>
wrote:
Once you've configured Oozie in CM, you should run Create Database
command from Oozie service in CM UI instead of running it from command line.

On Thu, Apr 17, 2014 at 6:11 PM, Vikram Bajaj wrote:

Hi,

While setting up the oozie service with mysql database, oozie does
not create schema automatically in CDH5 as opposed to CDH4.

The document says "The Oozie database tool works in 2 modes: it can
create the database, or it can produce an SQL script that a database
administrator can run to create the database manually. If you use the tool
to create the database schema, you must have the permissions needed to
execute DDL operations."

So how do we use the auto db create mode? I did try adding the
property

<property>
<name>oozie.db.schema.create</name>
<value>true</value>
</property>

To oozie-site.xml via the CM, but I still do not see the tables being
created.

Running ./ooziedb.sh create -run creates the tables in the local
derby but how do we pass the mysql parameters that are set as part of Oozie
service creation via CM?

Regards,
Vikram

To unsubscribe from this group and stop receiving emails from it,
send an email to scm-users+unsubscribe@cloudera.org.
To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 7 of 8 | next ›
Discussion Overview
groupscm-users @
categorieshadoop
postedApr 18, '14 at 1:11a
activeApr 19, '14 at 12:08a
posts8
users2
websitecloudera.com
irc#hadoop

2 users in discussion

Vikram Bajaj: 5 posts Vikram Srivastava: 3 posts

People

Translate

site design / logo © 2022 Grokbase