FAQ
While adding a node thru Cloudera manager installation failing at
hadoopfuse installation

Installing hadoop-0.20-mapreduce package...

BEGIN sudo yum list installed hadoop-0.20-mapreduce
Loaded plugins: rhnplugin, versionlock
Installed Packages
hadoop-0.20-mapreduce.x86_64 2.0.0+1475-1.cdh4.4.0.p0.23.el6 @cloudera-cdh4
END (0)
BEGIN echo jdk cloudera-manager-agent cloudera-manager-daemons | grep
hadoop-0.20-mapreduce
  END (1)
remote package hadoop-0.20-mapreduce is already installed


Installing hadoop-hdfs-fuse package...

BEGIN sudo yum list installed hadoop-hdfs-fuse
Loaded plugins: rhnplugin, versionlock
Error: No matching Packages to list
END (1)
BEGIN sudo yum info hadoop-hdfs-fuse
Loaded plugins: rhnplugin, versionlock
Available Packages
Name : hadoop-hdfs-fuse
Arch : x86_64
Version : 2.0.0+960
Release : 1.cdh4.2.1.p0.9.el6
Size : 21 k
Repo : cloudera_cdh4_rhel6_x86_64
Summary : Mountable HDFS
License : Apache License v2.0
Description : These projects (enumerated below) allow HDFS to be mounted
(on
: most flavors of Unix) as a standard file system using

END (0)
BEGIN sudo yum -y install hadoop-hdfs-fuse
Loaded plugins: rhnplugin, versionlock
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package hadoop-hdfs-fuse.x86_64 0:2.0.0+960-1.cdh4.2.1.p0.9.el6 will
be installed
  --> Processing Dependency: hadoop-libhdfs = 2.0.0+960-1.cdh4.2.1.p0.9.el6
for package: hadoop-hdfs-fuse-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
  --> Processing Dependency: hadoop = 2.0.0+960-1.cdh4.2.1.p0.9.el6 for
package: hadoop-hdfs-fuse-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
  --> Processing Dependency: hadoop-client = 2.0.0+960-1.cdh4.2.1.p0.9.el6
for package: hadoop-hdfs-fuse-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
  --> Running transaction check
---> Package hadoop-hdfs-fuse.x86_64 0:2.0.0+960-1.cdh4.2.1.p0.9.el6 will
be installed
  --> Processing Dependency: hadoop = 2.0.0+960-1.cdh4.2.1.p0.9.el6 for
package: hadoop-hdfs-fuse-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
  --> Processing Dependency: hadoop-client = 2.0.0+960-1.cdh4.2.1.p0.9.el6
for package: hadoop-hdfs-fuse-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
  ---> Package hadoop-libhdfs.x86_64 0:2.0.0+960-1.cdh4.2.1.p0.9.el6 will be
installed
  --> Processing Dependency: hadoop-hdfs = 2.0.0+960-1.cdh4.2.1.p0.9.el6 for
package: hadoop-libhdfs-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
  --> Finished Dependency Resolution
Error: Package: hadoop-hdfs-fuse-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
(cloudera_cdh4_rhel6_x86_64)
  Requires: hadoop = 2.0.0+960-1.cdh4.2.1.p0.9.el6
Installed: hadoop-2.0.0+1475-1.cdh4.4.0.p0.23.el6.x86_64 (@cloudera-cdh4)
hadoop = 2.0.0+1475-1.cdh4.4.0.p0.23.el6
Available: hadoop-2.0.0+552-1.cdh4.1.2.p0.27.el6.x86_64 (cloudera-cdh4)
hadoop = 2.0.0+552-1.cdh4.1.2.p0.27.el6
Available: hadoop-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
(cloudera_cdh4_rhel6_x86_64)
  hadoop = 2.0.0+960-1.cdh4.2.1.p0.9.el6
Error: Package: hadoop-libhdfs-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
(cloudera_cdh4_rhel6_x86_64)
  Requires: hadoop-hdfs = 2.0.0+960-1.cdh4.2.1.p0.9.el6
Installed: hadoop-hdfs-2.0.0+1475-1.cdh4.4.0.p0.23.el6.x86_64
(@cloudera-cdh4)
hadoop-hdfs = 2.0.0+1475-1.cdh4.4.0.p0.23.el6
Available: hadoop-hdfs-2.0.0+552-1.cdh4.1.2.p0.27.el6.x86_64
(cloudera-cdh4)
hadoop-hdfs = 2.0.0+552-1.cdh4.1.2.p0.27.el6
Available: hadoop-hdfs-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
(cloudera_cdh4_rhel6_x86_64)
  hadoop-hdfs = 2.0.0+960-1.cdh4.2.1.p0.9.el6
Error: Package: hadoop-hdfs-fuse-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
(cloudera_cdh4_rhel6_x86_64)
  Requires: hadoop-client = 2.0.0+960-1.cdh4.2.1.p0.9.el6
Installed: hadoop-client-2.0.0+1475-1.cdh4.4.0.p0.23.el6.x86_64
(@cloudera-cdh4)
  hadoop-client = 2.0.0+1475-1.cdh4.4.0.p0.23.el6
Available: hadoop-client-2.0.0+552-1.cdh4.1.2.p0.27.el6.x86_64
(cloudera-cdh4)
hadoop-client = 2.0.0+552-1.cdh4.1.2.p0.27.el6
Available: hadoop-client-2.0.0+960-1.cdh4.2.1.p0.9.el6.x86_64
(cloudera_cdh4_rhel6_x86_64)
  hadoop-client = 2.0.0+960-1.cdh4.2.1.p0.9.el6
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
MegaCli-8.02.16-1.i386 has missing requires of Lib_Utils
END (1)
remote package hadoop-hdfs-fuse could not be installed, giving up
waiting for rollback request



Close



To unsubscribe from this group and stop receiving emails from it, send an email to scm-users+unsubscribe@cloudera.org.

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 2 | next ›
Discussion Overview
groupscm-users @
categorieshadoop
postedOct 24, '13 at 6:54p
activeOct 25, '13 at 7:00a
posts2
users1
websitecloudera.com
irc#hadoop

1 user in discussion

Narayan chalasani: 2 posts

People

Translate

site design / logo © 2022 Grokbase