FAQ
Hi Andy,

Can you get the impalad and statestore log and provide it to us. The
stderr/stdout log is from the bash file that launches impalad/statestore.
The log from impalad/statestore will tell us more on why we can't start
these daemons.

Thanks,
Vikas

On Thu, Aug 8, 2013 at 8:17 AM, Andy wrote:

Hi all,

I install Impala on Ubuntu server 12.04 using Cloudera
Manager 4.6.2, Parcels. Then I add services: HDFS, Hive, MapReduce, Impala.

HDFS, Hive, MapReduce services work fine, the status is Good health. But I
can't start Impala, the error is:

*Supervisor returned FATAL. Please check the role log file, stderr, or
stdout.*
*
*
The error log is:

*+
HADOOP_CONF_DIR=/run/cloudera-scm-agent/process/208-impala-IMPALAD/hadoop-conf
*
*+ export
HIVE_CONF_DIR=/run/cloudera-scm-agent/process/208-impala-IMPALAD/hive-conf
*
*+
HIVE_CONF_DIR=/run/cloudera-scm-agent/process/208-impala-IMPALAD/hive-conf
*
*+ export
HBASE_CONF_DIR=/run/cloudera-scm-agent/process/208-impala-IMPALAD/hbase-conf
*
*+
HBASE_CONF_DIR=/run/cloudera-scm-agent/process/208-impala-IMPALAD/hbase-conf
*
*+
JDBC_JARS=/usr/share/java/mysql-connector-java.jar:/usr/share/cmf/lib/postgresql-9.0-801.jdbc4.jar:/usr/share/java/oracle-connector-java.jar
*
*+ [[ -z '' ]]*
*+ export
AUX_CLASSPATH=/usr/share/java/mysql-connector-java.jar:/usr/share/cmf/lib/postgresql-9.0-801.jdbc4.jar:/usr/share/java/oracle-connector-java.jar
*
*+
AUX_CLASSPATH=/usr/share/java/mysql-connector-java.jar:/usr/share/cmf/lib/postgresql-9.0-801.jdbc4.jar:/usr/share/java/oracle-connector-java.jar
*
*+ [[ -z '' ]]*
*+ export
CLASSPATH=/usr/share/java/mysql-connector-java.jar:/usr/share/cmf/lib/postgresql-9.0-801.jdbc4.jar:/usr/share/java/oracle-connector-java.jar
*
*+
CLASSPATH=/usr/share/java/mysql-connector-java.jar:/usr/share/cmf/lib/postgresql-9.0-801.jdbc4.jar:/usr/share/java/oracle-connector-java.jar
*
*+
FLAG_FILE=/run/cloudera-scm-agent/process/208-impala-IMPALAD/impala-conf/impalad_flags
*
*+ USE_DEBUG_BUILD=false*
*+ perl -pi -e
's#{{CMF_CONF_DIR}}#/run/cloudera-scm-agent/process/208-impala-IMPALAD#g'
/run/cloudera-scm-agent/process/208-impala-IMPALAD/impala-conf/impalad_flags
*
*+ '[' -f
/run/cloudera-scm-agent/process/208-impala-IMPALAD/impala-conf/.htpasswd ']'
*
*+ chmod 600
/run/cloudera-scm-agent/process/208-impala-IMPALAD/impala-conf/.htpasswd*
*+ false*
*+ export
IMPALA_BIN=/opt/cloudera/parcels/IMPALA-1.1-1.p0.8/lib/impala/sbin-retail*
*+
IMPALA_BIN=/opt/cloudera/parcels/IMPALA-1.1-1.p0.8/lib/impala/sbin-retail*
*+ '[' impalad = impalad ']'*
*+ exec
/opt/cloudera/parcels/IMPALA-1.1-1.p0.8/lib/impala/../../bin/impalad
--flagfile=/run/cloudera-scm-agent/process/208-impala-IMPALAD/impala-conf/impalad_flags
*
*
*
Are there anyone know how to fix this problem? Thank you.
*
*

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 12 | next ›
Discussion Overview
groupimpala-user @
categorieshadoop
postedAug 8, '13 at 3:17p
activeSep 4, '13 at 4:45p
posts12
users3
websitecloudera.com
irc#hadoop

3 users in discussion

Andy: 6 posts Vikas Singh: 5 posts Kieran Evans: 1 post

People

Translate

site design / logo © 2022 Grokbase