FAQ
Hello,

It looks to me like you are running the old version of impala shell. Your
output shows the shell at v1.0.1 and the server at version 1.1. How did you
do the update? Are you using cloudera manager + parcels or a package system
like yum?

Thanks,
Alan Jackoway

On Thu, Aug 1, 2013 at 11:56 AM, Mani wrote:

I have recently upgraded Impala to v1.0.1. I get error "RPC Error:
Deprecated RPC; please update your client" when I run refresh command from
Impala-shell prompt. Other commands and queries are working fine. Please
let me know what I am missing here.

[localhost:21000] > version;
Shell version: Impala Shell v1.0.1 (df844fb) built on Tue Jun 4 08:08:13
PDT 2013
Server version: impalad version 1.1 RELEASE (build
5e15fcacc48ec4ea65e8aa76362cb3ec9be26f13)
[localhost:21000] > refresh;
*RPC Error: Deprecated RPC; please update your client*
[localhost:21000] >

Thanks
Mani

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 2 of 5 | next ›
Discussion Overview
groupimpala-user @
categorieshadoop
postedAug 1, '13 at 3:56p
activeAug 1, '13 at 9:21p
posts5
users4
websitecloudera.com
irc#hadoop

People

Translate

site design / logo © 2022 Grokbase