FAQ
Hello CentOS Xen experts,

I am attempting my first Xen installation. I have a Centos 5.2 server
(dom0) and am attempting to install a Centos 5.2 guest (domU). The
install goes fine with one exception. At the end it complains "error
mounting /boot". My efforts googling around the net to dig up a
solution have come up empty, although I've seen similar issues reported.
Details below. Any suggests would be much appreciated.

I've read this: http://wiki.centos.org/HowTos/Xen/InstallingCentOSDomU
but have not yet tried it. However, I would expect the same result,
since it describes a simple variation of a normal Anaconda install.

Details:

* Centos 5.2 installation command, installing Centos 5.2 as the guest OS
using nfs mounted Centos 5.2 iso dvd image:
virt-install --paravirt -name vm-1 --ram 512 --file /vm/1/vm-1.img
--file-size -4 --nographcs --location:nfs:192.168.1.101:/mnt/iso
I select a minimal server config during the install that I know fits
in 4 GB. Not much more than the base packages.

* Last install (Anaconda) screen:
"Error mounting device xvda1 as /boot: Read-only file system"
"This most likely means this partition has not been formated."

* Error on reboot after install:
virDomainCreate() failed POST operation failed: (xend.err "Error
creating doamain: Boot loader didn't return any data!")

The /etc/xen/vm-1 and /vm/1/vm-1.img files exist as expected after the
install but will not boot.

Thanks,
Jim Trainor

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 5 | next ›
Discussion Overview
groupcentos-virt @
categoriescentos
postedJan 15, '09 at 3:22a
activeJan 16, '09 at 1:13p
posts5
users2
websitecentos.org
irc#centos

2 users in discussion

Jim Trainor: 3 posts Kai Schaetzl: 2 posts

People

Translate

site design / logo © 2022 Grokbase