FAQ
I have a warning that this 'new AutoAdapter(dataSource)' is
deprecated.

What do I do instead?

The implementation of the above uses deprecated methods,
otherwise I would have thought that the source provided the
solution on this one.

While injection is an implementation detail, it is used in the
documentation:

/**
* Returns a DbAdapterFactory configured to detect all databases
officially supported
* by Cayenne.
*
* @deprecated since 3.1 in favor of
* {@link
org.apache.cayenne.configuration.server.DbAdapterFactory}
* configured via dependency injection.
*/
public static DbAdapterFactory getDefaultFactory() {
return new DbAdapterFactoryChain(defaultFactories);
}


--
Øyvind Harboe

Can Zylin Consulting help on your project?

US toll free 1-866-980-3434 / International +47 51 87 40 27

http://www.zylin.com/zy1000.html
ARM7 ARM9 ARM11 XScale Cortex
JTAG debugger and flash programmer

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 3 | next ›
Discussion Overview
groupuser @
categoriescayenne
postedFeb 10, '11 at 8:11a
activeFeb 11, '11 at 9:45a
posts3
users2
websitecayenne.apache.org

2 users in discussion

Øyvind Harboe: 2 posts Andrus Adamchik: 1 post

People

Translate

site design / logo © 2022 Grokbase