FAQ
Hi,

ant 1.7.1, jsch-0.1.33, commons-net-1.5.0-dev, Red Hat Enterprise
Linux Server release 5.2 (Tikanga)

I am trying to use ant on one server, which is using sshexec to invoke
ant on a remote server. I also tried creating a shell script that just
executes ant and using that as the command attr value for sshexec. The
shell script also errors out with ant:command not found). I keep
getting:

"Remote command failed with exit status 127

[sshexec] bash: ant: command not found"

ANT_HOME is defined correctly and the $ANT_HOME/bin is added to the
PATH. Both the ant build (and shell script calling the ant build) work
when I am ssh'd into the remote machine. I use the same user for
sshexec as the one that successfully logs in and runs locally. I have
ssh'd into the remote machine from the calling machine and accepted
the key.

THE MAIN DIFFERENCE: This used to work for me in the past on Red Hat
ES 3 (I believe I am remembering the version correctly) and now the
machine is running Red Hat Enterprise Linux Server release 5.2 (Tikanga)

Any ideas what I am doing wrong?

thanks,
-Rob


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

Search Discussions

Discussion Posts

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 1 of 3 | next ›
Discussion Overview
groupuser @
categoriesant
postedSep 3, '08 at 12:31a
activeSep 3, '08 at 12:24p
posts3
users2
websiteant.apache.org

2 users in discussion

Robert Koberg: 2 posts Stefan Bodewig: 1 post

People

Translate

site design / logo © 2022 Grokbase