FAQ
I started testing this on a setup where I manually generate messages and I'm
not able replicate the issue. I think it only happens if there is moderate
load when failing over.

Here is the exact message that shows in the setup where I can replicate the
issue:

2013-05-28 10:42:56,977 | INFO | DB recovered from failure. |
org.apache.activemq.leveldb.LevelDBClient | ActiveMQ NIO Worker 93

This message shows up in my log after a failover when I delete the broken
queue. After that message I have these:

2013-05-28 10:42:56,990 | WARN | Async error occurred:
java.lang.IllegalArgumentException: The subscription does not exist:
ID:xx03-35870-1369757354540-1:3:5:1 |
org.apache.activemq.broker.TransportConnection.Service | ActiveMQ NIO Worker
29
java.lang.IllegalArgumentException: The subscription does not exist:
ID:xx03-35870-1369757354540-1:3:5:1
  at
org.apache.activemq.broker.region.AbstractRegion.messagePull(AbstractRegion.java:432)
  at
org.apache.activemq.broker.region.RegionBroker.messagePull(RegionBroker.java:468)
  at
org.apache.activemq.broker.BrokerFilter.messagePull(BrokerFilter.java:87)



--
View this message in context: http://activemq.2283324.n4.nabble.com/Activemq-5-9-leveldb-replication-issue-tp4667495p4667560.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Search Discussions

Discussion Posts

Previous

Follow ups

Related Discussions

Discussion Navigation
viewthread | post
posts ‹ prev | 4 of 8 | next ›
Discussion Overview
groupusers @
categoriesactivemq
postedMay 26, '13 at 2:22p
activeMar 13, '16 at 2:55a
posts8
users4
websiteactivemq.apache.org

People

Translate

site design / logo © 2022 Grokbase