FAQ

Search Discussions

33 discussions - 155 posts

  • Hi say I have 2 databases, DB1 and DB2 after i preformed a search over these 2 DBs, i have 1 result and I want to delete this resulting doc, how do i identify which database (DB1 / DB2) this document ...
    AndreyAndrey
    Nov 21, 2007 at 9:44 pm
    Jan 11, 2008 at 1:12 pm
  • I run ./configure --with-java and receive this error: checking for java... /usr/bin/java checking for javac... /usr/bin/javac checking for jar... /usr/bin/jar checking for jni.h... yes checking for ...
    Aleph ThomasAleph Thomas
    Nov 5, 2007 at 7:10 pm
    Nov 7, 2007 at 9:52 pm
  • Hi all, I have installed xapian ruby binding on my Leopard, but when i use require 'xapian', it's failed, the errors is: LoadError: no such file to load -- _xapian from ...
    CraX SUNCraX SUN
    Nov 23, 2007 at 6:29 am
    Nov 27, 2007 at 3:04 am
  • Hello, I am attempting to run the smoketest.php file from my devserver and am getting nothing but errors. It looks like it did not install correctly. Yesterday I compiled the source on os x and it ...
    Frank ClaycombFrank Claycomb
    Nov 27, 2007 at 2:25 pm
    Nov 28, 2007 at 7:05 pm
  • Hi all, Can one estimate how big the spelling database would be, based on the total index size and/or the size of the postlist table ? roughly similar to the postlist table. That's with indexing ...
    Fabrice ColinFabrice Colin
    Nov 2, 2007 at 2:31 pm
    Nov 8, 2007 at 11:11 am
  • I upgraded to 1.0.4 and am experiencing some strange problems with the parsing of a number value range. The first line is the query string being passed to the query parser, and the second line is ...
    Jim SpathJim Spath
    Nov 14, 2007 at 8:51 pm
    Dec 21, 2007 at 12:01 pm
  • Hello all, I have a problem, I create a DB using the java binding and will use from PHP and not work, not give me results for a simple search that work in java, now If I make the same but with a ...
    Aleph ThomasAleph Thomas
    Nov 21, 2007 at 1:28 pm
    Nov 23, 2007 at 5:12 pm
  • scriptindex is using well over 200MB of RAM to build our search index. Is this normal? If it is normal, is there anything I can do to reduce the memory usage? This is quickly going to become a ...
    Jim SpathJim Spath
    Nov 16, 2007 at 10:13 pm
    Nov 21, 2007 at 1:50 pm
  • Hi all, I've tried building RPMs for RHEL5 and hit this problem in Search::Xapian: make test fails on test 37: ok 34 - check PositionIterator ok 35 - create TermIterator ok 36 - check TermIterator ...
    Tim BrodyTim Brody
    Nov 8, 2007 at 1:21 pm
    Nov 15, 2007 at 10:26 am
  • I need know if I can make resume of the document, and how, but I need that in the resume appear the words that I am find. An need know too if this can be do using omega. thanks
    Aleph ThomasAleph Thomas
    Nov 6, 2007 at 8:42 pm
    Nov 7, 2007 at 6:18 pm
  • Has anyone made a Ruby Gem package of Xapian? I recently built a Ruby on Rails project and was able to drop in the Ferret Gem (a port of Lucene) and the acts_as_ferret Gem, and searching was easily ...
    Mike BooneMike Boone
    Nov 14, 2007 at 10:03 pm
    Nov 15, 2007 at 2:02 pm
  • Hello all, I need know how make some think as this, I have 4 fields in my DB, I need make search using this way using relevance by field. field1 "Article Title" (0.30) field2 "Article Type" (0.30) ...
    Aleph ThomasAleph Thomas
    Nov 7, 2007 at 4:15 pm
    Nov 7, 2007 at 4:52 pm
  • Hi About the "warming-up" of xapian from the first few queries, in which prespective does it cache the data in? xapian / xapian-binding / filesystem IO? I don't know if that was the right question to ...
    AndreyAndrey
    Nov 23, 2007 at 10:25 pm
    Nov 25, 2007 at 10:48 am
  • Hi all, I have had a problem reported with Xapian running on Windows and have managed to reproduce the problem myself (Windows XP latest service packs, Xapian core 1.0.4). The problem concerns ...
    Charlie HullCharlie Hull
    Nov 21, 2007 at 10:19 am
    Nov 22, 2007 at 10:01 am
  • Hi, sorry to bother you with this, but I couldn't find a satisfying answer to the question at openSUSE or in the xapian mailing list archives. In short, I need to convince our provider to install the ...
    Gregor SchmidGregor Schmid
    Nov 19, 2007 at 5:58 pm
    Nov 19, 2007 at 9:59 pm
  • I am consulting the DB made by omega from PHP, then I need recovery all the files that are pdf and talk about omega for example, my query is: $query_string = "mime:pdf/ AND omega"; ... $qp- ...
    Aleph ThomasAleph Thomas
    Nov 14, 2007 at 3:17 pm
    Nov 14, 2007 at 3:46 pm
  • PHP4's "end of life" is 2007-12-31, though there may be "critical security fixes" until 2008-08-08: http://www.php.net/archive/2007.php#2007-07-13-1 We're currently tentatively looking at releasing ...
    Olly BettsOlly Betts
    Nov 28, 2007 at 8:55 pm
    Dec 2, 2007 at 1:11 am
  • Hi, I want to update a document. The document is identified by the document path e.g. /home/user/file.txt. To find the doc id by the path I need to assign the path to the document. In the FAQ is ...
    Clemens ZeidlerClemens Zeidler
    Nov 19, 2007 at 6:42 pm
    Nov 22, 2007 at 11:49 am
  • Hello all, I need know if this function exist in java, and if not, what I can do... void Xapian::TermGenerator::index_text(const std::string &text, Xapian::termcount weight=1, const std::string ...
    Aleph ThomasAleph Thomas
    Nov 14, 2007 at 6:09 pm
    Nov 15, 2007 at 2:09 pm
  • Hi All, I worked with xapian 0.9.10 and now decided to use xapian 1.0.4 with php5.2.2 on RHEL4 x86_64. Xapian core and php-binding were successfully installed. But simple test for adding docs to ...
    Vasiliy SergeevVasiliy Sergeev
    Nov 13, 2007 at 1:33 pm
    Nov 14, 2007 at 8:11 am
  • Hi, I have an existing database of documents, and I'd like to add a value to each of the documents without having to recreate the entire database. The only way I've thought of to do this is to open ...
    Robert ParkerRobert Parker
    Nov 28, 2007 at 7:23 pm
    Nov 29, 2007 at 12:48 am
  • Hi, I'm trying to adapt the gmane indexer and variant of omega (thankfully made available by GMANE) to search through a set of ~3M messages in all sorts of languages. A couple of questions I could ...
    Thomas ViehmannThomas Viehmann
    Nov 26, 2007 at 8:43 pm
    Nov 28, 2007 at 3:10 pm
  • Hi Is the sort_by_value() currently use string comparasion only? I found it's kind of expenisve by inserting timestamps in the value slot and use it to sort the result, comparing with the ...
    AndreyAndrey
    Nov 27, 2007 at 5:22 am
    Nov 28, 2007 at 5:04 am
  • Hi, I was running xapian-check on an index I just built, and I get a repeated message saying "Unexpected end of data when reading termlist." This happens on all databases I create, either before or ...
    Robert ParkerRobert Parker
    Nov 16, 2007 at 10:20 pm
    Nov 17, 2007 at 12:08 pm
  • t/parser...........ok 1/51# Test 4 got: "Xapian::Query((Zone:(pos=1) OR Ztwo:(pos=2)))" (t/parser.t at line 33) t/parser...........NOK 4# Expected: "Xapian::Query((one:(pos=1) OR two:(pos=2)))" # ...
    Jim LynchJim Lynch
    Nov 13, 2007 at 1:16 am
    Nov 13, 2007 at 7:03 am
  • How I can make the search using prefix in java?, not have implemented yet in the binding? I have the 1.0.4
    Aleph ThomasAleph Thomas
    Nov 9, 2007 at 4:44 pm
    Nov 10, 2007 at 2:09 pm
  • My app work fine, when I have ibxapian_jni.so and xapian_jni.jar in the folder /lib but I need make a .jar that I can run in other server, how I can make the jar for include in it the library and not ...
    Aleph ThomasAleph Thomas
    Nov 8, 2007 at 4:24 pm
    Nov 10, 2007 at 9:15 am
  • hey together, i am evaluating a couple full text solutions and just found my way to xapian. i need to build a search for community users. currently i got about 500.000 users and the search just ...
    Stefan BeckerStefan Becker
    Nov 7, 2007 at 3:21 pm
    Nov 7, 2007 at 4:58 pm
  • hi hi how to achive Query with terms' weight to a Boolean matching? i think my question is unclear/misleading... example I have a document reads: "I am eating an apple while using apple computer" My ...
    AndreyAndrey
    Nov 2, 2007 at 4:49 am
    Nov 2, 2007 at 5:43 am
  • Please any can helpme about I create a DB in java and when use in php give me this error DatabaseOpeningError: Couldn't detect type of database xapian 1.04 and the binding db have flintlock and ...
    Aleph ThomasAleph Thomas
    Nov 30, 2007 at 10:13 pm
    Nov 30, 2007 at 10:13 pm
  • Currently we (attempt to) support building Xapian with any GCC = 2.95. However, I only have access to Debian's GCC "2.95.4" (which is 2.95.3 plus patches) and <sstream was added in GCC 2.95.3, so the ...
    Olly BettsOlly Betts
    Nov 25, 2007 at 3:23 pm
    Nov 25, 2007 at 3:23 pm
  • I have problem with read a database created in xapian for java from PHP, I not receive any result in the search, I make that using the database created in xapian for c and work, any Idea about. ...
    Aleph ThomasAleph Thomas
    Nov 22, 2007 at 4:02 pm
    Nov 22, 2007 at 4:02 pm
  • Xapian version 1.0.4: Installation successful OS: Fedora Core 6 Hardware: 1U server, 8 Core 2GHz Intel CPU, 12 GB memory Indexing: 56 million web pages XAPIAN_FLUSH_THRESHOLD00000 Total Indexing ...
    Kevin DurajKevin Duraj
    Nov 12, 2007 at 7:02 pm
    Nov 12, 2007 at 7:02 pm
Group Navigation
period‹ prev | Nov 2007 | next ›
Group Overview
groupxapian-discuss @
categoriesxapian
discussions33
posts155
users27
websitexapian.org
irc#xapian

27 users for November 2007

Olly Betts: 48 posts Aleph Thomas: 22 posts James Aylett: 17 posts Fabrice Colin: 9 posts Andrey: 7 posts Jim Lynch: 6 posts Jim Spath: 6 posts CraX SUN: 5 posts Frank Claycomb: 4 posts Ron Kass: 3 posts Bill Crawford: 2 posts Charlie Hull: 2 posts Clemens Zeidler: 2 posts Gregor Schmid: 2 posts Kevin Duraj: 2 posts Marcus Rueckert: 2 posts Mike Boone: 2 posts Richard Boulton: 2 posts Robert Parker: 2 posts Tim Brody: 2 posts
show more
Archives