FAQ

Search Discussions

454 discussions - 1,545 posts

  • Hi. I need to send an email using a servlet (Tomcat 4.1 / Debian 3.1), but when I send the form from the jsp page that call the servlet, i get this exception: javax.servlet.ServletException: Servlet ...
    Andrés ReyesAndrés Reyes
    Oct 7, 2005 at 7:34 am
    Oct 13, 2005 at 1:33 pm
  • Hi, Is there an implementation floating around of org.apache.catalina.Host and org.apache.catalina.Context that is very basic, perhaps only serving static resources? thanks, -Rob ...
    Robert KobergRobert Koberg
    Oct 27, 2005 at 5:02 pm
    Oct 29, 2005 at 6:04 pm
  • can someone please remove this email from the list? It's kindof nerving... thanx leon --------------------------------------------------------------------- To unsubscribe, e-mail: ...
    Leon RosenbergLeon Rosenberg
    Oct 7, 2005 at 2:39 pm
    Oct 7, 2005 at 6:55 pm
  • Hi All, I was discussing with someone two common system architectures for a web application environment and thought I'd extend it to the Tomcat community to see their views / thoughts. If we consider ...
    Peter JohnsonPeter Johnson
    Oct 13, 2005 at 5:58 am
    Oct 13, 2005 at 11:07 pm
  • Hello Everyone, I have configured tomcat with apache using mod-jk. Tomcat is running on port : 8080 And Apache is listening on port : 80. I have disabled the directory listing for tomcat by Putting ...
    Gupta, RazatGupta, Razat
    Oct 24, 2005 at 5:41 am
    Oct 28, 2005 at 3:45 am
  • HI I was wandering if anyone has experienced similar scenarios. I have an IIS Web Server which uses JK 1.2 as the connection to the AJP connector to a jboss 4.01 installation. The worker.properties ...
    Steve GauntSteve Gaunt
    Oct 14, 2005 at 10:45 am
    Sep 2, 2009 at 3:22 am
  • I am using the JAASRealm for Tomcat 5.x, and in my JAAS module, I am storing my own Principal subclass as the user principal. In my subsequent servlets, when I invoke the request.getUserPrincipal() ...
    Brad O'HearneBrad O'Hearne
    Oct 16, 2005 at 3:21 am
    Oct 18, 2005 at 10:17 pm
  • Hello All, my web.xml generated from RAD does not work in the Web Sphere Application Server, While the web.xml generated from ecplise 3.1 works fine. I guess the problem lies somewhere in the header ...
    Developer DeveloperDeveloper Developer
    Oct 18, 2005 at 3:59 pm
    Oct 21, 2005 at 11:33 am
  • I have looked through the FAQs and search the web, and although this should be a simple problem, I don't find an answer. I can't start tomcat: Exception during startup processing ...
    Brown wrapBrown wrap
    Oct 19, 2005 at 8:13 pm
    Oct 19, 2005 at 11:36 pm
  • Hi, We're using mod_jk on Apache as a load-balancer for multiple tomcats. We're using Laszlo, so the app is serving up Flash pages. On 2003 Server, everything works great. However, installing on XP ...
    DhayDhay
    Oct 28, 2005 at 3:24 pm
    Nov 17, 2005 at 8:23 am
  • Hi All, I just downloaded tomcat 5.5.12, trying to run it on Solaris 9. I did not make any changes to the config file at all. Just set the environment variables CATALINA_HOME and JAVA_HOME to point ...
    Nick LeeNick Lee
    Oct 28, 2005 at 4:23 pm
    Oct 28, 2005 at 11:33 pm
  • Hi, I am trying to read the universal charater form a text file to my java application that stores them in database. When I use encoding type "GBK" i can read all special charater in chinease, when i ...
    Birendar WaldiyaBirendar Waldiya
    Oct 18, 2005 at 10:02 am
    Oct 19, 2005 at 2:56 pm
  • Hi everybody, I've got a request from my client to force an encoding in the browser, regardless what user have set. When I set encoding inside my filter to Windows-1257 in the HTML source code I see ...
    MarkMark
    Oct 12, 2005 at 2:54 pm
    Oct 14, 2005 at 2:26 pm
  • I tested out my application on 5.5.12 yesterday and noticed one small anomally. I had a JSP in my sitemesh decorator "default.jsp" that ends up wrapping the login page for container managed ...
    Richard MixonRichard Mixon
    Oct 6, 2005 at 1:37 pm
    Oct 12, 2005 at 6:35 pm
  • I have set up a connection pool using the following set up: ___________________________________________________________________________________________- <?xml version="1.0" encoding="iso-8859-1"? ...
    Jeffery S EatonJeffery S Eaton
    Oct 10, 2005 at 3:16 am
    Oct 10, 2005 at 9:14 pm
  • I've written a simple web application consisting of a servlet which does a select from a table and displays the result. It is then packaged as a war and deployed using the tomcat ant task. After ...
    Bogdan CalmacBogdan Calmac
    Oct 26, 2005 at 1:18 am
    Oct 31, 2005 at 6:39 pm
  • My tomcat-users.xml <?xml version='1.0' encoding='utf-8'? <tomcat-users <role rolename="tomcat"/ <role rolename="role1"/ <role rolename="manager"/ <role rolename="admin"/ <user username="tomcat" ...
    梁炳場梁炳場
    Oct 20, 2005 at 2:26 pm
    Oct 21, 2005 at 11:29 pm
  • Hi All, This is probably not strictly a Tomcat question so apologies. If I am using Struts, how can I filter the output so that I convert it into a multipart response? Using a filter probably! But ...
    ALEX HYDEALEX HYDE
    Oct 18, 2005 at 9:02 am
    Oct 18, 2005 at 11:26 am
  • Hi! We have the issue on one of our production boxes, which is running server 5.5.9/ Windows 2003 enterprise release and our second machine is running server 5.5.9/ Windows 2003 standard release. 1) ...
    Lalit BatraLalit Batra
    Oct 13, 2005 at 3:16 am
    Oct 17, 2005 at 3:23 pm
  • Hi List, Honestly, I wish Tomcat web application deployment would be easier/smarter. To pre-empt certain list members from telling me it's my fault, I can assure you my WAR itself is totally 100% no ...
    Allistair CrossleyAllistair Crossley
    Oct 7, 2005 at 3:36 pm
    Oct 11, 2005 at 4:47 pm
  • Anyone know the proper way to handle these messages? I get piles of them in catalina.out ------------ Oct 5, 2005 3:00:23 PM org.apache.jk.common.ChannelSocket processConnection INFO: connection ...
    RickRick
    Oct 5, 2005 at 10:20 pm
    Oct 7, 2005 at 5:37 pm
  • Sorry for off-topic, but there are so many experts here! :-) Does anyone know for sure how much RAM I can use with JAVA 1.4 or 1.5? It seems to me, that the VM don't use more than 1.2 GB RAM even I ...
    Leon RosenbergLeon Rosenberg
    Oct 6, 2005 at 3:54 pm
    Oct 7, 2005 at 2:52 pm
  • Does anybody have a script to create a tomcat service on windows 2000? I'm trying to set my system up to run multiple copies of tomcat at the same time (on different ports, obviously), and can't get ...
    David KerberDavid Kerber
    Oct 3, 2005 at 4:16 pm
    Oct 4, 2005 at 3:30 pm
  • Infact, i am unable to start all tomcat instances and result is follwoing error.... Pls help!! Hi, I am unable to start one of my tomcat instances. But its getting crashed before it starts. Follwoing ...
    Nehal SangoiNehal Sangoi
    Oct 31, 2005 at 6:03 am
    Oct 31, 2005 at 10:35 am
  • Frequently we were getting "Cannot get a connection, pool exhausted" error on production. I know in our application, we are closing the connection after each connection. Here is our context.xml ...
    KUMAR, NANDA [AG-Contractor/1000]KUMAR, NANDA [AG-Contractor/1000]
    Oct 26, 2005 at 3:14 pm
    Oct 27, 2005 at 6:19 pm
  • All, I have discovered a bug in role authorization when using a JAASRealm and custom user / role principals. In a nutshell, successful authentication in the JAASRealm over a custom JAAS login module ...
    Brad O'HearneBrad O'Hearne
    Oct 21, 2005 at 3:36 am
    Oct 21, 2005 at 4:56 am
  • Greetings, I have a working JNDIRealm setup that connects with our local Active Directory using the following Realm statement: <Realm className="org.apache.catalina.realm.JNDIRealm" debug="99" ...
    Klotz Jr, DennisKlotz Jr, Dennis
    Oct 14, 2005 at 3:13 pm
    Oct 17, 2005 at 3:21 pm
  • Hello I have a web App with some jsp´s showing graphics generated by jfreechart, in my windows dev station it works fine but in my linux production server it was working fine to some days ago and now ...
    Mauricio Fernandez A.Mauricio Fernandez A.
    Oct 7, 2005 at 6:16 pm
    Oct 11, 2005 at 12:17 pm
  • I started Tomcat using startup.bat. Everything goes fine. I use shutdown.batto bring it down. The server fields the request and shuts down a bunch of services (as evidenced by the messages I see). ...
    Charles FinemanCharles Fineman
    Oct 2, 2005 at 4:09 pm
    Oct 3, 2005 at 9:58 pm
  • Do anyone out there know why I am getting this Tomcat error? SEVERE: Servlet.service() for servlet jsp threw exception javax.faces.el.EvaluationException: java.lang.OutOfMemoryError: PermGen space at ...
    Ritchie GillamRitchie Gillam
    Oct 3, 2005 at 1:22 pm
    Oct 3, 2005 at 4:23 pm
  • Hi, After src/*.java modification I do an "ant compile", "ant reload". Nothing happens. Old class files not overwritten. If I do "ant remove" followed by "ant install": everything is OK (refreshed). ...
    Tamas HegedusTamas Hegedus
    Oct 31, 2005 at 9:13 pm
    Nov 1, 2005 at 4:42 pm
  • Hi, I want to have Tomcat listen to port 80 instead port 8080. However, I don't want to run Tomcat as root. Is this possible? Thank you in advance, Kam ...
    Kam Lung LeungKam Lung Leung
    Oct 26, 2005 at 7:01 pm
    Oct 31, 2005 at 8:04 pm
  • Is there any practical limit to the number of webapps I can run in a single instance of TC 5.5? We would like to use TC 5.5 to support a large number of custom web apps developed for others who then ...
    David WallDavid Wall
    Oct 29, 2005 at 5:41 pm
    Oct 30, 2005 at 7:26 pm
  • Hi all, I am using tomcat JNDI for getting databse connection in my application For this I have created a context.xml file in myAPP/META-INF which looks like this: <?xml version="1.0" ...
    RahulRahul
    Oct 24, 2005 at 2:25 pm
    Oct 27, 2005 at 5:04 am
  • I dont know if it is required, but do you have a resource-ref entry in your web.xml, something like this? <resource-ref <description mySQL Datasource</description <res-ref-name ...
    Peter ZochePeter Zoche
    Oct 25, 2005 at 8:19 am
    Oct 25, 2005 at 10:13 am
  • Hi all, I have couple of questions regarding tomcat startup 1)when the tomcat is started , does it load all the jar file from its lib and create a object of all the classes? 2) if there is a static ...
    Santosh AsbeSantosh Asbe
    Oct 18, 2005 at 4:16 am
    Oct 19, 2005 at 9:14 am
  • I am receiving the following error when trying to run a Struts application. I checked and it seems that I do have all of the appropriate jar files installed. But for some reason, the Action class is ...
    Asad HabibAsad Habib
    Oct 10, 2005 at 1:07 pm
    Oct 15, 2005 at 8:38 am
  • I have a customer running Tomcat 4.0.18. About twice a week their system is locking up - obviously we don't know why or I would not be asking. Symptoms 1) CPU usage per TOP is not very high. 2) When ...
    Richard MixonRichard Mixon
    Oct 14, 2005 at 6:28 am
    Oct 14, 2005 at 2:30 pm
  • Hello: This is a little intimidating, but I am eager. I hope I am in the right place. I am a DHTML developer‹intermediate level. I¹ve been exposed to JSP on an iPlanet server, Sun OS 5.8 (but it is ...
    John GeigerJohn Geiger
    Oct 11, 2005 at 3:33 am
    Oct 11, 2005 at 6:59 pm
  • Hello I've been trying to setup a mysql connection pool using JNDI as shown in http://jakarta.apache.org/tomcat/tomcat-5.0-doc/jndi-datasource-examples-howto.html But no luck. I never get to see the ...
    John CherouvimJohn Cherouvim
    Oct 6, 2005 at 9:18 am
    Oct 7, 2005 at 2:12 am
  • Running Tomcat 5.5.9 on Windows 2000 server. I am trying to change the context path of an application, and it works fine when I put this into my server.xml: <Context path="/wradev/pelican" ...
    David KerberDavid Kerber
    Oct 5, 2005 at 5:58 pm
    Oct 6, 2005 at 12:37 pm
  • Greetings All Does anyone know of bugs in the 5.5.9 release of Tomcat with regards to recompiling Jsp's or incorrectly send SQL statements? The reason I ask is, I do some development of Jsp's in ...
    SchalkSchalk
    Oct 2, 2005 at 12:12 pm
    Oct 4, 2005 at 4:50 pm
  • Hi All, I'm trying to configure a JDBC realm for request users authentication and i'm using netbeans 4.1. I follow the tomcat docs example, and when i use a "memory realm" everything works fine. But ...
    Vicente CoutoVicente Couto
    Oct 27, 2005 at 8:18 pm
    Oct 28, 2005 at 6:15 pm
  • Okay I've spent the last several days going over everything I could find on the web about setting this up and I still can't get it to work. I have the following setup: jCIFS 1.2.6 JBoss 4.0.3 with ...
    Scott ShaverScott Shaver
    Oct 25, 2005 at 9:10 pm
    Oct 28, 2005 at 8:21 am
  • Hi, Quick overview, I'm setting some variables in the session from my servlet to be used in my JSP/JSTL page. Everything is fine if a JSP page is called before the servlet, but a call to the servlet ...
    Michael NeelMichael Neel
    Oct 26, 2005 at 3:12 pm
    Oct 27, 2005 at 8:23 am
  • As I recall, a session can be switched to https from http, but not back - that is considered to be a security hole. You might want to check the mail archives, since I believe it has been discussed a ...
    Caldarale, Charles RCaldarale, Charles R
    Oct 23, 2005 at 9:19 pm
    Oct 25, 2005 at 3:42 pm
  • Hi all I still want to use Tomcat with SSL (still not working). I've got a servlet that acts as a CA. 1. Question(s): Should I have separate keystores (JKS) for the web application and the Tomcat ...
    Raueber HotzenplotzRaueber Hotzenplotz
    Oct 23, 2005 at 12:55 pm
    Oct 23, 2005 at 8:16 pm
  • Hello tomcat users I have hesitated a while before sending up this question, for the presumably obvious reason that hacking the tomcat DefaultServlet is an act of questionable judgement. But there ...
    Maurice YarrowMaurice Yarrow
    Oct 18, 2005 at 1:28 am
    Oct 22, 2005 at 12:31 am
  • Hello, I am trying to setup multiple versions of Tomcat on the same server. The Server already uses Tomcat 3 and I'm trying to setup Tomcat 4 on the same server. What changes do I need to perform to ...
    Bliesner, Christopher PBliesner, Christopher P
    Oct 21, 2005 at 7:26 pm
    Oct 21, 2005 at 8:00 pm
  • We're running Tomcat 5.0.28 with JDK 1.4.2_8 hosting a single commercial web application on our web server which uses MySQL 4.0.26 running on another server. Both servers are Windows 2003 Enterprise, ...
    David BoyerDavid Boyer
    Oct 18, 2005 at 1:04 pm
    Oct 18, 2005 at 2:23 pm
Group Navigation
period‹ prev | Oct 2005 | next ›
Group Overview
groupusers @
categoriestomcat
discussions454
posts1,545
users433
websitetomcat.apache.org
irc#tomcat

433 users for October 2005

Caldarale, Charles R: 68 posts David Delbecq: 40 posts RTE - Meridian Club: 36 posts Mark Thomas: 30 posts Steve Kirk: 29 posts Leon Rosenberg: 25 posts Hassan Schroeder: 22 posts Nehal Sangoi: 22 posts Tim Funk: 22 posts David Kerber: 18 posts Richard Mixon: 18 posts Marcus Franke: 17 posts Mauricio Fernandez A.: 17 posts Brad O'Hearne: 15 posts Allistair Crossley: 13 posts Bob Hall: 13 posts GB Developer: 13 posts Klotz Jr, Dennis: 13 posts Andy gordon: 12 posts Maurice Yarrow: 12 posts
show more
Archives