Search Discussions

224 discussions - 669 posts

  • Hi, i'm looking for a mailing list to contact if i have trouble installing cpan modules. Is it here the right place? But here are no discussions in the last months. Bernd Helmholtz Zentrum Muenchen ...
    Lentes, BerndLentes, Bernd
    Jan 24, 2016 at 5:21 pm
    Jan 24, 2016 at 6:13 pm
  • Hi All, I've recently upgraded to OS X Yosemite, which has perl 5.18. and installed cpan v2.00. When in a cpan session, I cannot see what I type on the command line. Attached is a screenshot example, ...
    Galeb Abu-AliGaleb Abu-Ali
    Apr 4, 2015 at 11:00 pm
    Apr 4, 2015 at 11:00 pm
  • Does anyone know why my avatar doesn't display on pages w/my name on them? If I go to the page with all the avatars in one big page, -- it shows it there, so I'm pretty sure it's associated with my ...
    Linda A. WalshLinda A. Walsh
    Aug 16, 2014 at 12:30 am
    Aug 27, 2014 at 3:53 am
  • Hello, I intend to use cpanm to download perl modules into a secure environment that is guarded by firewalls and have a couple of questions on how to do that. a. I want to be able to verify the perl ...
    Abhijith ChandrashekarAbhijith Chandrashekar
    Jul 18, 2014 at 12:18 am
    Jul 29, 2014 at 9:57 pm
  • Hi there, I'm not able to install any perl modules on one of my RedHat 6.5 servers. Hereunder the issue: [root@xxx jmx4perl-1.10]#cpan Config::General CPAN: Storable loaded ok (v2.20) Going to read ...
    Bob SauvageBob Sauvage
    Jul 8, 2014 at 11:21 am
    Jul 8, 2014 at 11:21 am
  • Seems more recent versions of tars include various extensions that can confuse older versions of tar. I wasn't even aware that my gnu tar defaulted to POSIX 2002 headers (pax) until someone told me ...
    Linda WalshLinda Walsh
    Nov 11, 2013 at 10:55 pm
    Nov 11, 2013 at 10:55 pm
  • In short, there's a series of Perl modules that I end up re-implementing at every company I end up working at. This time around, I want to develop them as CPAN modules. Except: A lot of this is ...
    Dana DiederichDana Diederich
    Mar 12, 2013 at 4:15 pm
    Mar 19, 2013 at 9:38 pm
  • Hi. I'm not even going to pretend to be a Perl programmer (I used it years ago once.) However, I am trying to use CPAN to install a newer version of the DBI module, because the application I am ...
    Christopher HowardChristopher Howard
    Jan 16, 2013 at 12:29 am
    Jan 16, 2013 at 4:39 am
  • Dear all, I am trying to install PDF Lib but it doesn't work or I'm doing something wrong. This is what I did : cpan installPDFLib| But it says : PDFLib requires the pdflib package from ...
    Denis BUCHER (lists)Denis BUCHER (lists)
    Jan 7, 2013 at 5:25 pm
    Jan 8, 2013 at 4:57 pm
  • I am installing on CentOS 5.7 a list of modules via "cpan moduleA moduleB" etc. I have done this before with the same list of modules. Now the process is failing on XML::LibXML, apparently due to a ...
    Dec 19, 2012 at 9:01 am
    Dec 21, 2012 at 9:27 am
  • I've noticed that the Tk::EntryDialog module (Tk-EntryDialog-0.10 distribution) is available on search.cpan.org via the author page: http://search.cpan.org/~rkies/ but not on equivalent page in ...
    Indraniel DasIndraniel Das
    Sep 27, 2012 at 9:15 pm
    Sep 28, 2012 at 6:25 am
  • I see this message in my cpan builds that doesn't make sense. On one hand I see: Checking if your kit is complete... Looks good Writing Makefile for IO::Pty::Easy Writing MYMETA.yml and MYMETA.json ...
    Linda WalshLinda Walsh
    Apr 13, 2012 at 10:14 pm
    Apr 13, 2012 at 10:14 pm
  • I just noticed that WGDAVIS has no cpan modules listed anymore [0]. Could this be an indexing error or were they in fact removed? The modules are still present in backpan. The email address for the ...
    Mar 6, 2012 at 6:50 pm
    Mar 6, 2012 at 8:49 pm
  • I work with a large CPAN installation. SOAP.pm and SOAP::Lite both come with a SOAP::Packager module. So, one or the other of them breaks. Should the dist upload process detect this, and refuse to ...
    Mark HedgesMark Hedges
    Feb 10, 2012 at 12:12 am
    Feb 10, 2012 at 12:16 am
  • On search.cpan.org I can find Protocol::Modbus and it looks like a typical module. I can download it, it's passed tests (including my matching Perl version and platform), etc. But using "cpan", it ...
    Feb 4, 2012 at 11:30 am
    Feb 4, 2012 at 2:42 pm
  • […] Any progress on this one? TIA. cpan i PDL::NetCDF Module id = PDL::NetCDF DESCRIPTION Reads/Writes NetCDF files from/to PDL objs CPAN_USERID DHUNT (Douglas Hunt <dhunt@ucar.edu ) CPAN_VERSION ...
    Ivan ShmakovIvan Shmakov
    Nov 27, 2011 at 9:05 am
    Nov 29, 2011 at 9:16 pm
  • (Forgot to cc list) Just tried this: cpan i /config::inifiles/ Module CGI::Application::Plugin::Config::IniFiles (A/AR/ARTO/CGI-Application-Plugin-Config-IniFiles-0.03.tar.gz) Module Config::IniFiles ...
    Simon Loewenthal/NL/Tele2Simon Loewenthal/NL/Tele2
    Sep 1, 2011 at 10:17 am
    Sep 1, 2011 at 10:33 am
  • Dear everyone, I am trying to install Config::Inifiles on HP-UX 11.31, but it cannot locate this. # perl -MCPAN -e shell Set up gcc environment - 4.2.3 cpan shell -- CPAN exploration and modules ...
    Simon Loewenthal/NL/Tele2Simon Loewenthal/NL/Tele2
    Sep 1, 2011 at 9:42 am
    Sep 1, 2011 at 9:42 am
  • Hi, cpan doesn't have package document in pdf. I'm wondering if the pdf documents can be added for easy downloading. Also, I'd like to be able to download all the documents in a tar.bz2 file. Can ...
    Peng YuPeng Yu
    Aug 9, 2011 at 4:48 am
    Aug 9, 2011 at 10:58 am
  • Hi I am trying to install MediaWiki::Bot module locally on my server (I am not the admin). I am trying to use cpan command line interface for this. I used following options before beginning ...
    Jul 23, 2011 at 12:56 pm
    Jul 24, 2011 at 12:19 am
  • I looked at "perldoc CPAN" and other info, but I can't seem to cleanly install CPAN packages offline. I want to run CPAN normally to install a lot of Perl packages on one machine (CentOS 5.6 x64 ...
    Jun 26, 2011 at 2:50 am
    Dec 7, 2011 at 10:27 am
  • Hello, I installed cpan in my home directory. Platform is Linux. I start it via 'sudo cpan' and try 'upgrade' but got following errors : cpan[3] upgrade .. Running install for module 'Socket' The ...
    Bruno CostacurtaBruno Costacurta
    Jun 6, 2011 at 4:36 pm
    Jun 7, 2011 at 6:40 pm
  • Hi all: I just uploaded a new version (4.13) of PDL::NetCDF with changes suggested by Sisyphus, Robert Ginko and kmx. None of these seem to have helped with the cpan shell. It still shows: ...
    Doug HuntDoug Hunt
    May 6, 2011 at 9:08 pm
    May 16, 2011 at 4:34 pm
  • Hi, I have setup a local repository using CPAN::Mini, but every module i try to install get the same error message: "Package seems to come without Makefile.PL." Even though the file actually exists ...
    Apr 5, 2011 at 2:42 pm
    Apr 5, 2011 at 2:42 pm
  • Hi, I can't register myself to PAUSE. It crash with error 500. Anyone could fix this ?
    Vincent BachelierVincent Bachelier
    Apr 1, 2011 at 10:34 am
    Apr 1, 2011 at 10:34 am
  • I have ties to Andreas of CPAN b/c of my mod_perl involvement and can ask if someone wants me to. The largest reason for where something show up though is if you just release the module or if you've ...
    Philip M. GollucciPhilip M. Gollucci
    Feb 19, 2011 at 5:56 am
    Feb 19, 2011 at 5:56 am
  • Hi, As a FreeBSD port maintainer, its nice to have /modules/by-module/MODULE-VERSION.tar.gz available. However, recently I have discovered that the it hasn't been updated for the ones I'm interested ...
    Feb 11, 2011 at 12:43 am
    Feb 16, 2011 at 7:30 pm
  • Hi, I'm one of the core developers for the BioPerl project. We've had a persistent problem with users grabbing outdated versions of our distributions from CPAN. For example, the distribution ...
    Dave MessinaDave Messina
    Jan 27, 2011 at 4:32 pm
    Jan 28, 2011 at 10:38 am
  • Hi everyone, Im new here and new to this version of Linux. Im running a new install of Fedora core 11. Im in the process of setting everything up as a home server full blown from my home. It's dls. I ...
    Brian BratcherBrian Bratcher
    Oct 1, 2010 at 3:46 am
    Oct 1, 2010 at 8:31 am
  • Hello It is almost 7 months since I started CPAN mirror located in Slovakia. I am a little bit disappointed because it is not listed in cpan mirror list yet. Also I still did not receive any mail ...
    Sep 26, 2010 at 7:38 pm
    Oct 1, 2010 at 2:39 am
  • I'm having what looks like a very similar problem installing several different modules. It has happened the same way on two different machines running Mac OS X 10.6.4 immediately after installing ...
    Aram FingalAram Fingal
    Sep 15, 2010 at 4:52 pm
    Sep 15, 2010 at 4:52 pm
  • Hi, I'm the owner of the FreeOpenSourceSoftware.* domains, donated to the community as the Wiki http://FreeOpenSourceSoftware.org . I'm also the leader of http://Eseri.com, a team of software ...
    Wm StewartWm Stewart
    Sep 15, 2010 at 12:35 pm
    Sep 15, 2010 at 12:35 pm
  • Hi There I am trying to install WWW::Search module as its a pre requisite for =20 WWW::Search::NCBI::PubMed module. But When I try to run my program, its giving me the following error: Use of ...
    Hina DalalHina Dalal
    Sep 8, 2010 at 2:52 pm
    Sep 14, 2010 at 2:40 am
  • Hi ~ I'm running into a number of problems installing the SGML::Parser::OpenSP module on SnowLeopard. Eventually through MacPorts I was able to install the OpenSP libraries themselves, which seem ...
    John galeJohn gale
    May 26, 2010 at 11:27 pm
    May 26, 2010 at 11:27 pm
  • Hi, i have problems installing the above mentioned perl module. The test procedure says: [...] Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, ...
    Lentes, BerndLentes, Bernd
    Apr 27, 2010 at 3:56 pm
    Apr 27, 2010 at 3:56 pm
  • Hey folks, I've asked this recently on the CentOS list and got pointed at a few options, then went looking around and found you guys and figured I'd ask here. I found a thread in the archives about ...
    Alan McKayAlan McKay
    Apr 21, 2010 at 1:53 pm
    Apr 22, 2010 at 3:11 pm
  • From: Ajeet Kumar Sent: Wednesday, March 24, 2010 7:12 PM To: 'cpan-discuss@perl.org!' Subject: CPAN Module Installation problem Hello Everybody.. I have problem regarding perl module installation. I ...
    Ajeet KumarAjeet Kumar
    Mar 24, 2010 at 1:43 pm
    Mar 25, 2010 at 8:45 am
  • Hey All, I'm having trouble compiling either Algorithm::SVM or Algorithm::SVMLight from CPAN. I have pasted the error below. If this is not the correct list for this type of discussion please direct ...
    Francis keyesFrancis keyes
    Jan 14, 2010 at 3:12 am
    Oct 16, 2012 at 7:54 pm
  • Hello, For some time I have been trying to install the Net::Twitter module from CPAN in to my home directory (I do not want to install it system wide until I know that the installation will succeed). ...
    Robert LeveringtonRobert Leverington
    Dec 24, 2009 at 10:45 am
    Dec 24, 2009 at 1:07 pm
  • I'm trying to figure out how to restore the old path to the CPAN preferences because it seems to have changed recently. Which file do I have to edit? NEW: /Users/[USERNAME]/Library/Application ...
    Paul AdamsPaul Adams
    Dec 4, 2009 at 9:45 pm
    Dec 4, 2009 at 9:45 pm
  • I have tried Google searching and searching the CPAN-Discuss mail archives and I cannot figure out why this is failing. This is an Ubuntu server running Perl 5.8.8, and I installed serveral CPAN ...
    Joseph ToppiJoseph Toppi
    Nov 11, 2009 at 6:19 pm
    Nov 11, 2009 at 6:19 pm
  • Here's what happens: ----------- $ sudo perl -MCPAN -e shell Password: Terminal does not support AddHistory. cpan shell -- CPAN exploration and modules installation (v1.9402) Enter 'h' for help. ...
    Tom smithTom smith
    Nov 11, 2009 at 4:06 pm
    Nov 15, 2009 at 9:07 am
  • Hello, The pod to html conversion used on search.cpan.org seems to produce quite nice output. What tool is being used there, and is it publicly available? I couldn't see any evidence in the html ...
    Mitch GowerMitch Gower
    Oct 15, 2009 at 11:34 am
    Oct 21, 2009 at 1:16 pm
  • Hi there, Sending again since I was not sure the first post made it. I am not sure why but the cpan install is failing on my osx 10.5.7 machine. Looks like force is an option is that the recommended ...
    Jul 10, 2009 at 8:20 pm
    Jul 10, 2009 at 8:20 pm
  • # cpan IO::Socket::SSL CPAN: Storable loaded ok (v2.18) Going to read '/var/spool/cpan/sources/authors/01mailrc.txt.gz' CPAN: Compress::Zlib loaded ok (v2.015) CPAN: YAML loaded ok (v0.68) Going to ...
    Asif IqbalAsif Iqbal
    Jun 24, 2009 at 4:06 pm
    Jun 27, 2009 at 3:23 am
  • It seems Apache2::Request has disappeared from the CPAN index. A bug report was opened a few months ago regarding this problem: https://rt.cpan.org/Ticket/Display.html?id=44220 Currently, when ...
    Mike MillerMike Miller
    Jun 19, 2009 at 4:50 pm
    Jun 22, 2009 at 7:34 am
  • Hello, During the install in CPAN of Log::Log4perl, I got a Recursive dependency detected error, which I managed to reduce to: Scalar::Util Test::More Test::Harness File::Spec Scalar::Util (exact ...
    Jean-Denis MuysJean-Denis Muys
    Jun 11, 2009 at 10:21 am
    Jun 11, 2009 at 12:13 pm
  • Hello, When I try to install the Tk::AnstractCanvas module, I get a dependency problem because the module is dependant on itself: $ cpan Tk::AbstractCanvas CPAN: Storable loaded ok (v2.18) [ ... ] ...
    Josef WolfJosef Wolf
    Jun 1, 2009 at 11:28 am
    Jun 3, 2009 at 8:30 pm
  • Hi, I rather new to perl but normally do other languages. I have an issue with CPAN modules. A number of modules are compiled and installed into a build directory from a make file. This directory is ...
    Simon YvertsSimon Yverts
    Apr 9, 2009 at 8:05 pm
    Apr 9, 2009 at 8:08 pm
Group Navigation
period‹ prev | Latest | first ›
Group Overview
groupcpan-discuss @

Top users

Andreas J. Koenig: 40 posts Andreas J. Koenig: 36 posts Adam Kennedy: 32 posts Tyler MacDonald: 27 posts Stas Bekman: 22 posts Randy W. Sims: 21 posts Graham Barr: 16 posts Stephen Liu: 14 posts Tim Bunce: 13 posts Jonathan Yu: 13 posts James Muir: 11 posts Kurtz le pirate: 10 posts Nimectos: 10 posts Milki: 10 posts Doug Hunt: 9 posts Steffen Schwigon: 8 posts Andy Armstrong: 8 posts Ken Williams: 8 posts Thomas Klausner: 7 posts Brian d foy: 7 posts
show more