FAQ

Search Discussions

84 discussions - 340 posts

  • Please tell me I can do= this! = Using mod_perl, how do you keep Perl objects in RAM from page to= page? I don't want to re-instantiate my objects on every= page request, and I don't want the ...
    Peter1 AlvinPeter1 Alvin
    Nov 15, 2005 at 2:11 am
    Nov 23, 2005 at 10:16 am
  • Hello, Is anyone aware of any issues with the way Apache:::DBI works with DBD::Multiplex under Apache2 + modperl 2. I'm experiencing an issue where Apache::DBI seems to remember a connection but ...
    Pierre SmolarekPierre Smolarek
    Nov 22, 2005 at 6:47 pm
    Nov 24, 2005 at 10:17 am
  • Hello. Before Apache::DBI installation I'd using just DBI & PgPP for connecting with my PostgreSQL DataBase: $user = "owner"; $password = "pwd"; $data_source = "dbi:PgPP:mypgdb;localhost;5432"; $dbh ...
    Plymouth RockPlymouth Rock
    Nov 12, 2005 at 2:39 am
    Nov 22, 2005 at 7:09 am
  • p5-DBD-mysql50-3.0002 p5-DBI-1.48 p5-Apache-DBI-0.94_1 I upgraded the database server from the "4" version to "5", so I updated the Perl database Drivers - DBD,DBI, and Apache-DBI. Once I updated the ...
    Paul HarrisonPaul Harrison
    Nov 8, 2005 at 3:45 pm
    Nov 8, 2005 at 4:46 pm
  • Hi, Currently we have package Apache::RegistryLexInfo; @ISA = qw(Apache::RegistryNG); Should the next version which supports mod_perl 1.x and 2.x: o sub class ModPerl::RegistryBB, ...
    Philip M. GollucciPhilip M. Gollucci
    Nov 29, 2005 at 3:50 pm
    Dec 1, 2005 at 4:40 am
  • G'day all - this is my first post to this list. Hope what I write makes sense... I have a mod_perl 1.29 app running on Apache 1.3.31 - it utilises startup scripts as such: httpd.conf: <VirtualHost ...
    Brett RandallBrett Randall
    Nov 13, 2005 at 11:47 pm
    Nov 14, 2005 at 4:27 pm
  • I'm a little confused. And was wondering if I could get a sanity check.. I have a mod perl method handler and at start it runs this code my $is_initial_req = $r- is_initial_req; my $is_main = $r- ...
    Martin MossMartin Moss
    Nov 1, 2005 at 2:32 pm
    Nov 3, 2005 at 8:28 pm
  • Hi I have a cgi script running with mod_perl and mysql that uses utf8 input. As you might know, it is important to issue the command set names "utf8" after initialising the mysql connection, or utf8 ...
    Daniel McBreartyDaniel McBrearty
    Nov 3, 2005 at 7:12 pm
    Nov 6, 2005 at 7:50 pm
  • Hi, I have just uploaded Apache::DBI::Cache to cpan. The module aims at the same problems as Apache::DBI but works different. While Apache::DBI caches connections at connect time this module caches ...
    Torsten FoertschTorsten Foertsch
    Nov 30, 2005 at 10:35 am
    Dec 5, 2005 at 8:33 pm
  • All, During the Authentication phase, Any custom responses that need to be sent back to a user, MUST be sent with FORBIDDEN using custom_repsonse? Under Authentication 200 (OK) simply lets Apache ...
    Martin MossMartin Moss
    Nov 10, 2005 at 3:57 pm
    Nov 10, 2005 at 7:08 pm
  • I'm trying to use Apache::Monitor with mod_perl2, but it fails to load it. I changed some code because it didn't detected it was running inside mod_perl2 ,but I'm unable to fix it more. This is the ...
    Francesc GuaschFrancesc Guasch
    Nov 22, 2005 at 12:32 pm
    Nov 25, 2005 at 5:00 pm
  • Hello Everybody, I am Using a Trouble ticketing System- OTRS it is running on mod_perl, I am trying to configure " Preestablish datababase connections" During httpd process startup: I have configured ...
    KartheeKKartheeK
    Nov 17, 2005 at 7:42 am
    Nov 19, 2005 at 6:18 pm
  • sorry to resend this in case you all received it, (also forgot to mention that the same cgi mentioned below runs fine from the command line) a.r.
    Abul RahmanAbul Rahman
    Nov 10, 2005 at 3:00 pm
    Nov 11, 2005 at 9:10 pm
  • As soon as I preload Image::Magick under mod_perl2 on FreeBSD (5.3, 5.4 and 6.0) I get a "Segmentation fault (core dumped)" when I start Apache. Without preloading it works fine. What's the best ...
    Len KranendonkLen Kranendonk
    Nov 9, 2005 at 11:34 am
    Nov 9, 2005 at 5:58 pm
  • I have recently had a bit of exposure to Class:DBI and CGI::Application in a project running under CGI. My (brief) experience of both is that they cut the code you have to write dramatically, making ...
    Clinton GormleyClinton Gormley
    Nov 2, 2005 at 3:10 pm
    Nov 9, 2005 at 11:01 am
  • Hello, everybody. I have: FreeBSD 4.7 Apache 2.0.54 mod_perl 2.0.1 Apache::DBI 0.99 (taken from http://p6m7g8.net/Apache-DBI) In my startup.pl I have: use Apache::DBI (); $Apache::DBI::DEBUG = 2; ...
    Grigory PtashkoGrigory Ptashko
    Nov 2, 2005 at 5:33 pm
    Nov 3, 2005 at 9:52 pm
  • My perl script will not work correctly when run from Apache2 but works fine from the command line. Apache2 invokes the perl script to use Net::LDAP to bind through stunnel to another server. It works ...
    Blair CopelandBlair Copeland
    Nov 16, 2005 at 2:07 am
    Nov 16, 2005 at 5:19 am
  • Hi, is this really necessary in mod_perl2.pm? $mod_perl::VERSION = $mod_perl2::VERSION; $INC{"mod_perl.pm"} = File::Spec::Functions::devnull(); It makes libapreq fail to build when mp1 and mp2 are ...
    Torsten FoertschTorsten Foertsch
    Nov 1, 2005 at 9:06 am
    Nov 7, 2005 at 3:13 am
  • I need to install Mason on Fedora 2 with Apache 2. When I try to install Mason i receive: * ERROR: Prerequisite Apache::Request isn't installed I need to install the Apache2::Request (libapreq2) ...
    Victor DiasVictor Dias
    Nov 4, 2005 at 3:51 pm
    Nov 5, 2005 at 11:32 pm
  • We are experiencing strange behavior with the following code: -----SNIP----- #! /usr/bin/perl -w $ENV{'MOD_PERL_API_VERSION'} = '2'; use strict; use Time::localtime; my $foot = time(); my $foo = ...
    Richard N. FogleRichard N. Fogle
    Nov 6, 2005 at 3:12 pm
    Dec 2, 2005 at 12:56 pm
  • Hello, I need some hints on this problem: I have a code in mod_perl that generate a html page with some php code (<?php ... ? ), but before to send this data to the browser I would like the mod_php ...
    Edgard PinedaEdgard Pineda
    Nov 22, 2005 at 3:23 pm
    Nov 23, 2005 at 8:58 am
  • -------------8<---------- Start Bug Report ------------8<---------- 1. Problem Description: Has anyone managed to get a PerlAuthenHandler to work with mod_perl2.0.2? I'm having problems getting ...
    Gordon M LackGordon M Lack
    Nov 22, 2005 at 3:45 pm
    Nov 22, 2005 at 8:30 pm
  • Hello, I'm trying to get a basic web app running under mod_perl2, using an Oracle database connection. After I define the environment variables listed below, the test script works fine from the ...
    Steve DuranSteve Duran
    Nov 18, 2005 at 9:33 pm
    Nov 19, 2005 at 10:06 am
  • I've been attempting to turn my httpd.conf file into a perl module. Overall, it seems pretty straightforward but I've had trouble with the CustomLog and LogFormat directives. I can get them to work ...
    Brian PhillipsBrian Phillips
    Nov 10, 2005 at 5:55 pm
    Nov 10, 2005 at 7:53 pm
  • pkg_add -r perl pkg_add -r ImageMagick pkg_add -r mod_perl2 ls -1 /var/db/pkg ImageMagick-6.2.2.1 apache-2.0.55 expat-1.95.8_3 fontconfig-2.2.3,1 freetype2-2.1.10_1 ghostscript-gnu-7.07_13 ...
    Philip M. GollucciPhilip M. Gollucci
    Nov 9, 2005 at 5:46 pm
    Nov 10, 2005 at 6:57 am
  • Hi there, i'm just changing the web pages served with my mp2+libapreq2+mod_xslt2, and to inform that these pages has been modified i was used to use the $r- err_headers_out method to avoid any ...
    Eps com estemEps com estem
    Nov 7, 2005 at 10:46 am
    Nov 8, 2005 at 7:29 pm
  • My modperl app has its own init handler, but I'd also like to use Apache2::Reload on my dev box so I don't have to continue restarting Apache. Is it possible to register 2 init handlers through the ...
    JT SmithJT Smith
    Nov 5, 2005 at 5:59 pm
    Nov 5, 2005 at 9:10 pm
  • Hi list, I have a PerlAccessHandler which needs a copy of the POST data from the client in order to perform some validation. If the POST data is valid, the request is passed to mod_proxy which sends ...
    Srebrenko SehicSrebrenko Sehic
    Nov 2, 2005 at 4:18 pm
    Nov 3, 2005 at 4:48 pm
  • Ah, I love "The Cat" (http://www.perl.com/pub/a/2005/09/22/onion.html?page=5). Setting the encoding type on the form to [enctype="application/x-www-form-urlencoded"] appears to solve mod perl's ...
    Stone, Derrick J *HSStone, Derrick J *HS
    Nov 3, 2005 at 3:52 pm
    Nov 3, 2005 at 4:28 pm
  • First.. This is my first post to the list.. I hope that I'm not asking something thats already been answered. If I have, please point me in the right direction, and I'll gratefully go where needed. ...
    Michael PreslarMichael Preslar
    Nov 2, 2005 at 11:19 pm
    Nov 3, 2005 at 1:16 am
  • mod_perl-2.0.2-2 .. from a source RPM .. on Centos I'm trying to get RT to install, and thus need to first install mod_perl2. However I'm not getting past the server startup: Can't locate object ...
    Rick MeashamRick Measham
    Nov 2, 2005 at 7:10 am
    Nov 3, 2005 at 1:05 am
  • I am just getting introduced to mod-perl. Can anyone point me in a direction for learning this from scratch? I have experience in VB6, VB.NET, VC+. I do not know anything about Perl, PerlScript, or ...
    Branden JohnsonBranden Johnson
    Nov 30, 2005 at 2:31 am
    Nov 30, 2005 at 4:29 am
  • Hello, We have to do a project at college and I've chosen to write an apache module which should handle xslt-transformation (server-side). Now tutorials about apache modules are a very rare as far as ...
    Rony LiemmukdaRony Liemmukda
    Nov 22, 2005 at 7:38 am
    Nov 22, 2005 at 12:34 pm
  • I'd like to write a handler that would serve big files out of a local cache but proxy everything else through to another server. The situation is that there is an extranet in the US, but a lot of ...
    JT SmithJT Smith
    Nov 16, 2005 at 11:32 pm
    Nov 17, 2005 at 12:38 am
  • I'm getting this error when running a test in mod_perl. I've looked at the httpd.conf file and I can't figure out what's causing this error, or how to fix it. How do I re-define the value at line ...
    Brenda WashingtonBrenda Washington
    Nov 16, 2005 at 9:19 pm
    Nov 16, 2005 at 11:55 pm
  • Hi, i'm trying to avoid the "304 Not Modified" status when testing my updated handlers in localhost. From documentation, i read that phase PerlHeaderParserHandler is the most adequate to launch ...
    Gerard suchGerard such
    Nov 13, 2005 at 7:02 pm
    Nov 13, 2005 at 8:34 pm
  • I'm getting an undefined value from the code below: $CGI::DISABLE_UPLOADS = 0; $CGI::POST_MAX = 100 * 1_048_576; # 100 MB my $cgi = new CGI; print "Size: $ENV{CONTENT_LENGTH}"; my $cgi_file = $cgi- ...
    Boysenberry PayneBoysenberry Payne
    Nov 11, 2005 at 8:36 pm
    Nov 11, 2005 at 9:09 pm
  • Anyone ever seen this error before with Apache::DBI and Apache::AuthDBI? This is on a source-compiled apache v1 server and mysql 4.1.13. I'm checking through lots of things now to see where it might ...
    Kevin A. McGrailKevin A. McGrail
    Nov 10, 2005 at 8:25 pm
    Nov 10, 2005 at 11:30 pm
  • There is the problem: first running time my script gives correct results on mod_perl2.0.2 (Win32, Apache2.0.54, IE6), but after any next restart (F5 in browser) the variables do not clear: print ...
    Plymouth RockPlymouth Rock
    Nov 9, 2005 at 3:53 am
    Nov 9, 2005 at 5:58 am
  • I've recently moved to Apache2, and I'm now at my wit's end with custom configuration directives. I have them defined and working, following the examples in the docs, but the merging behavior is ...
    Jeremy NixonJeremy Nixon
    Nov 8, 2005 at 9:41 pm
    Nov 9, 2005 at 1:04 am
  • Hi, I am tryin to install mod_perl-2.0.2 on a linux box running Perl 5.8.3 and Apache 2.0.48. I get the following 'make test' error: t/filter/both_str_req_proxy.............# Failed test 1 in ...
    Gian Marco FenuGian Marco Fenu
    Nov 8, 2005 at 8:47 pm
    Nov 8, 2005 at 11:53 pm
  • Hi all, I'm using Apache+MP2+Soap::Lite as a service platform. One thing I notice is that my soap method returns the standard headers, plus the ones that the soap generates. Below is a sample of the ...
    Foo Ji-HawFoo Ji-Haw
    Nov 25, 2005 at 10:53 am
    Nov 28, 2005 at 6:02 am
  • Hi,lists, I am new to mod_perl.I have a simple mod_perl script running under Apache::Register.When it run,I found many error messages appeared in logs/error_log. The program is shown below: use ...
    Jeff PangJeff Pang
    Nov 26, 2005 at 1:34 am
    Nov 28, 2005 at 2:23 am
  • Hi all, I'm trying to write a system that writes its own config data to httpd.conf using Apache2::ServerRec- add_config from Apache2::ServerUtil, but I'm running into some troubles with <VirtualHost ...
    Arne SkjaerholtArne Skjaerholt
    Nov 21, 2005 at 12:32 am
    Nov 21, 2005 at 7:48 pm
  • If this is too far off topic, can you suggest where the experts on perl_alloc() and threads hang out? I'm trying to use Perl 5.8.7 (ActiveState) in a multi-threaded Java app on Solaris 5.9 ...
    JD BrennanJD Brennan
    Nov 20, 2005 at 2:41 am
    Nov 20, 2005 at 1:21 pm
  • Hi all when I # perl Makefile.PL MP_APXS=/usr/local/apache2/bin/apxs # make && make test # make install I get an error on the "make test", anyone have any ideas?? I'm running perl 5.8.7 [warning] ...
    Matt WellsMatt Wells
    Nov 18, 2005 at 9:23 pm
    Nov 18, 2005 at 9:30 pm
  • Hello, I'm on OS X 10.3.9 / AP2 / MP 2 / Perl 5.8.7 I've got a script that connects to a couple of ssh servers using Net::SSH::Perl. I've been able to log onto both servers using SSH in a terminal ...
    Boysenberry PayneBoysenberry Payne
    Nov 17, 2005 at 11:48 pm
    Nov 17, 2005 at 11:59 pm
  • Greetings, When installing the latest mod_perl with Apache 2.0.55 make test produced the following error: [warning] setting ulimit to allow core files ulimit -c unlimited; ...
    Kent, Mr. John \(Contractor\)Kent, Mr. John \(Contractor\)
    Nov 17, 2005 at 11:10 pm
    Nov 17, 2005 at 11:47 pm
  • Hi and a little dahut to all cryptids! I was trying out the Apache2::Resource module, and decided to try it out using just the default configuration. All I got was Can't locate object method "server" ...
    Kjetil KjernsmoKjetil Kjernsmo
    Nov 17, 2005 at 11:10 pm
    Nov 17, 2005 at 11:44 pm
  • I'm getting this error message when I run a t/TEST. Does anyone know why I'm getting this error? Starting program: /usr/local/apache2/bin/httpd -D ONE_PROCESS -d /opt/apache/mod_perl-2.0.1/t -f ...
    Brenda WashingtonBrenda Washington
    Nov 10, 2005 at 8:44 pm
    Nov 13, 2005 at 10:31 pm
Group Navigation
period‹ prev | Nov 2005 | next ›
Group Overview
groupmodperl @
categoriesmodperl, perl
discussions84
posts340
users107
websiteperl.apache.org

107 users for November 2005

Perrin Harkins: 35 posts Philip M. Gollucci: 32 posts Geoffrey Young: 16 posts Philippe M. Chiasson: 14 posts Boysenberry Payne: 11 posts Martin Moss: 10 posts Frank Wiles: 9 posts Plymouth Rock: 9 posts Badai Aqrandista: 8 posts Paul Harrison: 7 posts Pierre Smolarek: 7 posts Enno: 6 posts Abul Rahman: 5 posts Francesc Guasch: 5 posts Jeremy Nixon: 5 posts Malcolm J Harwood: 5 posts Tom Schindl: 5 posts Foo Ji-Haw: 4 posts John Doe: 4 posts JT Smith: 4 posts
show more
Archives