FAQ

Search Discussions

88 discussions - 491 posts

  • Hi all, I'm a happy user of HTML::Template on my mp2 setup. But when it comes to performance, I notice that to populate a loop of some 1500 records, the system takes 2-3 seconds on my P4 2GHz ...
    Foo Ji-HawFoo Ji-Haw
    Sep 4, 2005 at 9:32 pm
    Sep 10, 2005 at 7:10 pm
  • Hi everyone, I'm having trouble with my default index file (DirectoryIndex) in Apache 2. No matter what I try to do, index.pl does not show up as the default page. Instead, Apache gives me a ...
    Dickon NewmanDickon Newman
    Sep 27, 2005 at 5:59 pm
    Sep 30, 2005 at 5:08 pm
  • Hi all, I'm in the process of testing Koha (http://koha.org) with mod_perl and I'm running into a couple of snags. I get the following errors in the logs: [Tue Sep 06 13:42:09 2005] [error] [client ...
    Joshua FerraroJoshua Ferraro
    Sep 6, 2005 at 6:37 pm
    Sep 7, 2005 at 3:53 pm
  • Hi, I have a perl script which uses $| to set autoflush on. Basically, it flushes after every print. This script is working fine from the command line when run using standalone perl interpreter. But ...
    Pradeep kumarPradeep kumar
    Sep 1, 2005 at 12:53 pm
    Oct 4, 2005 at 3:07 pm
  • Yea, I got Apache2/MP2 installed and running on my OS X box. Now I'm rewriting my code and am getting the error: Can't locate object method "param" via package "Apache2::RequestRec" Here is what I ...
    Boysenberry PayneBoysenberry Payne
    Sep 14, 2005 at 6:15 pm
    Sep 15, 2005 at 7:36 am
  • Greetings. I've been scouring the list and the net for a solution for this but my apologies in advance if I didn't get the search terms right and missed a RTFM answer. I work for a web hosting ...
    Mark MoseleyMark Moseley
    Sep 16, 2005 at 12:05 am
    Sep 16, 2005 at 5:37 pm
  • Hello, I hope someone can help me as I cannot find any info on how to solve my issue. I'll try to make this short and sweet.... I have a website which has french accents (i.e. é) and I noticed that ...
    Sebastien PinsonnaultSebastien Pinsonnault
    Sep 8, 2005 at 6:42 am
    Sep 9, 2005 at 7:50 am
  • I have been working on installing Apache-2.0.54, Mod_perl-2.0.1 with perl-5.6.1 for a week now with little or no success. Is there anyone who can give me any help with the problem I'm experiencing? ...
    Brenda WashingtonBrenda Washington
    Sep 27, 2005 at 6:59 pm
    Oct 4, 2005 at 9:58 am
  • Hi, I'd greatly appreciate ideas on getting mod_perl successfully loaded via DSO into my Apache 1.3.33 installation. I compile and receive no errors (via Makefile.PL or via direct apache compile). I ...
    John KelleyJohn Kelley
    Sep 22, 2005 at 10:31 pm
    Sep 29, 2005 at 1:00 pm
  • Hi list, I have a problem with a .pl script, the scripts is executed in the first request, and it's been cached by the server, I call this script passing different arguments, and I expect that it ...
    Aliet Santiesteban SifontesAliet Santiesteban Sifontes
    Sep 21, 2005 at 11:10 pm
    Sep 23, 2005 at 6:35 pm
  • I'm finally learning my way around Apache::Test and I'm having a problem. Everything seems to be set up correctly (at least as far as I can determine). When running the actual code on my installed ...
    Malcolm J HarwoodMalcolm J Harwood
    Sep 18, 2005 at 11:58 pm
    Sep 19, 2005 at 5:17 pm
  • Hi, Wouldn't be a good idea (for someone who also know PHP well) to create a program that can create perl scripts from PHP scripts? Also for the languages which are used in ASP... Also making a ...
    Octavian RasnitaOctavian Rasnita
    Sep 11, 2005 at 1:16 pm
    Sep 14, 2005 at 7:45 am
  • Hello all, I have set up my MP2 application, which in the course of development has been reasonably stable. But when I put it under reasonably load (I have a daemon with 5 threads that call it ...
    Foo Ji-HawFoo Ji-Haw
    Sep 13, 2005 at 2:45 am
    Sep 13, 2005 at 10:01 am
  • Through my MP2 handler, I need to be able to set Content-Type based on the extension of any file that I'm reading from disk and then writing to the client. I'd like to somehow (programmatically) map ...
    Jeff AmbrosinoJeff Ambrosino
    Sep 23, 2005 at 3:49 pm
    Sep 23, 2005 at 6:27 pm
  • My techie set-up MP 1.99 on a new server running Apache 2 but things just aren't working properly. Unfortunately he had to go out of town for awhile, so I am looking to hire a MP "guru" to finishing ...
    Patrick KennedyPatrick Kennedy
    Sep 22, 2005 at 3:33 am
    Sep 23, 2005 at 5:28 pm
  • I'm getting the following error: [Mon Sep 19 18:45:48 2005] [notice] child pid 29371 exit signal Bus error (10) How do I go about troubleshooting this in MP2. I'm just switching to it and finally ...
    Boysenberry PayneBoysenberry Payne
    Sep 19, 2005 at 11:52 pm
    Sep 20, 2005 at 6:21 pm
  • In mod_perl 1.29 version, I preload the following modules at startup -- use Apache::Request (); use Apache::Cookie (); It works perfect. I'm currently learning how to use mod_perl2-2.0.1, when I try ...
    Paul HarrisonPaul Harrison
    Sep 14, 2005 at 9:03 pm
    Sep 15, 2005 at 3:27 am
  • All, I'm trying to confirm whether Apache::DBI is running on a server.. I can tell if it's loaded, using perl-status, but I can't tell if it's running correctly - e.g. intercepting calls to DBI- ...
    Martin MossMartin Moss
    Sep 29, 2005 at 3:53 pm
    Sep 30, 2005 at 1:15 pm
  • Hello, I'm trying to put a value I obtain from a modperl handler script into the environmental hash %ENV available in the cgi perl script, eventually called via the handler. I've tried calls: $r- ...
    Ray LiconRay Licon
    Sep 25, 2005 at 9:53 am
    Sep 25, 2005 at 10:02 pm
  • Is there a way I can change the mine type in apache so when a user clicks on a mp3 link it would pop_up the save window instead of playing it ? Maybe trick the browser into thinking the mp3 file is a ...
    Paul HarrisonPaul Harrison
    Sep 13, 2005 at 3:26 pm
    Sep 13, 2005 at 6:07 pm
  • Hola, We're using apache/1.3.33 and mod_perl/1.29. the problem is, a personal ENV variable is set in my environment and read from a script like ..... my $ENVNAME = $ENV{MY_PERSONAL_ENV} || 'STHELSE'; ...
    Anthony GardnerAnthony Gardner
    Sep 7, 2005 at 3:39 pm
    Sep 8, 2005 at 6:41 pm
  • I'm trying to get at PerlSetVar configurations, and this doesn't work under MP2: sub handler { my $r = shift; $r- print( $r- dir_config('MyConfig') ); return Apache2::Const::OK; }; I'm getting this ...
    Christopher H. LacoChristopher H. Laco
    Sep 2, 2005 at 3:08 am
    Sep 5, 2005 at 9:06 pm
  • Hi. I've got the following script, which I picked up off the apache mod_perl pages, running. /~~~~~~~~~~~~~~~~~~~ #!/usr/bin/perl # Script: vegetables1.pl use CGI::Pretty ':standard'; print header, ...
    LukeLuke
    Sep 26, 2005 at 12:43 am
    Sep 28, 2005 at 2:34 pm
  • A little OT, but has anyone got any experience or examples that use Apache2::SOAP or some other means to create a mod_perl SOAP server? I'm rushing headlong into SOAP development and (as one does) ...
    John ORourkeJohn ORourke
    Sep 22, 2005 at 12:27 pm
    Sep 23, 2005 at 8:49 am
  • Hi, I'm still struggling with trying to understand how Mod_Perl 2 works. All I want to do is to have a regular Perl script run under Mod_Perl just to speed it up. In the past, in Mod_Perl 1 I've used ...
    Justin LusterJustin Luster
    Sep 14, 2005 at 4:19 pm
    Sep 16, 2005 at 3:56 pm
  • This is just Perl related but as it's running under mod_perl, I'm sure you lot won't mind ;) I'm trying to benchmark a piece of code with timeit and I need a code ref. The thing is, I can't make a ...
    Anthony GardnerAnthony Gardner
    Sep 16, 2005 at 11:57 am
    Sep 16, 2005 at 3:53 pm
  • I want to know is there any package can give me a DB Connection Pool in a mod_perl application ? I've checked Apache::DBI, but it seems that it'll initialze a new connection when a new thread born.
    FiringmeFiringme
    Sep 12, 2005 at 7:11 am
    Sep 13, 2005 at 11:25 pm
  • Hello, i have a big problem with Segmentation Fault which i can not debug. I got this Segmentation Fault only in Safari or IE Browsers and not always only sometimes. This fact makes it hard for me to ...
    Christian KlingerChristian Klinger
    Sep 9, 2005 at 7:41 am
    Sep 9, 2005 at 12:42 pm
  • Hello all. I have a problem in writing mutlithread-safe application on mod_perl. I have a file main.pm which is my object implementation: package admin::main; 1; package svntrac::admin; use ...
    Taras Yurij VasylovitchTaras Yurij Vasylovitch
    Sep 26, 2005 at 9:11 pm
    Sep 28, 2005 at 9:51 am
  • Hello, I've recently switched to Apache 2 with mod_perl 2. Unfortunately I still have to run some perl scripts which only worked with Apache::PerlRun and PerlSetVar PerlRunOnce On. After a bit of ...
    Fabian KreitnerFabian Kreitner
    Sep 21, 2005 at 3:34 pm
    Sep 23, 2005 at 8:50 am
  • I'm exporting a database table through a mod_perl2 handler. The problem is that for large tables, the size of the httpd process balloons to consume alot of RAM. For example, a 299mb MySQL table (size ...
    Jeff AmbrosinoJeff Ambrosino
    Sep 22, 2005 at 3:06 pm
    Sep 22, 2005 at 4:45 pm
  • Hello... I'm trying to wrap an entire website in a perl handler. And then use the $r- lookup_uri() to access some files in the domain. ...
    Morten BøgeskovMorten Bøgeskov
    Sep 21, 2005 at 10:44 am
    Sep 21, 2005 at 2:17 pm
  • When using Storable freeze/thaw to work with basic object (hash) storage within a mysql db (blob column), I can't seem to get any more than 65535 bytes stored. Since 65535 appears to be a "magic" ...
    Bill WhillersBill Whillers
    Sep 19, 2005 at 5:43 am
    Sep 19, 2005 at 7:25 am
  • Can s.o. explain what is wrong with the following code .... $r- pnotes('KEY' = push( @{ $ar }, $some_val ) ); because, when it comes to getting the value from pnotes later with .... $r- pnotes(KEY), ...
    Anthony GardnerAnthony Gardner
    Sep 16, 2005 at 10:08 am
    Sep 16, 2005 at 11:06 am
  • Last time I tried to do a mod_perl 2 install on my OS X box was met with abysmal failure on my part. I ended up having to reinstall my whole box, what a nightmare. I've been lurking on this mailing ...
    Boysenberry PayneBoysenberry Payne
    Sep 12, 2005 at 6:40 pm
    Sep 13, 2005 at 7:16 pm
  • 1. Concept: 2. 3. GET http://domain.tld/search/a/b/c (via :80) 4. rewrite search/a/b/c - http://localhost:8080/perl/script?a=a&b=b&c=c [P] (via .htaccess RewriteRule) [OK] (localhost:8080 is another ...
    Jonathan SteffanJonathan Steffan
    Sep 15, 2005 at 3:40 am
    Oct 1, 2005 at 9:00 am
  • Hello, just a quick question... Has anyone out there successfully deployed HTML::Parser in an apache 1.3.x/ mod_perl / HTML::Mason environment (dynamically parsing pages) ? I realize that the module ...
    Mike HendersonMike Henderson
    Sep 22, 2005 at 6:30 pm
    Sep 26, 2005 at 9:12 pm
  • Thanks Matthew -- Our data is somewhat volatile but since our frozen objects can get pretty big, like others we're always looking for an all-around better "shared" solution for volatile data which is ...
    Bill WhillersBill Whillers
    Sep 19, 2005 at 7:02 pm
    Sep 19, 2005 at 8:58 pm
  • I'd like to do the following: open $fh, '<', 'some_file'; # A very big file $b = APR::Bucket- new($ba, $fh); while($b- read($buffer, 2048)) { ... } or $b = APR::Bucket- new($ba, \*STDIN);
    Nikolay AnanievNikolay Ananiev
    Sep 15, 2005 at 9:21 pm
    Sep 16, 2005 at 5:38 pm
  • Hi, this patch introduces $Apache2::SizeLimit::USE_SMAPS which is 1 by default. If /proc/PID/smaps are not available Apache::SizeLimit resets it to 0 itself. It can be reset by the user if he prefers ...
    Torsten FoertschTorsten Foertsch
    Sep 5, 2005 at 6:05 pm
    Sep 16, 2005 at 10:14 am
  • Hi, everyone. I really have a problem. I did install mod_perl on Apache 1.33 but later I decided to move to Apache2, so I install mod_perl2 too and I remove both apache 1.33 and mod_perl 1.99. Then, ...
    Ana AzuajeAna Azuaje
    Sep 5, 2005 at 9:11 pm
    Sep 5, 2005 at 11:08 pm
  • Hi, Yesterday I was asked about the viability of mod_perl ( and more generally Perl web based solutions ) in scaling web based applications. I have my own personal experiences with scaling mod_perl, ...
    Fred MoyerFred Moyer
    Sep 29, 2005 at 12:28 am
    Oct 23, 2005 at 8:56 pm
  • Hi, I am trying to redirect a request to another location and the following code works, but the new location is not printed in the address bar. $r- status_line('302 Moved'); $r- headers_out- ...
    Octavian RasnitaOctavian Rasnita
    Sep 30, 2005 at 8:05 pm
    Oct 2, 2005 at 5:43 pm
  • Hi List I'm trying to work out how to set a PerlResponseHandler within a PerlAccessHandler Notes: There's only 1 PerlResponsehandler and PerlAccessHandler per request. I was setting the ...
    Angie ahlAngie ahl
    Sep 28, 2005 at 1:46 pm
    Sep 28, 2005 at 2:12 pm
  • Hi all, Would anyone know where to start looking about how to track down the source of this following line in error.log: Apache2::Filter: (620018) APR does not understand this error code at -e line 0 ...
    Matthew DarwinMatthew Darwin
    Sep 20, 2005 at 10:51 pm
    Sep 25, 2005 at 5:05 pm
  • Fedora Core 4 httpd-2.0.54-10 mod_perl-2.0.0-0.rc5.3 I have an nph mod_perl script which will send a JPEG to a client either inline or as an attachment (if a param is passed). If it is an attachment, ...
    Christopher StantonChristopher Stanton
    Sep 20, 2005 at 11:52 pm
    Sep 21, 2005 at 1:30 am
  • Hi list, I'm in the process of migrating our CGI applications to mod_perl, we are using: Windows 2003 Enterprise Server, ActivePerl 5.8.7 Build 813, Apache-2.0.54. Perl with modules: 1. ...
    Aliet Santiesteban SifontesAliet Santiesteban Sifontes
    Sep 19, 2005 at 8:14 pm
    Sep 21, 2005 at 12:47 am
  • I have both Apache1 & 2 with mp1 & 2 on my system (for testing). By default, Apache::Test seems to find and use Apache1, which is fine, but I need to figure out how to tell it to run its tests with ...
    Dave RolskyDave Rolsky
    Sep 20, 2005 at 7:21 pm
    Sep 20, 2005 at 7:39 pm
  • Hi I've set up mod_perl v1.29 with apache 1.3.33 and I'm trying to maximise the amount of memory shared between the httpd processes. I've created a startup.pl file and have entered all modules I use, ...
    Dan HorneDan Horne
    Sep 19, 2005 at 10:14 pm
    Sep 20, 2005 at 9:49 am
  • Hi I am having problems while trying to configure perl module with apache. I am attaching my httpd.conf file. Please check out the section ************************************* # Added by Manish to ...
    Manish Rai JainManish Rai Jain
    Sep 18, 2005 at 6:16 am
    Sep 18, 2005 at 10:07 pm
Group Navigation
period‹ prev | Sep 2005 | next ›
Group Overview
groupmodperl @
categoriesmodperl, perl
discussions88
posts491
users118
websiteperl.apache.org

118 users for September 2005

Philip M. Gollucci: 63 posts Perrin Harkins: 30 posts Geoffrey Young: 29 posts Tom Schindl: 16 posts Boysenberry Payne: 15 posts Frank Wiles: 13 posts Jeff Ambrosino: 10 posts Philippe M. Chiasson: 10 posts Malcolm J Harwood: 9 posts Pradeep kumar: 9 posts David Christensen: 8 posts Foo Ji-Haw: 8 posts Octavian Rasnita: 8 posts Aliet Santiesteban Sifontes: 7 posts Dickon Newman: 7 posts Foo Ji-Haw: 7 posts John Kelley: 7 posts Anthony Gardner: 6 posts Frank Maas: 6 posts Jeff: 6 posts
show more
Archives