FAQ

Search Discussions

146 discussions - 728 posts

  • How can you change the length (expiry) of sessions in Apache::Session? Raphael -- Reporting bugs: http://perl.apache.org/bugs/ Mail list info: http://perl.apache.org/maillist/modperl.html
    Blanchard, RaphaelBlanchard, Raphael
    Nov 27, 2003 at 7:14 pm
    Nov 28, 2003 at 6:52 pm
  • Hi, I am building mod_perl using the following: wes@bioweb perl Makefile.PL \ ? APACHE_SRC=../$apache/src \ ? NO_HTTPD=1 \ ? USE_APACI=1 \ ? PREP_HTTPD=1 \ ? EVERYTHING=1 Will configure via APACI ...
    Wes BarrisWes Barris
    Nov 18, 2003 at 5:40 am
    Nov 26, 2003 at 2:40 am
  • The canonical way of finding out whether a module of yours is being called in a mod_perl environment, appears to be (thanks Stas!): use constant MP = $ENV{MOD_PERL} ? eval { require mod_perl; ...
    Elizabeth MattijsenElizabeth Mattijsen
    Nov 24, 2003 at 8:56 am
    Nov 26, 2003 at 12:18 am
  • First off, let me say hi all and thanks for mod_perl as it was just what I was looking for when starting out this project. The project is an web-based groupware email system which runs as a mod_perl ...
    Jordan LedermanJordan Lederman
    Nov 21, 2003 at 6:29 pm
    Nov 24, 2003 at 9:39 pm
  • Anyone have some suggestions for me? -------------8<---------- Start Bug Report ------------8<---------- 1. Problem Description: apr/table......................FAILED tests 20-21 2. Used Components ...
    Matisse EnzerMatisse Enzer
    Nov 7, 2003 at 6:06 pm
    Nov 17, 2003 at 7:29 pm
  • Hi, I work with mod_perl for Apache, but I have problem with Apache:Registry. The output error.log is [Thu Nov 27 12:26:16 2003] [error] failed to resolve handler `Apache::Registry' [Thu Nov 27 ...
    Patricio MuñozPatricio Muñoz
    Nov 27, 2003 at 5:42 pm
    Dec 1, 2003 at 9:33 pm
  • Hi everyone, on a winXP platform I have just upgraded Apache from 2.0.47 to 2.0.48 version and mod_perl from 1.99_10 to 1.99_12. Apache starts succcessfully but I got an Internal Server Error also on ...
    Paolo De RisoPaolo De Riso
    Nov 20, 2003 at 2:37 pm
    Dec 17, 2003 at 4:10 am
  • Unrelated to the issue with PerlIO blocking read that will be resolved shortly, CGI.pm has a problem working under mod_perl 2's 'SetHandler modperl' mode, when you can't do: read(STDIN, ....); ...
    Stas BekmanStas Bekman
    Nov 4, 2003 at 1:08 am
    Nov 9, 2003 at 8:22 am
  • i fear this has been asked many times, but i could not find a definitive answer. i am using a system on which mod_perl is available, but the Perl version it's using is 5.6.1 this system also has Perl ...
    Todd WhiteTodd White
    Nov 3, 2003 at 5:12 pm
    Nov 5, 2003 at 7:22 pm
  • Well, I tried to bounce it; apparently, ezmlm is even *less* ez than I thought. ----- Forwarded message from Stas Bekman <stas@stason.org ----- Date: Fri, 21 Nov 2003 13:49:15 -0800 From: Stas Bekman ...
    Jay R. AshworthJay R. Ashworth
    Nov 21, 2003 at 10:00 pm
    Nov 22, 2003 at 9:30 pm
  • 2.02-dev will be a maintenance release to fix the reported segfaults with Apache::Cookie::new(). Please give this candidate a try at http://httpd.apache.org/~joes/libapreq2-2.02_01-dev.tar.gz ...
    Joe SchaeferJoe Schaefer
    Nov 13, 2003 at 2:55 pm
    Nov 19, 2003 at 6:35 pm
  • Hi, I sent out an email yesterday describing some problems that I'm having with Apache::SSI. I've narrowed things down significantly and hope that this extra info can help someone point me in the ...
    Christopher P. LindseyChristopher P. Lindsey
    Nov 17, 2003 at 6:36 am
    Nov 18, 2003 at 3:22 pm
  • After serving up requests normally for some time, we get the following line in our error_log: [Mon Nov 10 13:44:31 2003] [notice] child pid 24121 exit signal Segmentation fault (11) There aren't any ...
    Marc SlagleMarc Slagle
    Nov 10, 2003 at 7:31 pm
    Nov 13, 2003 at 2:57 pm
  • Hello modperl, I have a mod_perl driven website and CMS for this site running under PerlRun. Site and CMS located in different direcories and use different modules, but have subroutines that have the ...
    Andrey A. KudrinAndrey A. Kudrin
    Nov 4, 2003 at 10:16 pm
    Nov 10, 2003 at 7:37 pm
  • Howdy I've searched, and searched, for a recipe and/or method for this; I can't find one that works :( Am using a home-rolled Apache 2.0.48 and mod_perl 1.99_10 setup. Given a file containing lines ...
    Graeme FowlerGraeme Fowler
    Nov 11, 2003 at 4:37 pm
    Nov 12, 2003 at 3:53 pm
  • I'm running Linux Apache/1.3.26 (Unix) mod_perl/1.26 PHP/4.2.3 and MySQL. I'm trying to write a simple web (perl) application that accesses a mysql database. I'm using DBI(). When I access the site ...
    Global JunkGlobal Junk
    Nov 11, 2003 at 4:36 pm
    Nov 12, 2003 at 3:14 pm
  • hi i'm trying so hard to be good and follow directions. when i run make test i keep getting errors like this: [Tue Nov 25 17:12:11 2003] [error] Can't locate My/child_init.pm in @INC (@INC contains: ...
    John SaylorJohn Saylor
    Nov 25, 2003 at 10:34 pm
    Dec 11, 2003 at 8:38 pm
  • Hi List, At the moment my application runs as a mix of mod_perl handlers and a rather large-ish Apache::Registry CGI program. Initially the application was generating everything on the fly. Due to ...
    Jean-Michel HiverJean-Michel Hiver
    Nov 26, 2003 at 11:54 am
    Nov 28, 2003 at 11:53 am
  • I was wondering whether the following trick could somehow work with mod_perl 2. And excuse my preference for prefork MPM's: I guess that's the hammer to work on all my nails (pun intended). I'm open ...
    Elizabeth MattijsenElizabeth Mattijsen
    Nov 26, 2003 at 2:37 pm
    Nov 27, 2003 at 8:26 am
  • I grabbed perlbench from CPAN and did some more benchmarks. These confirmed what we already suspected, i.e. there are no significant performance differences in Perl itself between 5.6.1, 5.8.0, and ...
    Perrin HarkinsPerrin Harkins
    Nov 11, 2003 at 1:59 am
    Nov 12, 2003 at 10:25 pm
  • Hello, in Debian there is a very old bug report about internal_redirect, the full text of which you can read at the following url, along with the necessary to reproduce it: ...
    Pierfrancesco CaciPierfrancesco Caci
    Nov 9, 2003 at 5:35 pm
    Nov 26, 2003 at 8:27 am
  • Hello, I've an old cgi-script that worked before I installed mod_perl, but now it won't work. I've put it in a directory that is configured to be handled by mod_cgi, but I get this error in my apache ...
    Dustin WhitneyDustin Whitney
    Nov 6, 2003 at 10:51 pm
    Nov 10, 2003 at 3:41 pm
  • Ok, I'm trying to install OpenWebMail but I keep getting an Internal Server Error when I try to access it via the web. Here is what I have/did Installed: Apache 1.3.29/mod_ssl 2.8.16-1.3.29/PHP 4.3.4 ...
    Jonathan VillaJonathan Villa
    Nov 26, 2003 at 3:39 pm
    Nov 26, 2003 at 6:41 pm
  • hi, I have just subscribed to this mailing list, so I hope I'm doing everything right... my problem: I'm running a reverse proxy with apache 1.3.x and mod_proxy on debian. For the authentication ...
    Tauber, Mathias HDPTauber, Mathias HDP
    Nov 4, 2003 at 5:31 pm
    Nov 26, 2003 at 3:20 pm
  • Hi everyone Am I safe following these instructions to make a second apache/mod_perl install on OSX Panther http://perl.apache.org/docs/1.0/guide/getwet.html I've read that panther has problems with ...
    Angie ahlAngie ahl
    Nov 21, 2003 at 2:09 pm
    Nov 22, 2003 at 9:43 am
  • Hi! 1. Problem Description: My apache child crash with a segfault when I call a page which generates a graph using the perl module GD::Graph. My system specs are: Fedora Core 1 httpd-2.0.47 (from ...
    Alexander HartmaierAlexander Hartmaier
    Nov 12, 2003 at 5:10 am
    Nov 14, 2003 at 12:16 pm
  • I'm just wondering if anyone has any input on this issue. I'm implementing an output filter, like so: <Files *.pcgi SetHandler perl-script PerlResponseHandler ModPerl::Registry ...
    Matthew DarwinMatthew Darwin
    Nov 5, 2003 at 10:43 pm
    Nov 12, 2003 at 7:27 pm
  • Hi! My setup is really simple, and because of this, I can't figure out what is going wrong. I am running: Apache/2.0.47 (Debian GNU/Linux) mod_perl/1.99_10 Perl/v5.8.1 My apache2.conf contains: ...
    Joshua N PritikinJoshua N Pritikin
    Nov 8, 2003 at 2:24 am
    Nov 8, 2003 at 4:21 am
  • I've encountered a weird, intermittent problem. I have a Perl handler that handles a certain URL. Sometimes it will fail because the $r passed to it loses its class. The handler starts with: sub ...
    AsherAsher
    Nov 18, 2003 at 5:41 am
    Dec 4, 2003 at 12:36 am
  • Hello! I wanted to build a debian package of apache for my specific purposes. My specific purpose is mod_accel support. I downloaded a source for apache debian package (apache-1.3.26) from stable ...
    BeerBongBeerBong
    Nov 26, 2003 at 8:21 am
    Nov 27, 2003 at 6:09 pm
  • Hi all, I have this PerlSetVar behaviour. Suppose to have: <Location /foo SetHander perl-script PerlSetVar Something 0 PerlResponseHandler MyModule </Location But in MyModule.pm, $r- ...
    Enrico SorcinelliEnrico Sorcinelli
    Nov 17, 2003 at 6:17 pm
    Nov 26, 2003 at 6:19 pm
  • This week at ApacheCon in Las Vegas, Geoff, Philippe and I sat down and created a new TODO list: http://cvs.apache.org/viewcvs.cgi/*checkout*/modperl-2.0/todo/release?rev=HEAD&content-type=text/plain ...
    Stas BekmanStas Bekman
    Nov 22, 2003 at 9:45 pm
    Nov 24, 2003 at 6:35 pm
  • I was planning to use Flex too. But I came upon an email from Jeff http://marc.theaimsgroup.com/?l=apache-modperl&m=100283817811419&w=2 saying "Regarding Flex, nobody uses it. It is for debugging. If ...
    Jonathan SwartzJonathan Swartz
    Nov 13, 2003 at 4:06 pm
    Nov 13, 2003 at 10:28 pm
  • Hi * After downloading the newest versions of mp2, libapreq2 I was able to compile to compile everything but the the test-suits showed some errors. I don't know if I'm doing something very stupid ...
    Swen SchilligSwen Schillig
    Nov 11, 2003 at 8:38 am
    Nov 12, 2003 at 8:01 pm
  • Hi Guys How many of you use makepl_args.mod_perl ? I have a file handy with all the required options & I build a static httpd with a single 'perl Makefile.PL'. I have found this method very ...
    Sreeji K DasSreeji K Das
    Nov 4, 2003 at 10:07 am
    Nov 9, 2003 at 10:30 am
  • I'm currently investigating using Apache::PageKit to develop a web application. I'm more-or-less constrained to use Apache 2 by the environmental requirements for the project which means mod_perl2 ...
    Paul FlindersPaul Flinders
    Nov 27, 2003 at 10:42 pm
    Dec 3, 2003 at 8:19 pm
  • Let me start by saying, I am a self taught programmer and have written modperl scripts to run under apache registry and dabbled with writting my own modperl modules. I want to write a modperl script ...
    John MichaelJohn Michael
    Nov 29, 2003 at 6:18 am
    Nov 29, 2003 at 1:31 pm
  • My bug report: :-) -------------8<---------- Start Bug Report ------------8<---------- 1. Problem Description: ModPerl won't build on RH7.3 with perl 5.6.1 from rpm perl-5.6.1-34.99.6 Tests fail; ...
    Jay R. AshworthJay R. Ashworth
    Nov 21, 2003 at 5:47 am
    Nov 21, 2003 at 9:49 pm
  • Hi All. I've had a search through the archives, and can't seem to find anything relevant. Pointers would be welcome. I've got a Mandrake linux 8.1 system (yeah, old), from which I've removed the ...
    Ken CoreyKen Corey
    Nov 13, 2003 at 12:38 pm
    Nov 13, 2003 at 4:23 pm
  • Anybody has an idea why mp1 build does: PERL5LIB = "PERL5LIB=/path/to/mod_perl-1.29/lib", (see the top-level Makefile). I can't see how is it going to work: PERL5LIB="PERL5LIB=/tmp" perl-5.8.1 -le ...
    Stas BekmanStas Bekman
    Nov 12, 2003 at 10:29 pm
    Nov 13, 2003 at 7:16 am
  • Hi, the following worked fine under 1.99_09 in a perl module called from a simple mod_perl script (SetHandler perl-script, PerlHandler ModPerl::Registry): But after upgrading to 1.99_10, the content ...
    Christian WetzigChristian Wetzig
    Nov 5, 2003 at 2:51 pm
    Nov 6, 2003 at 12:45 pm
  • Sorry if this is OT. If I recall, Apache- request() was being deprecated (or at least frowned upon)... Is this true? Also, (and I know it's a separate package, but) does anyone know if the same is ...
    Eric SammerEric Sammer
    Nov 6, 2003 at 5:26 am
    Nov 6, 2003 at 10:26 am
  • Hello everyone, I have some questions about performance of mod_perl. But on real applications, like on bigger, more complicated scripts, what is to be expected ? I've converted a perl application ...
    Frantzcy PaisibleFrantzcy Paisible
    Nov 5, 2003 at 2:16 pm
    Nov 5, 2003 at 8:50 pm
  • I am interested in using apache 2.0 and mod_perl to run a nice perl smtp server, and was wondering if there are any such projects out there. The server would take advantage of apache 2.0's generic ...
    Cahill, EarlCahill, Earl
    Nov 26, 2003 at 6:03 am
    Nov 26, 2003 at 7:43 pm
  • Hello, I have a problem which I could not solve prefectly yet. I'm using my own templating system which is basically quite simple. Every template is translateted into a subroutine that will return ...
    Marcel GreterMarcel Greter
    Nov 22, 2003 at 4:02 am
    Nov 26, 2003 at 6:01 am
  • I'm running a perl -MCPAN -e 'CPAN::Shell- install(CPAN::Shell- r)', to see if it helps me with a PerlMagick/ImageMagick version(?) incompatibility, and in the process, it decided to upgrade my ...
    Jay R. AshworthJay R. Ashworth
    Nov 25, 2003 at 12:56 am
    Nov 25, 2003 at 1:54 am
  • compiled mod_perl and embperl with debugging option. output is this: # gdb /usr/sbin/httpd GNU gdb Red Hat Linux (5.3.90-0.20030710.41rh) Copyright 2003 Free Software Foundation, Inc. GDB is free ...
    Alexander HartmaierAlexander Hartmaier
    Nov 13, 2003 at 4:12 pm
    Nov 13, 2003 at 9:41 pm
  • Hi, using Perl 5.8.1, mod_perl 1.29, Apache 1.3.29, I see this warning in my Apache error log file whenever I start Apache: [Wed Nov 5 01:24:20 2003] CGI.pm: Constant subroutine CGI::XHTML_DTD ...
    Joachim FeiseJoachim Feise
    Nov 6, 2003 at 9:51 pm
    Nov 11, 2003 at 10:38 pm
  • Hi All, How can I get a definitive answer as to whether mod_perl was compiled with Large File Support? I have a shell login account but not root. Regards Adam -- Reporting bugs: ...
    Adam GriffithsAdam Griffiths
    Nov 6, 2003 at 8:40 pm
    Nov 7, 2003 at 8:11 pm
  • 1. Problem Description: I'm testing with the httpd-std.conf file that comes with the FreeBSD port's apache2 install, with the following additions: LoadModule perl_module libexec/apache2/mod_perl.so ...
    Awk-mpAwk-mp
    Nov 28, 2003 at 4:55 am
    Nov 28, 2003 at 10:04 pm
Group Navigation
period‹ prev | Nov 2003 | next ›
Group Overview
groupmodperl @
categoriesmodperl, perl
discussions146
posts728
users141
websiteperl.apache.org

141 users for November 2003

Stas Bekman: 181 posts Perrin Harkins: 65 posts Geoffrey Young: 29 posts Jay R. Ashworth: 29 posts Ged Haywood: 24 posts Shannon Eric Peevey: 22 posts Randy Kobes: 13 posts Wes Barris: 11 posts Christopher P. Lindsey: 9 posts Elizabeth Mattijsen: 9 posts Joe Schaefer: 9 posts John Michael: 9 posts Jordan Lederman: 9 posts Enrico Sorcinelli: 8 posts Matisse Enzer: 8 posts Angie ahl: 7 posts Alexander Hartmaier: 6 posts Andrey A. Kudrin: 6 posts Cees Hek: 6 posts Gerald Richter: 6 posts
show more
Archives