FAQ
My configuration in mojomojo.conf includes

email SMTP
email 192.168.4.2

MojoMojo is running on a webserver. In the shell on that webserver, I can:

telnet 192.168.4.2 25

and talk to the email server.

With the above configuration, shouldn't MojoMojo be able to talk to the
email server and send email? Or am I missing something?

tcpdump reports no packets generated. Even when I set email to localhost, I
see no local packets generated. this is not a firewall issue.

debug reports:

[debug] C::V::Email::Template uses default view
MojoMojo::View::TT=HASH(0x4909768) for rendering.
[debug] C::V::Email uses default content_type text/plain.
[debug] Rendering template "mail/reset_password.tt"
[debug] C::V::Email uses specified content_type text/plain.
[debug] Rendering template "user/recover_pass.tt"
[info] Request took 0.210454s (4.752/s)

Is some other facility required to support email in MojoMojo?
--
View this message in context: http://n2.nabble.com/SMTP-mail-settings-tried-both-localhost-and-mailserver-in-mojomojo-conf-tp4468666p4468666.html
Sent from the mojomojo mailing list archive at Nabble.com.

Search Discussions

  • Rodrigo de Oliveira at Jan 27, 2010 at 7:57 pm

    With the above configuration, shouldn't MojoMojo be able to talk to the
    email server and send email? Or am I missing something?
    I'm having a similar problem. No mails sent, nothing reported to the logs.
    I'm on MojoMojo 0.999042 on perl 5.10.1 on AIX.
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: http://lists.scsys.co.uk/pipermail/mojomojo/attachments/20100127/aed13a8e/attachment.htm
  • Lsm at Jan 28, 2010 at 1:31 am
    It looks like Catalyst::View::Email just migrated from Email::Send to
    Email::Sender

    Various Catalyst::View::Email tutorials and example code is now broken.

    It seems you have to pass in an explicit "header" hash, rather than the
    individual header components.

    i.e.,

    before:

    $c->stash->{email} = {
    to => 'recipient@recipient.com',
    from => 'sender@sender.com',
    subject => 'subject',
    body => 'body',
    }

    after:

    $c->stash->{email} = {
    header => [
    to => 'recipient@recipient.com',
    from => 'sender@sender.com',
    subject => 'subject',
    ],
    body => 'body',
    }

    I surmise that the MojoMojo internals (and those of a lot of packages) may
    have to change, to keep using Catalyst::View::Email. Or
    Catalyst::View::Email needs to handle legacy inputs?

    FYI, I haven't confirmed this is the specific problem with MojoMojo, but
    other packages I'm using seem to have broken -- and I have fixed -- in
    precisely this manner.
    --
    View this message in context: http://n2.nabble.com/SMTP-mail-settings-tried-both-localhost-and-mailserver-in-mojomojo-conf-tp4468666p4470978.html
    Sent from the mojomojo mailing list archive at Nabble.com.
  • Mateu X. Hunter at Jan 28, 2010 at 1:33 am
    I have solid luck with postfix installed and:

    email SMTP
    email localhost
    system_mail Default Installation <noreply@mojomojo.org>

    for the mail config in mojomojo.conf



    My configuration in mojomojo.conf includes

    email SMTP
    email 192.168.4.2

    MojoMojo is running on a webserver. In the shell on that webserver, I
    can:

    telnet 192.168.4.2 25

    and talk to the email server.

    With the above configuration, shouldn't MojoMojo be able to talk to the
    email server and send email? Or am I missing something?

    tcpdump reports no packets generated. Even when I set email to localhost,
    I
    see no local packets generated. this is not a firewall issue.

    debug reports:

    [debug] C::V::Email::Template uses default view
    MojoMojo::View::TT=HASH(0x4909768) for rendering.
    [debug] C::V::Email uses default content_type text/plain.
    [debug] Rendering template "mail/reset_password.tt"
    [debug] C::V::Email uses specified content_type text/plain.
    [debug] Rendering template "user/recover_pass.tt"
    [info] Request took 0.210454s (4.752/s)

    Is some other facility required to support email in MojoMojo?
    --
    View this message in context:
    http://n2.nabble.com/SMTP-mail-settings-tried-both-localhost-and-mailserver-in-mojomojo-conf-tp4468666p4468666.html
    Sent from the mojomojo mailing list archive at Nabble.com.

    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
  • Diego Kuperman at Jan 28, 2010 at 4:46 am
    Hello!,
    On 1/27/10 10:33 PM, Mateu X. Hunter wrote:
    I have solid luck with postfix installed and:

    email SMTP
    email localhost
    system_mail Default Installation <noreply@mojomojo.org>

    for the mail config in mojomojo.conf
    hm, it seems that it works for you (and for me) because default config
    from MojoMojo::View::Email is helping you:

    http://github.com/marcusramberg/mojomojo/blob/master/lib/MojoMojo/View/Email.pm

    (sending from localhost)

    I'm not sure, but following the email plugin docs, the config should be
    diferent (as they need a diferent host):

    __PACKAGE__->config(
    'View::Email' => {
    sender => {
    mailer => 'SMTP',
    mailer_args => {
    host => '192.168.4.2'
    }
    }
    }
    );

    http://search.cpan.org/~dhoss/Catalyst-View-Email-0.20/lib/Catalyst/View/Email.pm#CONFIGURATION

    I didn't tested myself, but it looks reasonable to me. Please tell me if
    this make it work so I can update my config too :p

    -dk

    My configuration in mojomojo.conf includes

    email SMTP
    email 192.168.4.2

    MojoMojo is running on a webserver. In the shell on that webserver, I
    can:

    telnet 192.168.4.2 25

    and talk to the email server.

    With the above configuration, shouldn't MojoMojo be able to talk to the
    email server and send email? Or am I missing something?

    tcpdump reports no packets generated. Even when I set email to localhost,
    I
    see no local packets generated. this is not a firewall issue.

    debug reports:

    [debug] C::V::Email::Template uses default view
    MojoMojo::View::TT=HASH(0x4909768) for rendering.
    [debug] C::V::Email uses default content_type text/plain.
    [debug] Rendering template "mail/reset_password.tt"
    [debug] C::V::Email uses specified content_type text/plain.
    [debug] Rendering template "user/recover_pass.tt"
    [info] Request took 0.210454s (4.752/s)

    Is some other facility required to support email in MojoMojo?
    --
    View this message in context:
    http://n2.nabble.com/SMTP-mail-settings-tried-both-localhost-and-mailserver-in-mojomojo-conf-tp4468666p4468666.html
    Sent from the mojomojo mailing list archive at Nabble.com.

    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo


    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
  • Larry Marso at Jan 28, 2010 at 4:56 am
    Indeed, that does the trick. Thank you.

    Is there any input into mojomojo_local.conf that
    would reproduce this lower level configuration?

    Regards
    On Thu, Jan 28, 2010 at 01:46:02AM -0300, Diego Kuperman wrote:
    Hello!,
    On 1/27/10 10:33 PM, Mateu X. Hunter wrote:
    I have solid luck with postfix installed and:

    email SMTP
    email localhost
    system_mail Default Installation <noreply@mojomojo.org>

    for the mail config in mojomojo.conf
    hm, it seems that it works for you (and for me) because default config
    from MojoMojo::View::Email is helping you:

    http://github.com/marcusramberg/mojomojo/blob/master/lib/MojoMojo/View/Email.pm

    (sending from localhost)

    I'm not sure, but following the email plugin docs, the config should be
    diferent (as they need a diferent host):

    __PACKAGE__->config(
    'View::Email' => {
    sender => {
    mailer => 'SMTP',
    mailer_args => {
    host => '192.168.4.2'
    }
    }
    }
    );

    http://search.cpan.org/~dhoss/Catalyst-View-Email-0.20/lib/Catalyst/View/Email.pm#CONFIGURATION

    I didn't tested myself, but it looks reasonable to me. Please tell me if
    this make it work so I can update my config too :p

    -dk

    My configuration in mojomojo.conf includes

    email SMTP
    email 192.168.4.2

    MojoMojo is running on a webserver. In the shell on that webserver, I
    can:

    telnet 192.168.4.2 25

    and talk to the email server.

    With the above configuration, shouldn't MojoMojo be able to talk to the
    email server and send email? Or am I missing something?

    tcpdump reports no packets generated. Even when I set email to localhost,
    I
    see no local packets generated. this is not a firewall issue.

    debug reports:

    [debug] C::V::Email::Template uses default view
    MojoMojo::View::TT=HASH(0x4909768) for rendering.
    [debug] C::V::Email uses default content_type text/plain.
    [debug] Rendering template "mail/reset_password.tt"
    [debug] C::V::Email uses specified content_type text/plain.
    [debug] Rendering template "user/recover_pass.tt"
    [info] Request took 0.210454s (4.752/s)

    Is some other facility required to support email in MojoMojo?
    --
    View this message in context:
    http://n2.nabble.com/SMTP-mail-settings-tried-both-localhost-and-mailserver-in-mojomojo-conf-tp4468666p4468666.html
    Sent from the mojomojo mailing list archive at Nabble.com.

    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo


    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
  • Diego Kuperman at Jan 28, 2010 at 6:27 am

    On 1/28/10 1:56 AM, Larry Marso wrote:
    Indeed, that does the trick. Thank you.
    Excellent!
    Is there any input into mojomojo_local.conf that
    would reproduce this lower level configuration?
    hm, I think this will do it:

    <View::Email>
    <sender>
    mailer SMTP
    <mailer_args>
    host 192.168.4.2
    </mailer_args>
    </sender>
    </View::Email>

    I'm not sure as I'm more a yaml guy. If it work I'm not sure if there is
    a nicer way to write that, so: does it work for you?, does someone knows
    if there is a nicer way to write that?... I would like to update the
    default config on the repo to show that instead of the current buggy one ;)

    -dk
    Regards
    On Thu, Jan 28, 2010 at 01:46:02AM -0300, Diego Kuperman wrote:
    Hello!,
    On 1/27/10 10:33 PM, Mateu X. Hunter wrote:
    I have solid luck with postfix installed and:

    email SMTP
    email localhost
    system_mail Default Installation <noreply@mojomojo.org>

    for the mail config in mojomojo.conf
    hm, it seems that it works for you (and for me) because default config
    from MojoMojo::View::Email is helping you:

    http://github.com/marcusramberg/mojomojo/blob/master/lib/MojoMojo/View/Email.pm

    (sending from localhost)

    I'm not sure, but following the email plugin docs, the config should be
    diferent (as they need a diferent host):

    __PACKAGE__->config(
    'View::Email' => {
    sender => {
    mailer => 'SMTP',
    mailer_args => {
    host => '192.168.4.2'
    }
    }
    }
    );

    http://search.cpan.org/~dhoss/Catalyst-View-Email-0.20/lib/Catalyst/View/Email.pm#CONFIGURATION

    I didn't tested myself, but it looks reasonable to me. Please tell me if
    this make it work so I can update my config too :p

    -dk

    My configuration in mojomojo.conf includes

    email SMTP
    email 192.168.4.2

    MojoMojo is running on a webserver. In the shell on that webserver, I
    can:

    telnet 192.168.4.2 25

    and talk to the email server.

    With the above configuration, shouldn't MojoMojo be able to talk to the
    email server and send email? Or am I missing something?

    tcpdump reports no packets generated. Even when I set email to localhost,
    I
    see no local packets generated. this is not a firewall issue.

    debug reports:

    [debug] C::V::Email::Template uses default view
    MojoMojo::View::TT=HASH(0x4909768) for rendering.
    [debug] C::V::Email uses default content_type text/plain.
    [debug] Rendering template "mail/reset_password.tt"
    [debug] C::V::Email uses specified content_type text/plain.
    [debug] Rendering template "user/recover_pass.tt"
    [info] Request took 0.210454s (4.752/s)

    Is some other facility required to support email in MojoMojo?
    --
    View this message in context:
    http://n2.nabble.com/SMTP-mail-settings-tried-both-localhost-and-mailserver-in-mojomojo-conf-tp4468666p4468666.html
    Sent from the mojomojo mailing list archive at Nabble.com.

    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo


    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
  • Larry Marso at Jan 28, 2010 at 6:34 am
    I believe I've already tried exactly that. Didn't work.
    On Thu, Jan 28, 2010 at 03:27:41AM -0300, Diego Kuperman wrote:
    <View::Email>
    <sender>
    mailer SMTP
    <mailer_args>
    host 192.168.4.2
    </mailer_args>
    </sender>
    </View::Email>
  • Diego Kuperman at Jan 28, 2010 at 6:54 am

    On 1/28/10 3:34 AM, Larry Marso wrote:
    I believe I've already tried exactly that. Didn't work.
    On Thu, Jan 28, 2010 at 03:27:41AM -0300, Diego Kuperman wrote:
    <View::Email>
    <sender>
    mailer SMTP
    <mailer_args>
    host 192.168.4.2
    </mailer_args>
    </sender>
    </View::Email>
    Hm!, weird... I just tested using Config::General and it dumps just the
    same as before:

    $VAR1 = {
    'View::Email' => {
    'sender' => {
    'mailer' => 'SMTP',
    'mailer_args' => {
    'host' => '192.168.4.2'
    }
    }
    }
    };

    -dk
  • Diego Kuperman at Jan 28, 2010 at 9:23 pm
    Could you update Catalyst::View::Email to 0.21 (released today) and
    check again?

    -dk

    On 1/28/10 3:34 AM, Larry Marso wrote:
    I believe I've already tried exactly that. Didn't work.
    On Thu, Jan 28, 2010 at 03:27:41AM -0300, Diego Kuperman wrote:
    <View::Email>
    <sender>
    mailer SMTP
    <mailer_args>
    host 192.168.4.2
    </mailer_args>
    </sender>
    </View::Email>
    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
  • Larry Marso at Jan 30, 2010 at 12:34 am
    Sorry for the delay (traveling). I see that Catalyst::View::Email is
    up to 0.22 now.

    It works now, specifying an email server at another accessible machine
    (not localhost), using the specification in mojomojo_local.conf

    <View::Email>
    <sender>
    mailer SMTP
    <mailer_args>
    host 192.168.4.2
    </mailer_args>
    </sender>
    </View::Email>

    and commenting out the email and system_email lines with the defaults.

    Thank you so much.
    On Thu, Jan 28, 2010 at 1:23 PM, Diego Kuperman wrote:
    Could you update Catalyst::View::Email to 0.21 (released today) and
    check again?

    -dk

    On 1/28/10 3:34 AM, Larry Marso wrote:
    I believe I've already tried exactly that. ?Didn't work.
    On Thu, Jan 28, 2010 at 03:27:41AM -0300, Diego Kuperman wrote:
    <View::Email>
    ? ? <sender>
    ? ? ? ? mailer SMTP
    ? ? ? ? <mailer_args>
    ? ? ? ? ? ? host 192.168.4.2
    ? ? ? ? </mailer_args>
    ? ? </sender>
    </View::Email>
    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
  • Diego Kuperman at Jan 30, 2010 at 5:09 am

    On 1/29/10 9:34 PM, Larry Marso wrote:
    Sorry for the delay (traveling). I see that Catalyst::View::Email is
    up to 0.22 now.

    It works now, specifying an email server at another accessible machine
    (not localhost), using the specification in mojomojo_local.conf

    <View::Email>
    <sender>
    mailer SMTP
    <mailer_args>
    host 192.168.4.2
    </mailer_args>
    </sender>
    </View::Email>
    great!, I'll update the default conf on the repo to look like this (but
    using localhost).
    and commenting out the email and system_email lines with the defaults.
    Hm, you shouldn't comment out the system_email line, it's in use on the
    "From" header:

    http://github.com/marcusramberg/mojomojo/blob/84a030ce9f1f337b9a15c5fcd7f5feb0f667a7b6/lib/MojoMojo/Controller/User.pm#L194

    -dk
  • Mateu X. Hunter at Jan 28, 2010 at 6:27 pm

    Indeed, that does the trick. Thank you.

    Is there any input into mojomojo_local.conf that
    would reproduce this lower level configuration?
    You can put the same lines in mojomojo_local.conf to preserve it when
    upgrading mojomojo.

    - M
    Regards
    On Thu, Jan 28, 2010 at 01:46:02AM -0300, Diego Kuperman wrote:
    Hello!,
    On 1/27/10 10:33 PM, Mateu X. Hunter wrote:
    I have solid luck with postfix installed and:

    email SMTP
    email localhost
    system_mail Default Installation <noreply@mojomojo.org>

    for the mail config in mojomojo.conf
    hm, it seems that it works for you (and for me) because default config
    from MojoMojo::View::Email is helping you:

    http://github.com/marcusramberg/mojomojo/blob/master/lib/MojoMojo/View/Email.pm

    (sending from localhost)

    I'm not sure, but following the email plugin docs, the config should be
    diferent (as they need a diferent host):

    __PACKAGE__->config(
    'View::Email' => {
    sender => {
    mailer => 'SMTP',
    mailer_args => {
    host => '192.168.4.2'
    }
    }
    }
    );

    http://search.cpan.org/~dhoss/Catalyst-View-Email-0.20/lib/Catalyst/View/Email.pm#CONFIGURATION

    I didn't tested myself, but it looks reasonable to me. Please tell me if
    this make it work so I can update my config too :p

    -dk

    My configuration in mojomojo.conf includes

    email SMTP
    email 192.168.4.2

    MojoMojo is running on a webserver. In the shell on that webserver,
    I
    can:

    telnet 192.168.4.2 25

    and talk to the email server.

    With the above configuration, shouldn't MojoMojo be able to talk to
    the
    email server and send email? Or am I missing something?

    tcpdump reports no packets generated. Even when I set email to
    localhost,
    I
    see no local packets generated. this is not a firewall issue.

    debug reports:

    [debug] C::V::Email::Template uses default view
    MojoMojo::View::TT=HASH(0x4909768) for rendering.
    [debug] C::V::Email uses default content_type text/plain.
    [debug] Rendering template "mail/reset_password.tt"
    [debug] C::V::Email uses specified content_type text/plain.
    [debug] Rendering template "user/recover_pass.tt"
    [info] Request took 0.210454s (4.752/s)

    Is some other facility required to support email in MojoMojo?
    --
    View this message in context:
    http://n2.nabble.com/SMTP-mail-settings-tried-both-localhost-and-mailserver-in-mojomojo-conf-tp4468666p4468666.html
    Sent from the mojomojo mailing list archive at Nabble.com.

    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo


    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo
    _______________________________________________
    Mojomojo mailing list
    Mojomojo@lists.scsys.co.uk
    http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/mojomojo

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupmojomojo @
postedJan 27, '10 at 5:40p
activeJan 30, '10 at 5:09a
posts13
users4
websitemojomojo.org

People

Translate

site design / logo © 2017 Grokbase