Hello! Having the next problem, maybe somebody has issued that.
I'm trying to use the next function:
http://php.net/manual/ru/amqpconnection.settimeout.php
but nothing changes. Timeout isn't working. Thereby there's no way to avoid
hanging up the site when trying to send message to rabbitMQ...
Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130618/b7411b3a/attachment.htm>

Search Discussions

  • Alvaro Videla at Jun 27, 2013 at 7:40 am
    Hi,


    I've never used this library. Maybe there's a bug there. Have you tried
    contacted the library authors?


    In any case, there's also http://github.com/videlalvaro/php-amqplib which
    supports timeouts on the "wait" method:
    https://github.com/videlalvaro/php-amqplib/blob/master/PhpAmqpLib/Channel/AbstractChannel.php#L174


    Regards,


    Alvaro






    On Wed, Jun 19, 2013 at 8:40 AM, Iliya Isd wrote:

    Hello! Having the next problem, maybe somebody has issued that.
    I'm trying to use the next function:
    http://php.net/manual/ru/amqpconnection.settimeout.php
    but nothing changes. Timeout isn't working. Thereby there's no way to
    avoid hanging up the site when trying to send message to rabbitMQ...
    Any ideas?

    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130627/b21a7ad1/attachment.htm>
  • Umutcan at Jun 27, 2013 at 8:27 am
    Hi,


    There is setTimeout(),setReadTimeout(),setWriteTimeout(). setTimeout is
    deprecated in the latest version.


    These timeouts does not work if you are having problems in connection
    time. They all works after client is connected. There is an issue about
    this: https://github.com/pdezwart/php-amqp/issues/63


    Regards,
    Umutcan
    On 06/27/2013 10:40 AM, Alvaro Videla wrote:
    Hi,

    I've never used this library. Maybe there's a bug there. Have you
    tried contacted the library authors?

    In any case, there's also http://github.com/videlalvaro/php-amqplib
    which supports timeouts on the "wait" method:
    https://github.com/videlalvaro/php-amqplib/blob/master/PhpAmqpLib/Channel/AbstractChannel.php#L174

    Regards,

    Alvaro



    On Wed, Jun 19, 2013 at 8:40 AM, Iliya Isd <iliyaisd at gmail.com
    wrote:

    Hello! Having the next problem, maybe somebody has issued that.
    I'm trying to use the next function:
    http://php.net/manual/ru/amqpconnection.settimeout.php
    but nothing changes. Timeout isn't working. Thereby there's no way
    to avoid hanging up the site when trying to send message to
    rabbitMQ...
    Any ideas?

    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130627/2eec5400/attachment.htm>
  • Amol Kedar at Jul 16, 2013 at 10:10 pm
    hi i am trying http://github.com/videlalvaro/php-amqplib


    and it keeps giving me errors
    $ php amqp_consumer.php
    PHP Fatal error: Class 'PhpAmqpLib\Connection\AMQPConnection' not found in
    /php-amqplib/demo/amqp_consumer.php on line 10


    this is on ubuntu 10.04 and PHP 5.3.10-1ubuntu3
    any clue?

    On Thursday, June 27, 2013 3:40:07 AM UTC-4, Alvaro Videla wrote:

    Hi,

    I've never used this library. Maybe there's a bug there. Have you tried
    contacted the library authors?

    In any case, there's also http://github.com/videlalvaro/php-amqplib which
    supports timeouts on the "wait" method:
    https://github.com/videlalvaro/php-amqplib/blob/master/PhpAmqpLib/Channel/AbstractChannel.php#L174

    Regards,

    Alvaro



    On Wed, Jun 19, 2013 at 8:40 AM, Iliya Isd <iliy... at gmail.com<javascript:>
    wrote:
    Hello! Having the next problem, maybe somebody has issued that.
    I'm trying to use the next function:
    http://php.net/manual/ru/amqpconnection.settimeout.php
    but nothing changes. Timeout isn't working. Thereby there's no way to
    avoid hanging up the site when trying to send message to rabbitMQ...
    Any ideas?

    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq... at lists.rabbitmq.com <javascript:>
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130716/74e9d61b/attachment.htm>
  • Michael Klishin at Jul 17, 2013 at 6:46 pm

    Amol Kedar:


    PHP Fatal error: Class 'PhpAmqpLib\Connection\AMQPConnection' not found in /php-amqplib/demo/amqp_consumer.php on line 10

    this is on ubuntu 10.04 and PHP 5.3.10-1ubuntu3
    any clue?

    If AMQPConnection cannot be found, it suggests you have a classpath
    issue. Are you sure that the RabbitMQ client dependency is on classpath?


    Also, I'd start a new thread for your question.
    --
    MK


    -------------- next part --------------
    A non-text attachment was scrubbed...
    Name: signature.asc
    Type: application/pgp-signature
    Size: 495 bytes
    Desc: Message signed with OpenPGP using GPGMail
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130717/f5ae57c4/attachment.pgp>
  • Alvaro Videla at Jul 17, 2013 at 10:29 pm
    You need to make sure your autoload.php setupt correctly for the library.
    If you use composer.php that's done automatically for you. After that you
    need to make sure you "use" the namespace.




    On Wed, Jul 17, 2013 at 8:46 PM, Michael Klishin wrote:

    Amol Kedar:
    PHP Fatal error: Class 'PhpAmqpLib\Connection\AMQPConnection' not found
    in /php-amqplib/demo/amqp_consumer.php on line 10
    this is on ubuntu 10.04 and PHP 5.3.10-1ubuntu3
    any clue?
    If AMQPConnection cannot be found, it suggests you have a classpath
    issue. Are you sure that the RabbitMQ client dependency is on classpath?

    Also, I'd start a new thread for your question.
    --
    MK


    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130718/f9a05c4e/attachment.htm>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprabbitmq-discuss @
categoriesrabbitmq
postedJun 19, '13 at 6:40a
activeJul 17, '13 at 10:29p
posts6
users5
websiterabbitmq.com
irc#rabbitmq

People

Translate

site design / logo © 2017 Grokbase