Hi, I'm sorry I can't say what version I'm running because the server is
down.


All I did from the Admin site home page is export the settings for the
RabbitMQ and now I can't log in anymore.


Got response code 500 with body
Internal Server ErrorThe server encountered an error while processing this
request:


{error,{case_clause,{{[],false},2}},
[{base64,strip_illegal,3},
{base64,mime_decode_l,1},
{rabbit_mochiweb_util,parse_auth_header,1},
{rabbit_mgmt_util,is_authorized,3},
{webmachine_resource,resource_call,3},
{webmachine_resource,do,3},
{webmachine_decision_core,resource_call,1},
{webmachine_decision_core,decision,1}]}






Anyone have this issue?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130401/477a9c8f/attachment.htm>

Search Discussions

  • Tim Watson at Apr 2, 2013 at 11:20 am
    Have you tried disabling and then re-enabling the management plugin?


    On 2 Apr 2013, at 06:55, Sean Shannon wrote:

    Hi, I'm sorry I can't say what version I'm running because the server is down.

    All I did from the Admin site home page is export the settings for the RabbitMQ and now I can't log in anymore.

    Got response code 500 with body

    Internal Server Error

    The server encountered an error while processing this request:
    {error,{case_clause,{{[],false},2}},
    [{base64,strip_illegal,3},
    {base64,mime_decode_l,1},
    {rabbit_mochiweb_util,parse_auth_header,1},
    {rabbit_mgmt_util,is_authorized,3},
    {webmachine_resource,resource_call,3},
    {webmachine_resource,do,3},
    {webmachine_decision_core,resource_call,1},
    {webmachine_decision_core,decision,1}]}


    Anyone have this issue?
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130402/3ff6a270/attachment.htm>
  • Tim Watson at Apr 2, 2013 at 11:42 am
    Do you get asked for auth details when downloading the exported data? I do, although I don't get this crash afterwards.


    On 2 Apr 2013, at 12:20, Tim Watson wrote:

    Have you tried disabling and then re-enabling the management plugin?
    On 2 Apr 2013, at 06:55, Sean Shannon wrote:

    Hi, I'm sorry I can't say what version I'm running because the server is down.

    All I did from the Admin site home page is export the settings for the RabbitMQ and now I can't log in anymore.

    Got response code 500 with body

    Internal Server Error

    The server encountered an error while processing this request:
    {error,{case_clause,{{[],false},2}},
    [{base64,strip_illegal,3},
    {base64,mime_decode_l,1},
    {rabbit_mochiweb_util,parse_auth_header,1},
    {rabbit_mgmt_util,is_authorized,3},
    {webmachine_resource,resource_call,3},
    {webmachine_resource,do,3},
    {webmachine_decision_core,resource_call,1},
    {webmachine_decision_core,decision,1}]}


    Anyone have this issue?
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130402/282c6a0d/attachment.htm>
  • Tim Watson at Apr 2, 2013 at 11:58 am
    Oh and you should be able to run 'rabbitmqctl status' to tell us the version number you're running.


    Cheers
    Tim


    On 2 Apr 2013, at 12:42, Tim Watson wrote:

    Do you get asked for auth details when downloading the exported data? I do, although I don't get this crash afterwards.
    On 2 Apr 2013, at 12:20, Tim Watson wrote:

    Have you tried disabling and then re-enabling the management plugin?
    On 2 Apr 2013, at 06:55, Sean Shannon wrote:

    Hi, I'm sorry I can't say what version I'm running because the server is down.

    All I did from the Admin site home page is export the settings for the RabbitMQ and now I can't log in anymore.

    Got response code 500 with body

    Internal Server Error

    The server encountered an error while processing this request:
    {error,{case_clause,{{[],false},2}},
    [{base64,strip_illegal,3},
    {base64,mime_decode_l,1},
    {rabbit_mochiweb_util,parse_auth_header,1},
    {rabbit_mgmt_util,is_authorized,3},
    {webmachine_resource,resource_call,3},
    {webmachine_resource,do,3},
    {webmachine_decision_core,resource_call,1},
    {webmachine_decision_core,decision,1}]}


    Anyone have this issue?
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130402/39e7dc87/attachment.htm>
  • Sean Shannon at Apr 5, 2013 at 4:49 pm
    Amazingly, the service started working again on its own. Another post
    suggests that it was an issue with my client (browser) and not the admin
    portal.


    I am running RabbitMQ 3.0.0, Erlang R14B04


    Thanks!

    On Tuesday, April 2, 2013 4:58:16 AM UTC-7, hyperthunk wrote:

    Oh and you should be able to run 'rabbitmqctl status' to tell us the
    version number you're running.

    Cheers
    Tim

    On 2 Apr 2013, at 12:42, Tim Watson <watson.... at gmail.com <javascript:>>
    wrote:

    Do you get asked for auth details when downloading the exported data? I
    do, although I don't get this crash afterwards.

    On 2 Apr 2013, at 12:20, Tim Watson <watson.... at gmail.com <javascript:>>
    wrote:

    Have you tried disabling and then re-enabling the management plugin?

    On 2 Apr 2013, at 06:55, Sean Shannon <sean... at gmail.com <javascript:>>
    wrote:

    Hi, I'm sorry I can't say what version I'm running because the server is
    down.

    All I did from the Admin site home page is export the settings for the
    RabbitMQ and now I can't log in anymore.

    Got response code 500 with body
    Internal Server ErrorThe server encountered an error while processing
    this request:

    {error,{case_clause,{{[],false},2}},
    [{base64,strip_illegal,3},
    {base64,mime_decode_l,1},
    {rabbit_mochiweb_util,parse_auth_header,1},
    {rabbit_mgmt_util,is_authorized,3},
    {webmachine_resource,resource_call,3},
    {webmachine_resource,do,3},
    {webmachine_decision_core,resource_call,1},
    {webmachine_decision_core,decision,1}]}



    Anyone have this issue?

    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq... at lists.rabbitmq.com <javascript:>
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq... at lists.rabbitmq.com <javascript:>
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq... at lists.rabbitmq.com <javascript:>
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130405/e5afd379/attachment.htm>
  • Sean Shannon at Apr 2, 2013 at 1:05 pm
    Yes.

    On Tuesday, April 2, 2013 4:42:39 AM UTC-7, hyperthunk wrote:

    Do you get asked for auth details when downloading the exported data? I
    do, although I don't get this crash afterwards.

    On 2 Apr 2013, at 12:20, Tim Watson <watson.... at gmail.com <javascript:>>
    wrote:

    Have you tried disabling and then re-enabling the management plugin?

    On 2 Apr 2013, at 06:55, Sean Shannon <sean... at gmail.com <javascript:>>
    wrote:

    Hi, I'm sorry I can't say what version I'm running because the server is
    down.

    All I did from the Admin site home page is export the settings for the
    RabbitMQ and now I can't log in anymore.

    Got response code 500 with body
    Internal Server ErrorThe server encountered an error while processing
    this request:

    {error,{case_clause,{{[],false},2}},
    [{base64,strip_illegal,3},
    {base64,mime_decode_l,1},
    {rabbit_mochiweb_util,parse_auth_header,1},
    {rabbit_mgmt_util,is_authorized,3},
    {webmachine_resource,resource_call,3},
    {webmachine_resource,do,3},
    {webmachine_decision_core,resource_call,1},
    {webmachine_decision_core,decision,1}]}



    Anyone have this issue?

    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq... at lists.rabbitmq.com <javascript:>
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq... at lists.rabbitmq.com <javascript:>
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130402/452d5271/attachment.htm>
  • Tim Watson at Apr 2, 2013 at 1:14 pm
    I see you're using an old version of Rabbit (as we're now using rabbitmq-web-dispatch as the web server dependency). Can you run `rabbitmqctl status` to get the version info please?


    On 2 Apr 2013, at 14:05, Sean Shannon wrote:

    Yes.

    On Tuesday, April 2, 2013 4:42:39 AM UTC-7, hyperthunk wrote:
    Do you get asked for auth details when downloading the exported data? I do, although I don't get this crash afterwards.
    On 2 Apr 2013, at 12:20, Tim Watson wrote:

    Have you tried disabling and then re-enabling the management plugin?
    On 2 Apr 2013, at 06:55, Sean Shannon wrote:

    Hi, I'm sorry I can't say what version I'm running because the server is down.

    All I did from the Admin site home page is export the settings for the RabbitMQ and now I can't log in anymore.

    Got response code 500 with body

    Internal Server Error

    The server encountered an error while processing this request:
    {error,{case_clause,{{[],false},2}},
    [{base64,strip_illegal,3},
    {base64,mime_decode_l,1},
    {rabbit_mochiweb_util,parse_auth_header,1},
    {rabbit_mgmt_util,is_authorized,3},
    {webmachine_resource,resource_call,3},
    {webmachine_resource,do,3},
    {webmachine_decision_core,resource_call,1},
    {webmachine_decision_core,decision,1}]}


    Anyone have this issue?
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq... at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq... at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss
    _______________________________________________
    rabbitmq-discuss mailing list
    rabbitmq-discuss at lists.rabbitmq.com
    https://lists.rabbitmq.com/cgi-bin/mailman/listinfo/rabbitmq-discuss

    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130402/7591d3ea/attachment.htm>
  • Simon MacMullen at Apr 5, 2013 at 10:57 am

    On 02/04/13 06:55, Sean Shannon wrote:
    {error,{case_clause,{{[],false},2}},
    [{base64,strip_illegal,3},
    {base64,mime_decode_l,1},
    {rabbit_mochiweb_util,parse_auth_header,1},
    {rabbit_mgmt_util,is_authorized,3},
    {webmachine_resource,resource_call,3},
    {webmachine_resource,do,3},
    {webmachine_decision_core,resource_call,1},
    {webmachine_decision_core,decision,1}]}

    Hmm. That looks like the HTTP basic auth is not valid base64.


    I would expect you should be able to fix this by either closing and
    reopening your browser (if using RabbitMQ 2.x) or by logging out and
    then in again (if using 3.x).


    After you've done that, can you tell me if you're using 2.x or 3.x?
    Since the origin of the HTTP basic auth is quite different in the two cases.


    Cheers, Simon


    --
    Simon MacMullen
    RabbitMQ, VMware
  • Sean Shannon at Apr 5, 2013 at 4:50 pm
    It somehow fixed itself, probably because of what you suggest. This is the
    version we are running: RabbitMQ 3.0.0, Erlang R14B04




    On Fri, Apr 5, 2013 at 3:57 AM, Simon MacMullen wrote:

    On 02/04/13 06:55, Sean Shannon wrote:

    {error,{case_clause,{{[],**false},2}},
    [{base64,strip_illegal,3},
    {base64,mime_decode_l,1},
    {rabbit_mochiweb_util,parse_**auth_header,1},
    {rabbit_mgmt_util,is_**authorized,3},
    {webmachine_resource,resource_**call,3},
    {webmachine_resource,do,3},
    {webmachine_decision_core,**resource_call,1},
    {webmachine_decision_core,**decision,1}]}
    Hmm. That looks like the HTTP basic auth is not valid base64.

    I would expect you should be able to fix this by either closing and
    reopening your browser (if using RabbitMQ 2.x) or by logging out and then
    in again (if using 3.x).

    After you've done that, can you tell me if you're using 2.x or 3.x? Since
    the origin of the HTTP basic auth is quite different in the two cases.

    Cheers, Simon

    --
    Simon MacMullen
    RabbitMQ, VMware





    --
    -Sean
    -------------- next part --------------
    An HTML attachment was scrubbed...
    URL: <http://lists.rabbitmq.com/pipermail/rabbitmq-discuss/attachments/20130405/56c7a847/attachment.htm>

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprabbitmq-discuss @
categoriesrabbitmq
postedApr 2, '13 at 5:55a
activeApr 5, '13 at 4:50p
posts9
users4
websiterabbitmq.com
irc#rabbitmq

People

Translate

site design / logo © 2017 Grokbase